所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态DNS Client示例

配置动态DNS Client示例

本举例介绍动态DNS域名解析的配置过程。

组网需求

图6-3所示,DeviceA作为DNS Client端和DNS Server配合,使得DeviceA通过域名(huawei.com)能够访问IP地址为10.2.1.3/16的主机,配置域名后缀com和net。

图6-3 配置动态DNS组网图
说明:

本例中interface1,interface2分别代表GE0/1/0,GE0/1/1



配置思路

动态DNS的配置思路如下:

  1. 使能DNS域名解析功能

  2. 配置DNS服务器的IP地址

  3. 配置域名后缀

数据准备

为完成此配置举例,需要准备如下数据:

  • DeviceB和DeviceC的域名名称

  • DNS服务器的IP地址

  • 域名后缀

操作步骤

  1. 配置DeviceA

    # 配置动态DNS表项。

    <HUAWEI> system-view
    [~HUAWEI]sysname DeviceA
    [*HUAWEI]commit

    # 使能DNS域名解析功能。

    [~DeviceA] dns resolve

    # 配置DNS Server的IP地址。

    [*DeviceA] dns server 10.3.1.2

    # 配置域名后缀net。

    [*DeviceA] dns domain net

    # 配置域名后缀com。

    [*DeviceA] dns domain com
    [*DeviceA] commit
    [~DeviceA] quit
    说明:

    若要完成对域名的解析,还需要配置DeviceA至DNS Server的路由。路由的配置方法请参看《NE20E 综合业务承载路由器 配置指南-IP路由配置》。

  2. 验证配置结果

    # 在DeviceA上执行ping huawei命令,可以ping通,且对应的目的地址为10.2.1.3。

    <DeviceA> ping huawei.com
      PING huawei.com (10.2.1.3): 56  data bytes, press CTRL_C to break
        Reply from 10.2.1.3: bytes=56 Sequence=1 ttl=126 time=6 ms
        Reply from 10.2.1.3: bytes=56 Sequence=2 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=3 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=4 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=5 ttl=126 time=4 ms
      --- huawei.com ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 4/4/6 ms
    

    # 在DeviceA用display dns dynamic-host命令可以查看到动态缓存区中的动态DNS表项信息。

    <DeviceA> display dns dynamic-host
    No  Domain Name           IpAddress            TTL      Alias
    1   huawei.com            10.2.1.3             3579  
    说明:

    显示信息中的TTL表示该表项存在的时间,单位是秒。

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
     dns resolve
     dns server 10.3.1.2
     dns domain net
     dns domain com
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.0.0
    #
    rip 1
     network 10.1.0.0
    #
    return
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.2.1.1 255.255.0.0
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 10.1.1.2 255.255.0.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    rip 1
     network 10.1.0.0
     network 10.2.0.0
     network 1.0.0.0
    #
    return
  • DeviceC的配置文件

    #
     sysname DeviceC
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.2.1.2 255.255.0.0
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 10.3.1.1 255.255.0.0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    rip 1
     network 10.2.0.0
     network 10.3.0.0
     network 2.0.0.0
    #
    return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1548

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页