所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DHCP Relay示例

配置DHCP Relay示例

本举例介绍了DHCP Relay的配置过程。该配置举例在运营商IP设备上可用。

组网需求

图4-7所示,DHCP客户端所在网段为10.100.0.0/16,而DHCP服务器所在的网段为172.16.0.0/16。需要通过带DHCP Relay功能的设备中继转发DHCP报文,使得DHCP客户端可以向DHCP服务器申请到IP地址等相关配置信息。

DHCP客户端所在网段为10.100.0.0/16。DNS服务器的IP地址为10.100.1.2/16,NetBIOS服务器的IP地址为10.100.1.3/16,网关的IP地址为10.100.1.1。在DHCP服务器上,路由表中至少包含一条到网段10.100.0.0的可达路由。

图4-7 配置DHCP Relay组网图
说明:

本例中interface1,interface2分别代表GE0/1/0,GE0/2/0



配置思路

配置DHCP Relay的思路如下:

  1. 配置DHCP Relay。
    1. 配置接口GigabitEthernet0/2/0上IP地址。
    2. 在接口GE0/1/0上配置DHCP服务器的地址,并且使能DHCP中继功能。
  2. 配置DHCP Server。
    1. 配置从DHCP服务器到DHCP Relay的接口GE0/1/0的路由。
    2. 配置接口GigabitEthernet0/1/0的IP地址。
    3. 配置DNS服务器,NetBIOS服务器和出口网关地址。
    4. 在DHCP Server上配置地址池。

数据准备

为完成此配置举例,需准备如下的数据:

  • 启动DHCP Relay功能的接口编号及接口的IP地址

  • DHCP Server的IP地址

操作步骤

  1. 配置DHCP Relay

    # 配置接口GigabitEthernet0/2/0的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface GigabitEthernet 0/2/0
    [~DeviceA-GigabitEthernet0/2/0] ip address 172.16.1.1 255.255.0.0
    [*DeviceA-GigabitEthernet0/2/0] undo shutdown
    [*DeviceA-GigabitEthernet0/2/0] commit
    [~DeviceA-GigabitEthernet0/2/0] quit

    # 在接口GE0/1/0上配置DHCP服务器的地址,并且使能DHCP中继功能。

    [~DeviceA] dhcp enable
    [~DeviceA] interface gigabitethernet 0/1/0
    [*DeviceA-GigabitEthernet0/1/0] ip address 10.100.1.1 255.255.0.0
    [*DeviceA-GigabitEthernet0/1/0] ip relay address 172.16.1.2
    [*DeviceA-GigabitEthernet0/1/0] ip relay giaddr 10.100.20.1
    [*DeviceA-GigabitEthernet0/1/0] dhcp select relay
    [*DeviceA-GigabitEthernet0/1/0] undo shutdown
    [*DeviceA-GigabitEthernet0/1/0] commit
    [~DeviceA-GigabitEthernet0/1/0] quit

  2. 配置DHCP Server

    具体配置过程略。DHCP Server需要满足以下条件:

    • 在DHCP Server上配置地址池,分配地址池范围。
    • 配置域名,DNS服务器、NetBIOS服务器和出口网关的地址。
    • 建议配置地址池租期,提高IP地址的使用效率。

  3. 验证配置结果

    在DHCP Relay设备上执行display dhcp relay address命令,如果能够查看到服务器地址,则说明配置成功。

    [~DeviceA] display dhcp relay address all
       ** GigabitEthernet0/1/0 DHCP Relay Address  **
              Dhcp Option          Relay Agent IP       Server IP
              *                    10.100.20.1          172.16.1.2

配置文件

  • DHCP Relay配置文件

    #
    sysname DeviceA
    #
    dhcp enable
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.100.1.1 255.255.0.0
     dhcp select relay
     ip relay address 172.16.1.2
     ip relay giaddr 10.100.20.1
    #
    interface GigabitEthernet 0/2/0
     undo shutdown
     ip address 172.16.1.1 255.255.0.0
    #
    return 
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1595

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页