所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置接口借用IP地址示例

配置接口借用IP地址示例

本举例介绍接口借用IP地址的配置过程。

组网需求

图9-6所示,一家企业通过ISDN组建内部网,有2个节点:DeviceA、DeviceB。每个节点路由设备分别通过以太网接口连接本地的局域网,通过拨号端口与对端节点相连。各路由设备与以太网连接的接口均为GE0/1/0,与ISDN连接的接口均为GigabitEthernet0/2/0。为了节省IP地址,规划拨号口借用以太网接口的IP地址。

图9-6 配置接口借用IP地址组网图
说明:

本例中interface1,interface2分别代表GE0/1/0,GE0/2/0



配置注意事项

配置思路

配置接口借用IP地址的思路如下:

  1. 配置被借用接口的IP地址

  2. 配置接口借用其他接口的IP地址

数据准备

为完成此配置例,需准备如下的数据:

  • 被借用接口的IP地址

  • 被借用接口的编号

操作步骤

  1. 配置路由设备DeviceA

    # 配置接口GE0/1/0的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ip address 172.16.10.1 255.255.255.0
    [*DeviceA-GigabitEthernet0/1/0] undo shutdown
    [*DeviceA-GigabitEthernet0/1/0] quit

    # 配置GigabitEthernet口借用以太网接口的IP地址。

    [*DeviceA] interface GigabitEthernet 0/2/0
    [*DeviceA-GigabitEthernet0/2/0] ip address unnumbered interface gigabitethernet 0/1/0
    [*DeviceA-GigabitEthernet0/2/0] undo shutdown
    [*DeviceA-GigabitEthernet0/2/0] quit

  2. 配置路由设备DeviceB

    # 配置接口GE0/1/0的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] ip address 172.16.20.1 255.255.255.0
    [*DeviceB-GigabitEthernet0/1/0] undo shutdown
    [*DeviceB-GigabitEthernet0/1/0] quit

    # 配置GigabitEthernet口借用以太网接口的IP地址。

    [*DeviceB] interface GigabitEthernet 0/2/0
    [*DeviceB-GigabitEthernet0/2/0] ip address unnumbered interface gigabitethernet 0/1/0
    [*DeviceB-GigabitEthernet0/2/0] undo shutdown
    [*DeviceB-GigabitEthernet0/2/0] quit

    # 配置到路由设备DeviceB的以太网网段的路由。

    [*DeviceA] ip route-static 172.16.20.0 255.255.255.0 GigabitEthernet 0/2/0
    [*DeviceA] commit

  3. 验证配置结果

    # 在路由设备DeviceA上可以ping通与路由设备DeviceB相连的IP地址。

    [~DeviceA] ping 172.16.20.1
      PING 172.16.20.2: 56  data bytes, press CTRL_C to break
        Reply from 172.16.20.2: bytes=56 Sequence=1 ttl=255 time=25 ms
        Reply from 172.16.20.2: bytes=56 Sequence=2 ttl=255 time=25 ms
        Reply from 172.16.20.2: bytes=56 Sequence=3 ttl=255 time=26 ms
        Reply from 172.16.20.2: bytes=56 Sequence=4 ttl=255 time=26 ms
        Reply from 172.16.20.2: bytes=56 Sequence=5 ttl=255 time=26 ms
      --- 172.16.20.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 25/25/26 ms

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.10.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address unnumbered interface GigabitEthernet0/1/0
    #
    ip route-static 172.16.20.0 255.255.255.0 GigabitEthernet0/2/0
    #
    return
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.20.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address unnumbered interface GigabitEthernet0/1/0
    #
    ip route-static 172.16.10.0 255.255.255.0 GigabitEthernet0/2/0
    #
    return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1463

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页