所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN间ARP代理示例

配置VLAN间ARP代理示例

本示例组网的特点是需要互通的设备处于不同的VLAN,可以通过配置VLAN间的ARP代理功能,实现不同VLAN内的设备间的互通。

组网需求

某公司拥有多个部门且位于同一网段,为了提升业务安全性,同一部门的员工划分到同一个VLAN中,不同部门的员工划分到不同VLAN中。现由于业务需要,不同部门间的员工需要互通。

图2-9所示,研发部和测试部分布在不同的VLAN中,现需要实现不同VLAN间的员工可以互相访问。

图2-9 配置VLAN间ARP代理组网图
说明:

本例中interface1,interface2,interface3分别代表GE0/1/1,GE0/1/2,GE0/1/3



由于研发部和测试部门位于同一网段,可以在连接研发部门和测试部门的设备上部署VLAN间ARP代理功能,实现不同VLAN内的用户间的互通。

配置思路

采用如下思路配置VLAN间ARP代理:

  1. 在CE上创建VLAN,确定用户所属的VLAN。
  2. 在PE上配置VLAN聚合。

    1. 配置二层转发功能。

    2. 创建Super-VLAN,并把Sub-VLAN加入Super-VLAN。

    3. 创建Super-VLAN对应的VLANIF接口,并配置IP地址,作为网关地址。

  3. 使能VLAN间ARP代理功能,实现Sub-VLAN之间的互通。

数据准备

为完成此配置例,需准备如下的数据:

  • 不同VLAN内用户的IP地址。
  • 组网中相关设备的接口编号。
  • Sub-VLAN ID、Super-VLAN ID。
  • Super-VLAN对应的VLANIF接口编号及IP地址。

操作步骤

  1. 在CE上创建VLAN,并将二层端口加入VLAN

    # 配置CE1。

    <HUAWEI> system-view
    [~HUAWEI] sysname CE1
    [*HUAWEI] commit
    [~CE1] vlan batch 2
    [*CE1] commit
    [~CE1] interface gigabitethernet 0/1/1
    [~CE1-GigabitEthernet0/1/1] portswitch
    [*CE1-GigabitEthernet0/1/1] undo shutdown
    [*CE1-GigabitEthernet0/1/1] port link-type access
    [*CE1-GigabitEthernet0/1/1] port default vlan 2
    [*CE1-GigabitEthernet0/1/1] commit
    [~CE1-GigabitEthernet0/1/1] quit
    [~CE1] interface gigabitethernet 0/1/2
    [~CE1-GigabitEthernet0/1/2] portswitch
    [*CE1-GigabitEthernet0/1/2] undo shutdown
    [*CE1-GigabitEthernet0/1/2] port link-type access
    [*CE1-GigabitEthernet0/1/2] port default vlan 2
    [*CE1-GigabitEthernet0/1/2] commit
    [~CE1-GigabitEthernet0/1/2] quit
    [~CE1] interface gigabitethernet 0/1/3
    [~CE1-GigabitEthernet0/1/3] portswitch
    [*CE1-GigabitEthernet0/1/3] undo shutdown
    [*CE1-GigabitEthernet0/1/3] port link-type access
    [*CE1-GigabitEthernet0/1/3] port default vlan 2
    [*CE1-GigabitEthernet0/1/3] commit
    [~CE1-GigabitEthernet0/1/3] quit

    # 配置CE2。

    <HUAWEI> system-view
    [~HUAWEI] sysname CE2
    [*HUAWEI] commit
    [~CE2] vlan batch 3
    [*CE2] commit
    [~CE2] interface gigabitethernet 0/1/1
    [~CE2-GigabitEthernet0/1/1] portswitch
    [*CE2-GigabitEthernet0/1/1] undo shutdown
    [*CE2-GigabitEthernet0/1/1] port link-type access
    [*CE2-GigabitEthernet0/1/1] port default vlan 3
    [*CE2-GigabitEthernet0/1/1] commit
    [~CE2-GigabitEthernet0/1/1] quit
    [~CE2] interface gigabitethernet 0/1/2
    [~CE2-GigabitEthernet0/1/2] portswitch
    [*CE2-GigabitEthernet0/1/2] undo shutdown
    [*CE2-GigabitEthernet0/1/2] port link-type access
    [*CE2-GigabitEthernet0/1/2] port default vlan 3
    [*CE2-GigabitEthernet0/1/2] commit
    [~CE2-GigabitEthernet0/1/2] quit
    [~CE2] interface gigabitethernet 0/1/3
    [~CE2-GigabitEthernet0/1/3] portswitch
    [*CE2-GigabitEthernet0/1/3] undo shutdown
    [*CE2-GigabitEthernet0/1/3] port link-type access
    [*CE2-GigabitEthernet0/1/3] port default vlan 3
    [*CE2-GigabitEthernet0/1/3] commit
    [~CE2-GigabitEthernet0/1/3] quit

  2. 在PE上配置VLAN聚合

    1. 配置二层转发功能。

      <HUAWEI> system-view
      [~HUAWEI] sysname PE
      [*HUAWEI] commit
      [~PE] vlan batch 2 to 4
      [*PE] commit
      [~PE] interface gigabitethernet 0/1/1
      [~PE-GigabitEthernet0/1/1] portswitch
      [*PE-GigabitEthernet0/1/1] undo shutdown
      [*PE-GigabitEthernet0/1/1] port link-type trunk
      [*PE-GigabitEthernet0/1/1] port trunk allow-pass vlan 2
      [*PE-GigabitEthernet0/1/1] commit
      [~PE-GigabitEthernet0/1/1] quit
      [~PE] interface gigabitethernet 0/1/2
      [~PE-GigabitEthernet0/1/2] portswitch
      [*PE-GigabitEthernet0/1/2] undo shutdown
      [*PE-GigabitEthernet0/1/2] port link-type trunk
      [*PE-GigabitEthernet0/1/2] port trunk allow-pass vlan 3
      [*PE-GigabitEthernet0/1/2] commit
      [~PE-GigabitEthernet0/1/2] quit
    2. 创建Super-VLAN,并将Sub-VLAN加入Super-VLAN。

      [~PE] vlan 4
      [*PE-vlan4] aggregate-vlan
      [*PE-vlan4] access-vlan 2 to 3
      [*PE-vlan4] commit
      [~PE-vlan4] quit
    3. 创建Super-VLAN对应的VLANIF接口,并配置IP地址。

      [~PE] interface vlanif 4
      [*PE-vlanif4] ip address 10.1.1.12 24
      [*PE-vlanif4] commit

      上述配置完成后,按图2-9所示的IP地址分别为各PC配置IP地址,PC的IP地址和VLANIF接口的IP地址处于同一网段。

      配置成功后,各VLAN中的员工与交换机之间可以相互Ping通,但VLAN2中的员工与VLAN3中的员工不能相互Ping通。

  3. 使能VLAN间ARP代理功能

    [~PE-vlanif4] arp-proxy inter-sub-vlan-proxy enable
    [*PE-vlanif4] commit
    [~PE-vlanif4] quit

  4. 检查配置结果

    上述配置完成后,VLAN2中的员工与VLAN3中的员工可以相互Ping通。

配置文件

  • CE1的配置文件

    #
     sysname CE1
    #
     vlan batch 2
    #
     interface GigabitEthernet0/1/1
      portswitch
      undo shutdown
      port link-type access
      port default vlan 2
    #
     interface GigabitEthernet0/1/2
      portswitch
      undo shutdown
      port link-type access
      port default vlan 2
    #
     interface GigabitEthernet0/1/3
      portswitch
      undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 2
    #
     return
  • CE2的配置文件

    #
     sysname CE2
    #
     vlan batch 3
    #
     interface GigabitEthernet0/1/1
      portswitch
      undo shutdown
      port link-type access
      port default vlan 3
    #
     interface GigabitEthernet0/1/2
      portswitch
      undo shutdown
      port link-type access
      port default vlan 3
    #
     interface GigabitEthernet0/1/3
      portswitch
      undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    return
  • PE的配置文件

    #
     sysname PE
    #
     vlan batch 2 to 4
    #
     vlan 4
      aggregate-vlan
      access-vlan 2 to 3
    #
     interface Vlanif4
      ip address 10.1.1.12 255.255.255.0
      arp-proxy enable
      arp-proxy inter-sub-vlan-proxy enable
    #
     interface GigabitEthernet0/1/1
      portswitch
      undo shutdown
      port link-type trunk
      port trunk allow-pass vlan 2
    #
     interface GigabitEthernet0/1/2
      portswitch
      undo shutdown
      port link-type trunk
      port trunk allow-pass vlan 3
    #
     return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1571

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页