所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DHCP服务器支持相同MAC不同VLAN的用户上线示例

配置DHCP服务器支持相同MAC不同VLAN的用户上线示例

介绍一个以太网用户通过不同VLAN向DHCP服务器申请IP地址示例(无中继设备),结合配置组网图来理解业务的配置过程。

组网需求

VOIP、IPTV等多种业务在不同的用户平面内需要申请不同网段的IP地址。而支持这些业务的DHCP Client会使用一个MAC地址去申请不同网段的IP地址,并基于VLAN ID区分不同的业务。这就要求DHCP服务器支持为相同的MAC不同VLAN的用户分配IP地址。

图1所示,配置DHCP服务器为DHCP Client动态分配IP地址。当DHCP服务器收到的用户报文的Tag为100时,通过网关地址10.10.10.1/24选择huawei1地址池;当DHCP服务器收到的用户报文的Tag为200时,通过网关地址10.10.20.1/24选择huawei2地址池。

说明:

目前DHCP服务器只支持通过不同地址池为相同MAC地址的用户分配地址。

图4-9 配置DHCP服务器支持相同MAC不同VLAN的用户上线组网图
说明:

本例中Interface1代表GE0/1/1



配置思路

DHCP服务器的配置思路如下:

  1. 配置用户上线接口的IP地址。

  2. 配置地址池的网关地址和地址段。

  3. 配置三层子接口。

数据准备

完成此配置举例,需要准备以下数据:

  • 用户上线接口的IP地址。

  • 网关地址。

  • 地址段编号及范围。

操作步骤

  1. 配置用户上线接口的IP地址

    <HUAWEI> system-view
    [~HUAWEI] sysname DHCP Server
    [*HUAWEI] commit
    [~DHCP Server] interface gigabitethernet 0/1/1
    [~DHCP Server-GigabitEthernet0/1/1] ip address 10.1.1.1 255.255.255.0
    [*DHCP Server-GigabitEthernet0/1/1] commit
    [~DHCP Server-GigabitEthernet0/1/1] quit

  2. 配置地址池的网关地址和地址段

    # 配置地址池huawei1。

    [~DHCP Server] dhcp enable
    [*DHCP Server] ip pool huawei1 server
    [*DHCP Server-ip-pool-huawei1] gateway 10.10.10.1 255.255.255.0
    [*DHCP Server-ip-pool-huawei1] section 0 10.10.10.20 10.10.10.30
    [*DHCP Server-ip-pool-huawei1] commit
    [~DHCP Server-ip-pool-huawei1] quit

    # 配置地址池huawei2。

    [~DHCP Server] ip pool huawei2 server
    [*DHCP Server-ip-pool-huawei2] gateway 10.10.20.1 255.255.255.0
    [*DHCP Server-ip-pool-huawei2] section 0 10.10.20.20 10.10.20.30
    [*DHCP Server-ip-pool-huawei2] commit
    [~DHCP Server-ip-pool-huawei2] quit

  3. 配置三层子接口(以Dot1q终结子接口为例)

    [~DHCP Server] interface gigabitethernet 0/1/1.1
    [*DHCP Server-GigabitEthernet0/1/1.1] ip address 10.10.10.1 255.255.255.0
    [*DHCP Server-GigabitEthernet0/1/1.1] encapsulation dot1q-termination
    [*DHCP Server-GigabitEthernet0/1/1.1] dot1q termination vid 100
    [*DHCP Server-GigabitEthernet0/1/1.1] commit
    [~DHCP Server-GigabitEthernet0/1/1.1] quit
    [~DHCP Server] interface gigabitethernet 0/1/1.2
    [*DHCP Server-GigabitEthernet0/1/1.2] ip address 10.10.20.1 255.255.255.0
    [*DHCP Server-GigabitEthernet0/1/1.2] encapsulation dot1q-termination
    [*DHCP Server-GigabitEthernet0/1/1.2] dot1q termination vid 200
    [*DHCP Server-GigabitEthernet0/1/1.2] commit
    [~DHCP Server-GigabitEthernet0/1/1.2] quit

  4. 验证配置结果

    # 在DHCP服务器上使用display ip pool命令用来查看IP地址池配置情况。

    [~DHCP Server] display ip pool name huawei1
      Pool-Name      : huawei1
      Pool-No        : 2
      Pool-constant-index: -
      Lease          : 3 Days 0 Hours 0 Minutes
      NetBios Type   : N-Node
      Auto recycle   : 30
      Option 3       : Enable
      DNS-Suffix     : -
      Dom-Search-List0: -
      Dom-Search-List1: -
      Dom-Search-List2: -
      Dom-Search-List3: -
      Option-Code 125 : enterprise-code : 2011, string: -
      Position       : Server          Status           : Unlocked        
      RUI-Flag       : -
      Attribute      : Private         
      Gateway        : 10.10.10.1      Mask             : 255.255.255.0   
      Vpn instance   : --              Unnumbered gateway: -               
      Profile-Name   : -               Server-Name     : -               
      Total Idle     : 11              Have Dhcp IP     : 1
      Timeouts       : 0
      Timeout Count  : 0               Sub Option Count : 0               
      Option Count   : 0               Force-reply Count: 0               
      Codes: CFLCT(conflicted)
      ---------------------------------------------------------------------------------------
      ID           start             end total  used  idle CFLCT disable reserved static-bind
      ---------------------------------------------------------------------------------------
       0     10.10.10.20     10.10.10.30    11     0    11     0       0        0           0
      ---------------------------------------------------------------------------------------
    [~DHCP Server] display ip pool name huawei2
      Pool-Name      : huawei2
      Pool-No        : 3
      Pool-constant-index: -
      Lease          : 3 Days 0 Hours 0 Minutes
      NetBios Type   : N-Node
      Auto recycle   : 30
      Option 3       : Enable
      DNS-Suffix     : -
      Dom-Search-List0: -
      Dom-Search-List1: -
      Dom-Search-List2: -
      Dom-Search-List3: -
      Option-Code 125 : enterprise-code : 2011, string: -
      Position       : Server          Status           : Unlocked        
      RUI-Flag       : -
      Attribute      : Private         
      Gateway        : 10.10.20.1      Mask             : 255.255.255.0   
      Vpn instance   : --              Unnumbered gateway: -               
      Profile-Name   : -               Server-Name     : -               
      Total Idle     : 11              Have Dhcp IP     : 1
      Timeouts       : 0
      Timeout Count  : 0               Sub Option Count : 0               
      Option Count   : 0               Force-reply Count: 0               
      Codes: CFLCT(conflicted)
      ---------------------------------------------------------------------------------------
      ID           start             end total  used  idle CFLCT disable reserved static-bind
      ---------------------------------------------------------------------------------------
       0     10.10.20.20     10.10.20.30    11     0    11     0       0        0           0
      ---------------------------------------------------------------------------------------

配置文件

DHCP服务器的配置文件

#
sysname DHCP Server
#
dhcp enable
#
ip pool huawei1 server
 gateway 10.10.10.1 255.255.255.0
 section 0 10.10.10.20 10.10.10.30
#
ip pool huawei2 server
 gateway 10.10.20.1 255.255.255.0
 section 0 10.10.20.20 10.10.20.30
#
interface GigabitEthernet0/1/1
 ip address 10.1.1.1 255.255.255.0
#
interface GigabitEthernet0/1/1.1
 ip address 10.10.10.1 255.255.255.0
 encapsulation dot1q-termination
 dot1q termination vid 100
#
interface GigabitEthernet0/1/1.2
 ip address 10.10.20.1 255.255.255.0
 encapsulation dot1q-termination
 dot1q termination vid 200
#
return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1569

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页