所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IP报文转发的全局非等价负载分担示例

配置IP报文转发的全局非等价负载分担示例

本举例介绍IP报文转发的全局非等价负载分担的配置过程。

组网需求

图10-3所示,DeviceA和DeviceC之间通过两条链路连接。

  • DeviceA的GE0/2/0DeviceB的GE0/2/0是一条实际物理链路。

  • DeviceA上Eth-Trunk1接口的成员口是GE0/3/0和GE0/1/8DeviceB上Eth-Trunk1接口的成员口是GE0/3/0和GE0/1/8

因为Eth-Trunk1接口包含了两个GE接口,所以其带宽是两条物理成员链路的带宽之和。现在要在DeviceA到DeviceC的这两条链路上实现全局非等价负载分担。

图10-3 配置非等价负载分担示例
说明:

本例的配置在DeviceA、DeviceB、DeviceC设备上进行,HUAWEI NE20E-S2可以做为DeviceA、DeviceB、DeviceC设备。



设备名称 接口名称 IP地址
DeviceA GE0/2/0 10.30.1.1/24
Eth-Trunk1 10.40.1.1/24
DeviceB GE0/2/0 10.30.1.2/24
Eth-Trunk1 10.40.1.2/24
GE0/1/0 10.50.1.1/24
DeviceC GE0/2/0 10.50.1.2/24
说明:

本示例中DeviceA和DeviceB的GE0/2/0接口带宽为1G,GE0/3/0接口带宽为2G,GE0/1/8接口带宽为3G。

配置思路

采用如下的思路配置非等价负载分担:

  1. 在各路由器上配置静态路由。

  2. DeviceA上全局使能非等价负载分担功能,使DeviceA和DeviceC之间的流量基于不同的链路进行非等价负载分担。

数据准备

完成此配置,需准备如下的数据:

  • 接口类型和接口编号

  • 接口的IP地址

  • Eth-Trunk编号

操作步骤

  1. 配置各物理接口和Eth-Trunk接口的IP地址(略)
  2. 配置静态路由

    # 配置DeviceA。

    [~DeviceA] ip route-static 10.20.1.0 255.255.255.0 gigabitethernet0/2/0 10.30.1.2
    [*DeviceA] ip route-static 10.20.1.0 255.255.255.0 eth-trunk1 10.40.1.2
    [*DeviceA] ip route-static 10.50.1.0 255.255.255.0 gigabitethernet0/2/0 10.30.1.2
    [*DeviceA] ip route-static 10.50.1.0 255.255.255.0 eth-trunk1 10.40.1.2
    [*DeviceA] commit

    # 配置DeviceB。

    [~DeviceB] ip route-static 10.1.1.0 255.255.255.0 gigabitethernet0/2/0 10.30.1.1
    [*DeviceB] ip route-static 10.1.1.0 255.255.255.0 eth-trunk1 10.40.1.1
    [*DeviceB] ip route-static 10.20.1.0 255.255.255.0 gigabitethernet0/2/2 10.50.1.2
    [*DeviceB] commit

    # 配置DeviceC。

    [~DeviceC] ip route-static 10.1.1.0 255.255.255.0 gigabitethernet0/2/0 10.50.1.1
    [*DeviceC] ip route-static 10.30.1.0 255.255.255.0 gigabitethernet0/2/0 10.50.1.1
    [*DeviceC] ip route-static 10.40.1.0 255.255.255.0 GigabitEthernet0/2/0 10.50.1.1
    [*DeviceC] commit

  3. DeviceA上使能全局非等价路由负载分担功能

    [~DeviceA] load-balance unequal-cost enable
    [*DeviceA] commit

  4. 检查配置结果

    # 此时在DeviceC上可以ping通10.1.1.1。执行命令display interface brief,查看出接口的带宽占用率信息。可以看到Eth-Trunk1接口上的带宽占用率与GE0/2/0接口上的带宽占用率基本相同,说明非等价负载分担功能已经使能,出接口的流量已经按照带宽比例均匀分配到各出接口。

    [~DeviceC] ping -c 100 -t 10 -m 10 10.1.1.1
    PING 10.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=254 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms
    ...
     --- 10.1.1.1 ping statistics ---
        100 packet(s) transmitted
        99 packet(s) received
        1.00% packet loss
        round-trip min/avg/max = 1/1/6 ms
    [~DeviceB] display interface brief
    PHY: Physical
    *down: administratively down
    ^down: standby
    (l):loopback
    (s):spoofing
    (b): BFD down
    (e): EFM down
    (d):Dampening Suppressed
    InUti/OutUti: input utility/output utility
    Interface                PHY  Protocol      InUti  OutUti  inErrors    outErrors
    Eth-Trunk1               up    up           20%     30%        35          210
    GigabitEthernet0/1/0     up    up           15%     20%        22          120
    GigabitEthernet0/2/0     up    up           20%     30%        23          125
    GigabitEthernet0/2/1    *down  down         0%      0%         0            0
    GigabitEthernet0/2/3    *down  down         0%      0%         0            0
    GigabitEthernet0/2/4    *down  down         0%      0%         0            0
    GigabitEthernet0/2/5    *down  down         0%      0%         0            0
    GigabitEthernet0/2/6    *down  down         0%      0%         0            0
    GigabitEthernet0/2/7    *down  down         0%      0%         0            0
    Ip-Trunk1                down  down         0%      0%         0            0
    LoopBack0                down  up(s)        0%      0%         0            0
    NULL0                    up    up           0%      0%         0            0

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
    load-balance unequal-cost enable
    #
    interface Eth-Trunk1
     ip address 10.40.1.1 255.255.255.0
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.30.1.1 255.255.255.0
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     eth-trunk 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     eth-trunk 1
    #
     ip route-static 10.20.1.0 255.255.255.0 GigabitEthernet0/2/0 10.30.1.2
     ip route-static 10.20.1.0 255.255.255.0 Eth-Trunk1 10.40.1.2
     ip route-static 10.50.1.0 255.255.255.0 GigabitEthernet0/2/0 10.30.1.2
     ip route-static 10.50.1.0 255.255.255.0 Eth-Trunk1 10.40.1.2
    #
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
    interface Eth-Trunk1
     ip address 10.40.1.2 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.30.1.2 255.255.255.0
    #
    interface GigabitEthernet0/2/2
     undo shutdown
     ip address 10.50.1.1 255.255.255.0
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     eth-trunk 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     eth-trunk 1
    #
     ip route-static 10.1.1.0 255.255.255.0 GigabitEthernet0/2/0 10.30.1.1
     ip route-static 10.1.1.0 255.255.255.0 Eth-Trunk1 10.40.1.1
     ip route-static 10.20.1.0 255.255.255.0 GigabitEthernet0/2/2 10.50.1.2
    #
    return
    
  • DeviceC的配置文件

    #
     sysname DeviceC
    #
     ip route-static 10.1.1.0 255.255.255.0 GigabitEthernet0/2/2 10.50.1.1
     ip route-static 10.30.1.0 255.255.255.0 GigabitEthernet0/2/2 10.50.1.1
     ip route-static 10.40.1.0 255.255.255.0 GigabitEthernet0/2/2 10.50.1.1
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.20.1.1 255.255.255.0
    #
    interface GigabitEthernet0/2/2
     undo shutdown
     ip address 10.50.1.2 255.255.255.0
    #
    return
    
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1458

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页