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CloudEC V600R019C00 典型故障处理(企业入驻式,融合会议)

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补丁加载失败

补丁加载失败

现象描述

在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令,当返回以下信息时,表示出现了补丁加载失败:

  • 指定的补丁名无效。
  • 补丁不存在。
  • 前一个补丁不在运行状态。请执行CON PATCH命令使其处于运行态。
  • 加载的补丁版本比系统现有版本低。
  • 指定的模块不存在。
  • 操作超时。
  • 补丁正在初始化,操作失败。
  • 指定的网元实例不存在。
  • 加载失败。

可能原因

常见原因有如下几种:

  • 补丁名称不正确。
  • 补丁不存在。
  • 系统中存在处于未运行状态的补丁。
  • 被加载补丁版本低于己有补丁版本。
  • 打补丁时指定的模块号不存在。
  • 主机进程异常。
  • 进程刚复位,正在从OMU恢复加载补丁,此时拒绝执行补丁加载命令。
  • 打补丁时指定的网元ID不存在。
  • 制作补丁包的进程文件和当前环境上的进程文件版本信息不一致。

定位思路

根据客户端返回的错误信息描述,参考处理过程做相应的处理。

处理步骤

    判断客户端返回的信息

    1. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令加载补丁,根据返回信息分别进行处理。

      • 指定的补丁名无效=> 2
      • 补丁不存在=> 6
      • 前一个补丁不在运行状态。请执行CON PATCH命令使其处于运行态=> 9
      • 加载的补丁版本比系统现有版本低=> 14
      • 指定的模块不存在=> 16
      • 操作超时=> 19
      • 补丁正在初始化,操作失败=> 19
      • 指定的网元实例不存在=> 23
      • 其他=> 26

    判断补丁名称是否正确

    1. 在客户端的“MML命令行 - CGP”窗口执行LST PKG命令查询加载的补丁包名称。

      说明:

      补丁包名称的命名规则为:网元类型_网元版本“SPCXXX.tar”,其中“XXX”与该补丁包的编号一致,“SPCXXX”即为该补丁名称。如“CGP_V200R018C00_SPC501.tar”,其中“SPC501”为该补丁名称。

    2. 比较待加载补丁包对应的补丁名称与输入参数中的“补丁名称”是否一致。

      • 是 => 26
      • 否 => 4

    3. 修改输入参数中的补丁名称为正确的补丁名称。
    4. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    判断补丁包是否存在

    1. 在客户端的“MML命令行 - CGP”窗口执行LST PKG命令检查待加载的补丁包是否己经存在。

      • 是 => 26
      • 否 => 7

    2. 通过客户端的FTP工具将补丁包文件上传到“软件包”目录下。
    3. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    判断补丁的状态

    1. 在客户端的“MML命令行 - CGP”窗口执行DSP PATCH命令,判断之前加载过的补丁是否为“去激活”“激活”状态。

      • 去激活 => 10
      • 激活 => 12

    2. 依次在客户端的“MML命令行 - CGP”窗口执行ACT PATCHCON PATCH命令,使其达到运行状态。
    3. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    4. 在客户端的“MML命令行 - CGP”窗口执行CON PATCH命令确认补丁,使其达到运行状态。
    5. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    判断当前系统是否存在高于此补丁版本的补丁

    1. 在客户端的“MML命令行 - CGP”窗口执行DSP PATCH命令查看当前系统已存在的补丁。
    2. 判断已存在的补丁版本是否高于当前准备打上的补丁版本。

      说明:
      • 补丁号大的补丁版本高。例:SPH002高于SPH001。
      • 高版本补丁包含低版本补丁的内容。
      • 是 => 处理完毕
      • 否 => 26

    判断补丁模块是否存在

    1. 在客户端的“MML命令行 - CGP”窗口执行LST MODULE命令查看要打补丁的模块是否存在。

    2. 在客户端被管网元的MML命令行窗口执行相应命令来添加模块、进程或者进程组。
    3. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    判断是否存在模块故障或复位

    1. 在客户端的“MML命令行 - CGP”窗口执行DSP MODULE命令查看模块状态,检查模块状态。

      • 有模块“可用状态”“未就绪” => 20
      • 有模块“可用状态”“故障”,或“主备状态”不为“主用”“备用” => 21
      • 所有模块“可用状态”“正常”,且“主备状态”“主用”“备用” => 26

    2. 等模块复位完成后(约2~3分钟),在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    3. 请参见ALM-1003 模块故障告警帮助处理。
    4. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新指定网元ID加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    判断指定的网元ID是否存在

    1. 在客户端的“MML命令行 - CGP”窗口执行LST PKG命令查看补丁包所对应的网元版本。
    2. 在客户端的“MML命令行 - CGP”窗口执行LST ME命令,根据23查询到的网元版本查询对应的网元ID。
    3. 在客户端的“MML命令行 - CGP”窗口执行LOD PATCH命令重新指定网元ID加载补丁,判断故障是否恢复。

      • 是 => 处理完毕
      • 否 => 26

    联系华为技术支持

    1. 请使用“信息收集工具”收集“问题处理通用信息收集场景”信息。
    2. 请联系华为技术支持处理。

参考信息

无。

翻译
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更新时间:2019-08-07

文档编号:EDOC1100059052

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