华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
测量结果不可信(CGP虚拟化)
测量结果不可信(CGP虚拟化)
现象描述
- 在性能管理系统查询普通测量结果中,“可信度”显示“不可信”。
- 在监控任务实时上报的结果中,“可信度”显示“不可信”。
可能原因
常见原因有以下几种:
- 设置时区或者进入夏令时。
- 业务进程故障。
- 虚拟机故障。
- 业务进程倒换。
- OMU发生主备倒换。
定位思路
性能管理系统显示的测量结果(包括普通任务以及监控任务),来源于主机进程上报的bill话单。PM模块按照主机模板填写时的统计规则,对主机上报的话单进行统计计算,得到任务的可信度及指标结果值。当出现测量结果不可信问题时,应该考虑从主机进程和PM运行状态两方面分析。
处理步骤
检查是否为任务创建后的第一个周期
- 在性能测量结果查询页,观察测量结果是否为创建任务后的第一个周期。
如果不可信测量结果的开始时间比测量任务创建时间早或与测量任务创建时间相同,则可认为该测量结果是测量任务创建后的第一个测量周期生成的。
- 在性能测量结果查询页,观察下一个周期测量结果,对应可信度栏显示是否为可信。
因为创建任务后第一个周期统计时间不完整,结果不可信属于正常现象。
查看是否进行了时区或夏令时设置
- 在测量结果查询页,观察测量结果的起始时间或结束时间是否有时区或夏令时标识。
如时间“2010-04-04 15:15:00 +09:00 DST”即含时区和夏令时标志。
- 在客户端的“MML命令行 - CGP”窗口执行LST
OPTLOG命令查询操作日志,观察测量结果不可信的对应周期起始时间前后,是否有执行SET TZ命令进行过时区和夏令时设置,或执行SET
TIME命令进行过时间设置的记录。
说明: 时区和夏令时或者时间的改变导致修改之后的一个周期结果不可信是正常现象。
判断是否存在进程故障
- 在客户端的“MML命令行 - CGP”窗口执行DSP
MODULE命令查看模块状态,检查是否存在“主备状态”不为“主用”或“备用”的模块。
- 请参见ALM-1003 模块故障告警帮助进行处理,观察告警恢复之后的下一个周期开始,话务统计结果“可信度”是否为“可信”。
判断是否存在单板故障
- 观察客户端“告警浏览”窗口的CGP网元下在测量结果不可信的对应周期起始时间前后,是否存在ALM-2001 单板故障告警。
- 请参见ALM-2001 单板故障告警帮助进行处理,观察告警恢复之后的下一个周期开始,话务统计结果“可信度”是否为“可信”。
判断是否存在进程倒换
- 在客户端的“MML命令行 - CGP”窗口执行LST
EVTLOG命令查看CGP网元在测量结果不可信的对应周期起始时间前后,是否存在1018 模块倒换成功事件。
- 请参见1018 模块倒换成功事件帮助进行处理,观察事件恢复后的下一个周期开始,话务统计结果“可信度”是否为“可信”。
判断是否存在OMU双机主备倒换
- 观察客户端“告警浏览”窗口的CGP网元下在测量结果不可信的对应周期起始时间前后,是否存在ALM-8601 OMU双机主备倒换告警。
- 请参见ALM-8601 OMU双机主备倒换告警帮助进行处理,观察告警恢复后的下一个周期开始,话务统计结果“可信度”是否为“可信”。
收集日志信息,联系技术支持人员进行处理
- 使用“信息收集工具”收集“问题处理通用信息收集场景”信息和“自定义场景”中的“PCDR话单”信息。
- 联系华为技术支持处理。