所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R013C00 命令参考

本文档介绍了设备中各特性的配置命令,包括每条命令的功能、格式、参数、视图、缺省级别、使用指南、举例和相关命令。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置系统启动命令

配置系统启动命令

命令支持情况

默认所有款型均支持本章节命令,如有个别命令行或参数存在差异,请详见具体命令行中的说明。

check file-integrity

命令功能

check file-integrity用来对文件和签名文件的一致性进行校验。

命令格式

check file-integrity filename signature-filename

参数说明

参数

参数说明

取值

filename

待检查的文件名,此文件必须存在。

字符串形式,不支持空格,不区分大小写,命名规范为*.cc *.pat *.zip *.7z,长度范围是4~64。

signature-filename

待检查文件对应的签名文件,此文件必须存在。

字符串形式,不支持空格,不区分大小写,命名必须为*.asc,长度范围是5~64。

视图

系统视图

缺省级别

3:管理级

使用指南

应用场景

通过该命令行,可以对文件和签名文件,进行一致性的校验。校验失败的文件不能作为系统软件、补丁软件或Web文件使用。

说明:
签名文件随版本发布,每个合法的系统软件、补丁软件或Web文件均对应有相应的签名文件。用户需要先将签名文件上传至设备才可以使用此命令。

使用实例

#对系统软件和签名文件进行一致性校验。

<HUAWEI> system-view
[HUAWEI] check file-integrity S12700-V200R013C00SPC200.cc S12700-V200R013C00SPC200.cc.asc

clear configuration interface

命令功能

clear configuration interface命令用来一键式清除接口下的配置。

命令格式

clear configuration interface interface-type interface-number

参数说明

参数 参数说明 取值
interface-type interface-number 指定一键式清除配置的接口类型和编号。 当前不支持Tunnel类型和css-port类型接口。

视图

系统视图

缺省级别

3:管理级

使用指南

应用场景

当用户需要将设备上的某个接口用作其他用途时,原始的配置需要逐条删除。如果该接口下存在大量的配置,那么用户将耗费大量的时间进行删除动作,增大了用户的维护量。为了减少用户的维护量和降低操作的复杂度,可通过本命令一键式清除接口下的配置。

用户也可在接口视图下执行命令clear configuration this一键式清除接口下的配置。

说明:

combo-port命令不支持一键式清除。

配置影响

执行本命令后,指定接口下所有配置将被清除,接口的状态将被置为shutdown状态。

注意事项

本命令执行时间较长,任意时刻,若用户希望终止执行本命令,可以键入CTRL_C。

通常情况下执行一键式清除命令后接口的配置恢复缺省配置,接口下如果有特殊配置时,执行一键式清除命令后,清除后配置可能以undo命令形式出现。

使用实例

# 一键式清除GigabitEthernet1/0/1接口下所有配置。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] display this
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid pvid vlan 50
#
return
[HUAWEI-GigabitEthernet1/0/1] quit
[HUAWEI] clear configuration interface gigabitethernet 1/0/1
Warning: All configurations of the interface will be cleared, and its state will
 be shutdown. Continue? [Y/N] :y...
Info: Total execute 2 command(s), 2 successful, 0 failed. 
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] display this
#
interface GigabitEthernet1/0/1
 shutdown
#
return

clear configuration this

命令功能

clear configuration this命令用来一键式清除接口下的配置或将配置恢复到缺省值。

命令格式

clear configuration this

参数说明

视图

接口视图(除Tunnel类型、css-port类型接口视图以及端口组视图之外的所有接口视图)

缺省级别

3:管理级

使用指南

应用场景

当用户需要将设备上的某个接口用作其他用途时,原始的配置需要逐条删除。如果该接口下存在大量的配置,那么用户将耗费大量的时间进行删除动作,增大了用户的维护量。为了减少用户的维护量和降低操作的复杂度,可在接口视图下执行本命令一键式清除接口下的配置。

用户也可在系统视图下执行命令clear configuration interface interface-type interface-num指定接口一键式清除接口下的配置。

配置影响

执行本命令后,系统会提示用户是否需要清除接口下的配置。选择“y”后,指定接口下所有配置将被清除,恢复至默认配置,接口的状态将被置为shutdown状态

执行本命令可一键式清除接口下的配置或将配置恢复到缺省值,类似于在接口下批量执行undo命令。

注意事项

本命令执行时间较长,任意时刻,若用户希望终止执行本命令,可以键入CTRL_C。

通常情况下执行一键式清除命令后接口的配置恢复缺省配置,接口下如果有特殊配置时,执行一键式清除命令后,清除后配置可能以undo命令形式出现。

由于某些命令之间存在关联,当通过undo命令来清除某些命令时会连带清除与之相关的命令。在接口下执行clear configuration this命令后,回显中的统计结果与实际清除结果可能会不一致,请以实际清除结果为准。

使用实例

# 一键式清除GigabitEthernet1/0/1接口下所有配置。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] display this
#
interface GigabitEthernet1/0/1
 description abc
 port link-type access
#
return
[HUAWEI-GigabitEthernet1/0/1] clear configuration this
Warning: All configurations of the interface will be cleared, and its state will be shutdown. Continue? [Y/N] :y
Info: Total 2 command(s) executed, 2 successful, 0 failed.
[HUAWEI-GigabitEthernet1/0/1] display this
#
interface GigabitEthernet1/0/1
 shutdown
#
return

clear inactive-configuration slot

命令功能

clear inactive-configuration slot命令用来清除不在位单板的非激活配置信息。

命令格式

clear inactive-configuration slot slot-id

参数说明

参数 参数说明 取值
slot-id 指定不在位单板的槽位号。

请根据设备实际配置选取。

视图

系统视图

缺省级别

3:管理级

使用指南

更换单板时,如果不希望保存现有的配置信息,可以使用该命令清除不在位单板的配置信息。

该命令会清除不在位单板的非激活配置信息,同时删除该不在位单板上的子接口。

执行该命令清除单板配置前,请确保指定槽位的单板不在位。

同一时间只允许一个用户执行该命令清除指定接口的非激活配置。

使用实例

# 清除7号槽位不在位单板上的配置信息。

<HUAWEI> system-view
[HUAWEI] clear inactive-configuration slot 7
Warning: The inactive configuration of slot 7 will be deleted and can't be restored.
Are you sure to continue?[Y/N] y
The command will takes a few minutes, please wait..
Info: Succeeding in clearing the inactive configuration.

configuration backup local disable

命令功能

configuration backup local disable命令用来关闭备份当前运行配置的功能。

undo configuration backup local disable命令用来打开备份当前运行配置的功能。

缺省情况下,备份运行配置到本地的功能处于打开状态。

命令格式

configuration backup local disable

undo configuration backup local disable

参数说明

视图

系统视图

缺省级别

3:管理级

使用指南

应用场景

如果用户需要在设备配置发生变更后,自动备份当前运行配置到本地,可以通过该命令打开备份运行配置到本地的功能,以方便查看历史配置变更记录,快速定位问题。

注意事项

  • 打开备份运行配置到本地的功能,当配置发生变化2小时后,设备将自动备份当前的运行配置到本地,如果在备份的同时有save、自动保存操作时,会发生冲突,备份配置文件将周期性延迟半小时保存,直到保存成功。
  • 如果在备份配置文件的同时CPU使用率超过60%,备份配置文件将周期性延迟半小时保存,直到保存成功。
  • 保存备份配置文件的同时,配置命令无法下发。
  • 在试图保存备份配置文件时,如果当前的配置与上一次保存的配置相同,设备将不重复备份当前的运行配置到本地。

文件管理规则说明:

  • 本地存储路径固定为“$_backup/running_config/”。
  • 文件命名规则为“yyyymmddhhmmss.sysname.zip”。yyyy表示年,第一个“mm”表示月,“dd”表示日,“hh”表示小时,第二个“mm”表示分,“ss”表示秒,“sysname”表示设备主机名称。
  • 保存文件大于30个时,或者总占用空间大于10M时,或者设备剩余空间小于30M时,备份配置文件将会按照老化规则进行自动老化。
  • 备份配置文件个数小于等于5个时不再进行老化。

文件老化规则说明:

  • 按照备份文件生成的时间为文件指定序号和老化优先级:
    说明:

    文件序号说明:最新生成的文件序号指定为1,之前生成的备份文件序号指定为2,文件序号依次增加,序号越大文件的生成时间越早。

    文件老化优先级:序号越小文件优先级越高,文件老化时首先老化优先级低的文件,其中优先级为0的文件不参与老化。如果文件分属于多个优先级,则以高优先级为准。

    • 0级:文件序号1至5。
    • 1级:文件序号6至10。
    • 2级:刚刚过去一周,当天所生成的最后一份备份文件。
    • 3级:刚刚过去的五个月,当月所生成的最后一份备份文件。
    • 4级:其它备份文件。
  • 文件老化说明:
    • 按照备份文件的老化优先级,依照时间顺序对备份配置文件进行老化,优先老化生成时间早的文件。

使用实例

# 关闭备份运行配置到本地的功能。

<HUAWEI> system-view
[HUAWEI] configuration backup local disable

configuration copy file to running

命令功能

configuration copy file to running命令用来执行指定的配置文件中的命令。

命令格式

configuration copy file file-name to running

参数说明

参数 参数说明 取值
file-name 指定待执行的配置文件名称。 字符串形式,格式为[ drive ] [ path ] [ filename ],绝对路径名长度范围是4~160。必须以“.cfg”或“.zip”作为扩展名。

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

如需要运行已存在的配置文件时,可执行该命令。通过该命令可以一次性将指定配置文件中的命令全部执行。

注意事项

本命令同时只允许一个用户执行。

该命令执行过程中,如果发生配置恢复、批量备份操作,则命令执行终止。

该命令执行过程中,如果某条命令执行失败,则跳过继续执行下一条命令。

待执行的配置文件中如果包含重启的命令,设备按顺序执行到重启命令时会导致重启设备,请谨慎使用。

使用实例

# 执行配置文件huawei.cfg中的命令。

<HUAWEI> configuration copy file huawei.cfg to running
Warning: This operation may take a long time, press CTRL+C to break. Continue?[Y/N]:y

configuration copy startup to file

命令功能

configuration copy startup to file命令用来将设备的启动配置文件备份到指定的文件中。

命令格式

configuration copy startup to file file-name

参数说明

参数 参数说明 取值
file-name 指定目的文件名称。 字符串形式,格式为[ drive ] [ path ] [ filename ],绝对路径名长度范围是4~160。必须以“.cfg”或“.zip”作为扩展名,且后缀必须与被备份文件的后缀一致。

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

当需要将设备启动配置文件进行备份时,可以使用该命令。

注意事项

当存在同名文件时,系统会提示是否覆盖。输入“Y”进行覆盖,输入“N”不进行覆盖。

使用实例

# 将设备的启动配置文件备份到huawei.cfg。

<HUAWEI> configuration copy startup to file huawei.cfg

compare configuration

命令功能

compare configuration命令用来比较当前的配置文件(包含离线配置)与下次启动的配置文件内容是否一致。

命令格式

compare configuration [ configuration-file ] [ current-line-number save-line-number ]

参数说明

参数 参数说明 取值
configuration-file 指定需要与当前配置进行比较的配置文件名。 字符串形式,不支持空格,区分大小写,长度范围是5~48
current-line-number 表示从当前配置的该行号开始比较。 整数形式,取值范围是0~65535。
save-line-number 表示从指定配置的该行号开始比较。 整数形式,取值范围是0~65535。

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

如果不输入current-line-number save-line-number,表示从配置文件的首行开始进行比较。这两个参数是为了在发现配置文件不同之处后,跳过该不同处继续进行比较。

compare configuration命令在比较出不同之处时,系统将从不同之处位于的行分别显示当前配置文件(包含离线配置)和保存的配置文件。缺省情况下,当前配置文件和保存的配置文件分别显示120字符。

  • 如果从不同之处到配置文件末尾不足120字符,将显示到配置文件末尾为止。
  • 如果从不同之处到配置文件末尾超过120字符,则超过120字符的配置文件将不显示。

注意事项

  • 本命令执行时间较长,任意时刻,若用户希望终止执行本命令,可以键入CTRL_C。
  • 配置文件必须以“.cfg” 或“.zip”作为扩展名。

  • 如果不指定configuration-file,系统比较当前的配置文件(包含离线配置)与下次启动的配置文件内容是否一致。

  • 如果指定configuration-file,系统比较当前的配置文件(包含离线配置)与指定的配置文件内容是否一致。

使用实例

# 比较当前的配置文件(包含离线配置)与下次启动的配置文件内容是否一致。

<HUAWEI> compare configuration
Info: The system is now comparing the configuration, please wait....
Warning: The current configuration is not the same as the next startup 
configuration file. There may be several differences, and the following are some 
configurations beginning from the first: 
====== Current configuration line 6 ======
 vlan batch 1 to 2 10 to 11 15 70 to 71 91 to 92 100 111 230 240 901
 vlan batch 911 1111
#
 l2protocol-tunnel vtp group-mac 0100-0ccd-ffff

 ====== Configuration file line 6 ======
 vlan batch 1 to 2 10 to 11 15 70 91 to 92 100 111 230 240 901
 vlan batch 911 1111
#
 l2protocol-tunnel vtp group-mac 0100-0ccd-ffff  
相关主题

display changed-configuration time

命令功能

display changed-configuration time命令用来查看最后一次配置变更的时间。

命令格式

display changed-configuration time

参数说明

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

用户修改设备当前配置后,可以使用该命令,查看最后一次配置变更的时间。

使用实例

# 显示最后一次配置变更的时间。

<HUAWEI> display changed-configuration time

display configuration recover-result

命令功能

display configuration recover-result命令用来查看配置恢复结果。

命令格式

display configuration recover-result

参数说明

视图

所有视图

缺省级别

3:管理级

使用指南

应用场景

用户可使用display configuration recover-result命令查看配置恢复执行的结果以及命令配置恢复失败的记录。记录信息包括配置恢复执行失败的命令行、命令所在视图信息、命令在当前启动配置文件中的行号,命令执行失败原因以及配置恢复执行时间。

此命令最多可以显示256条记录,按照时间顺序排序,最新的排在最后显示。当配置恢复的命令累计超过256条时,设备将不再继续记录配置恢复失败的命令信息。

前提条件

执行此命令的前提是整机设备重启配置恢复有效。

使用实例

# 显示配置恢复结果。

<HUAWEI> display configuration recover-result
The current startup saved-configuration file is flash:/vrpcfg.zip.
The number of failed commands is 2. 
----------------------------------------------------------------------

Command : ip address 10.85.1.1 255.255.255.0
View    : Vlanif85
Line    : 414
Reason  : Failed to parse the command.
Time    : 10:00:06  2012-07-25 UTC+08:00 DST

Command : ip address 10.86.1.1 255.255.255.0
View    : Vlanif86
Line    : 417
Reason  : Failed to parse the command.
Time    : 10:00:06  2012-07-25 UTC+08:00 DST 

----------------------------------------------------------------------
表2-63  display configuration recover-result命令输出信息描述

项目

描述

Command

配置恢复失败的命令行信息。

View

配置恢复失败命令所属视图信息。

Line

命令在当前启动配置文件中的行号。

Reason

命令执行失败原因。

Time

配置恢复执行时间。

display current-configuration

命令功能

display current-configuration命令用来查看设备当前生效的配置参数。

对于某些正在生效的配置参数,如果与缺省工作参数相同,则不显示。

命令格式

display current-configuration [ configuration [ configuration-type [ configuration-instance ] ] | interface [ interface-type [ interface-number ] ] ] [ feature feature-name ] [ filter filter-expression ]

display current-configuration [ all | inactive ]

display current-configuration configuration vpn-instance [ vpn-instance-name ] related

参数说明

参数

参数说明

取值

configuration

显示所有配置信息,除了接口下的配置。

-
configuration-type

显示指定配置类型的配置信息,除了接口下的配置。

指定的配置类型依赖于系统当前已有的配置。例如:
  • system:显示系统配置。
  • user-interface:显示用户界面配置。
  • aaa:显示AAA配置。
-
configuration-instance

显示指定配置实例的配置信息,除了接口下的配置。

指定的配置实例依赖于系统当前已有的配置。

字符串形式,不支持空格,不区分大小写,长度范围是1~80个字符。
interface [ interface-type [ interface-number ] ]

显示指定类型、编号的接口配置信息。

指定接口下的配置信息依赖于系统当前已有的配置。
  • interface-type:表示接口类型。
  • interface-number:表示接口编号。
-
feature feature-name

显示指定名称特性的配置信息。

指定特性的配置信息依赖于系统当前已有的配置。

-
filter filter-expression

显示按过滤条件过滤后的配置信息。

说明:
如果显示信息较多,使用filter查看过滤后的配置信息时系统需要较长的时间才能获取正确的信息,因此需要用户等待一段时间。

字符串形式,不区分大小写,不支持空格,长度范围是1~255,且必须从命令的首个字符开始匹配。

例如,当filter-expression取值为“snmp-agent”时,只能过滤出以“snmp-agent”开始的命令。

all

显示所有配置。

-
inactive

显示所有不在位的单板配置信息。

单板不在位时,其对应的配置信息为非激活状态,这些配置信息前面有前导符*。

-
vpn-instance [ vpn-instance-name ] 显示与VPN实例相关的配置信息。 必须是已存在的VPN实例名称。
related 显示与指定模块相关的配置信息。 -

视图

所有视图

缺省级别

3:管理级

使用指南

如果用户完成一组配置之后,需要验证是否配置正确,则可以执行display current-configuration命令来查看当前生效的参数,对于某些参数,虽然用户已经配置,但如果这些参数所在的功能如果没有生效,则不予显示。

显示的信息与用户配置相关。

如果配置信息比较多,可以使用正则表达式对输出信息进行过滤。

如果查看的是离线配置,其对应的配置信息为非激活状态,在执行命令display current-configuration alldisplay current-configuration inactive时,这些配置信息前面有前导符*。

使用实例

# 查看包含字符串“vlan”的所有配置信息。

<HUAWEI> display current-configuration | include vlan
vlan batch 10 77 88               
 port trunk allow-pass vlan 10                  

# 查看ftp特性的配置信息。

<HUAWEI> display current-configuration feature ftp 
#
FTP server enable
#
------------ END ------------ 

display factory-configuration reset-result

命令功能

display factory-configuration reset-result命令用来查看设备最近一次恢复出厂配置的结果。

命令格式

display factory-configuration reset-result

参数说明

视图

所有视图

缺省级别

1:监控级

使用指南

在使用reset factory-configuration命令恢复出厂配置后,可以使用此命令查看恢复出厂配置的结果信息。

使用实例

# 查看最近一次恢复出厂配置的结果。

<HUAWEI> display factory-configuration reset-result
Slot   Time                         Type                                   Result
 _____________________________________________________________________________________          
1/7    2017/10/11 15:55:11 [DST]   Startup saved-configuration file      Succeeded
                                   Configuration in flash                Succeeded
                                   Cloud-mng db-configuration            Succeeded
                                   Data file                             Succeeded

1/8    2017/10/11 15:55:20 [DST]   Startup saved-configuration file      Succeeded
                                   Configuration in flash                Succeeded
                                   Cloud-mng db-configuration            Succeeded
                                   Data file                             Succeeded
表2-64  display factory-configuration reset-result命令输出信息描述表

项目

描述

Slot

槽位号

Time

执行恢复出厂配置的时间。

Type

需要恢复至出厂配置状态的配置文件类型。

  • Startup saved-configuration file:配置文件中的配置。
  • Configuration in flash:flash中的配置,如集群配置。
  • Cloud-mng db-configuration:NETCONF中的数据库文件。
  • Data file:文件系统中的数据文件。

Result

配置文件恢复至出厂配置状态的结果。

  • Succeeded:恢复出厂配置状态成功。
  • Failed:恢复出厂配置状态失败。

display reset-reason

命令功能

display reset-reason命令用来查看单板的复位原因。

命令格式

display reset-reason [ slot slot-id ]

参数说明

参数

参数说明

取值

slot slot-id

指定单板的槽位号。

整数形式,根据设备实际硬件情况选取。

视图

所有视图

缺省级别

1:监控级

使用指南

可以通过此命令查看单板的复位原因,以此帮助定位问题。当不指定槽位号时,display reset-reason命令将显示所有单板的复位原因。

使用实例

# 显示所有单板复位的原因。

<HUAWEI> display reset-reason
The LPU chassis[1] board[1] has no reset records.
The LPU chassis[1] board[2] has no reset records.
The LPU chassis[1] board[3]'s reset total 1, detailed information:
--  1. 2012/03/13   19:58:15, Reset No.: 1
       Reason: Check mod information fail
The MPU chassis[1] board[4] has no reset records.
The MPU chassis[1] board[5]'s reset total 967, detailed information:
--  1. 2012/03/20   13:07:52, Reset No.: 967
       Reason: Warm reset board for no receiving message in a long time
--  2. 2012/03/20   12:57:52, Reset No.: 966
       Reason: Warm reset board for no receiving message in a long time
--  3. 2012/03/20   12:47:52, Reset No.: 965
       Reason: Warm reset board for no receiving message in a long time
--  4. 2012/03/20   12:37:52, Reset No.: 964
       Reason: Warm reset board for no receiving message in a long time
--  5. 2012/03/20   12:27:52, Reset No.: 963
       Reason: Warm reset board for no receiving message in a long time

# 显示某个单板复位的原因。

<HUAWEI> display reset-reason slot 1
The LPU chassis[1] board[1] has no reset records.
表2-65  display reset-reason命令输出信息描述

项目

描述

LPU

业务接口板

MPU

主控板

SFU

交换网板

chassis

单板所在框号

board

单板所在槽位号

reset total

重启次数

detailed information

重启信息

Reset No.

重启编号

Reason

重启原因

相关主题

display saved-configuration

命令功能

display saved-configuration命令用来查看设备下次启动时所用的配置文件。

命令格式

display saved-configuration [ last | time | configuration ]

参数说明

参数 参数说明 取值
last 显示上次保存的系统配置信息。 -
time 最近的一次手工或者系统自动保存配置的时间。 -
configuration 自动保存配置功能的参数信息。 -

视图

所有视图

缺省级别

3:管理级

使用指南

如果设备成功上电并进入系统后工作不正常,可以执行display saved-configuration命令查看设备的启动配置,即查看通过startup saved-configuration命令指定的配置文件。

display saved-configuration last命令用来查看上次保存的系统配置信息,即,本次启动时使用的配置文件。

display saved-configuration time命令用来查看上次保存的系统配置的时间。

display saved-configuration configuration命令用来查看自动保存配置功能的参数信息,包括定时保存时间间隔、CPU利用率等信息。

显示的信息与用户配置相关。

使用实例

# 显示设备下次启动时所用的配置文件。

<HUAWEI> display saved-configuration
#
 sysname Switch
...
#
 vlan batch 10 20
#
interface Vlanif10
 ip address 192.168.1.3 255.255.255.0
#
interface Vlanif20
 ip address 192.168.4.3 255.255.255.0
...
#
interface GigabitEthernet2/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet2/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
...
#
user-interface maximum-vty 15
user-interface con 0
user-interface vty 0 14
 idle-timeout 0 0
#
return

display schedule reboot

命令功能

display schedule reboot命令用来查看设备定时重新启动的配置信息。

命令格式

display schedule reboot

参数说明

视图

所有视图

缺省级别

3:管理级

使用指南

当用户通过schedule reboot命令配置定时重新启动功能后,可以通过本命令查看相关配置信息。

使用实例

# 查看当前设备上定时重新启动的配置信息。

<HUAWEI> display schedule reboot
Info:System will reboot at 22:00:00 2013/09/17 (in 1 hours and 43 minutes).
表2-66  display schedule reboot命令输出信息描述

项目

描述

System will reboot at

表示设备定时重新启动的具体时间。

in hours and minutes

表示设备定时重新启动时间与当前时间的差值。

相关主题

display snmp-agent trap feature-name configuration all

命令功能

display snmp-agent trap feature-name configuration all命令用来查看配置管理模块的所有告警开关的信息。

命令格式

display snmp-agent trap feature-name configuration all

参数说明

视图

所有视图

缺省级别

1:监控级

使用指南

打开告警开关之后,执行命令display snmp-agent trap feature-name configuration all可以查看配置管理所有告警的使能情况。

使用实例

# 查看配置管理模块的所有告警信息。

<HUAWEI> display snmp-agent trap feature-name configuration all
------------------------------------------------------------------------------
Feature name: CONFIGURATION
Trap number : 7
------------------------------------------------------------------------------
Trap name                       Default switch status   Current switch status
hwCfgManEventlog                off                     off
hwCfgOperateCompletion          off                     off
hwCfgB2STransferFail            off                     off
hwCfgB2SOperate                 off                     off
hwCfgRestoreFail                on                      on
hwConfigInconsistent            on                      on 
hwConfigInconsistentResume      on                      on 
表2-67  display snmp-agent trap feature-name configuration all命令输出信息描述

项目

描述

Feature name

告警所属的模块名称。

Trap number

告警的数量。

Trap name

告警的名称。
  • hwCfgManEventlog:系统配置发生事件改变时的告警。
  • hwCfgOperateCompletion:系统配置备份完成时的告警。
  • hwCfgB2STransferFail:备份当前配置文件到服务器失败时的告警。
  • hwCfgB2SOperate:开始将配置文件备份到服务器时的告警。
  • hwCfgRestoreFail:系统配置保存失败时的告警。
  • hwConfigInconsistent:当主交换机和成员交换机当前的运行配置不一致时的告警。
  • hwConfigInconsistentResume:当主交换机和成员交换机当前的运行配置不一致恢复时的告警。

Default switch status

默认告警的状态:

  • on:表示告警处于开启状态。
  • off:表示告警处于关闭状态。

Current switch status

当前告警标识符:

  • on:表示告警处于开启状态。
  • off:表示告警处于关闭状态。

display snmp-agent trap feature-name datasync all

命令功能

display snmp-agent trap feature-name datasync all命令用来查看DataSync模块的所有告警开关的信息。

命令格式

display snmp-agent trap feature-name datasync all

参数说明

视图

所有视图

缺省级别

1:监控级

使用指南

简单网络管理协议SNMP(Simple Network Management Protocol)是广泛用于TCP/IP网络的网络管理标准协议。SNMP提供了一种通过运行网络管理软件的中心计算机(即网络管理工作站)来管理网元的方法。网元上运行的管理代理可以主动上报告警给管理工作站,可使管理工作站及时获取网络状态,从而使网络管理员能够及时采取相应措施。

执行display snmp-agent trap feature-name datasync all命令可以用来查看DataSync模块所有告警的开启关闭状态。

使用实例

# 查看DataSync模块的所有告警信息。

<HUAWEI> display snmp-agent trap feature-name datasync all
------------------------------------------------------------------------------
Feature name: DataSync
Trap number : 1
--------------------------------------------------------------------------------
Trap name                       Default switch status      Current switch status
hwCfgChgNotify                  on                         on
表2-68  display snmp-agent trap feature-name datasync all命令输出信息描述

项目

描述

Feature name

告警所属的模块名称。

Trap number

告警的数量。

Trap name

告警的名称,DataSync模块的告警包括:
  • hwCfgChgNotify:系统配置变更。

Default switch status

缺省的告警状态:
  • on:表示告警处于开启状态。
  • off:表示告警处于关闭状态。

Current switch status

当前的告警状态:
  • on:表示告警处于开启状态。
  • off:表示告警处于关闭状态。

display startup

命令功能

display startup命令用来查看设备本次及下次启动相关的系统软件、配置文件、PAF、License文件和补丁文件。

命令格式

display startup [ slot slot-id | chassis chassis-number ]

参数说明

参数 参数说明 取值
slot slot-id

指定槽位号。

整数形式,取值范围以实际设备为准。
chassis chassis-number

指定集群ID。

整数形式,取值范围为1~2。

视图

所有视图

缺省级别

1:监控级

使用指南

在系统升级或降级之前,可执行此命令查看下次启动的系统软件及各文件是否为正确的启动加载文件,确认重启后,可确保系统升级或降级成功。也可通过此命令查看本次启动加载的系统软件及各文件。

使用实例

# 显示本次及下次启动相关的文件名。

<HUAWEI> display startup
MainBoard:
  Configured startup system software:        flash:/basicsoftware.cc
  Startup system software:                   flash:/basicsoftware.cc
  Next startup system software:              flash:/basicsoftware.cc
  Startup saved-configuration file:          flash:/vrpcfg.zip
  Next startup saved-configuration file:     flash:/vrpcfg.zip
  Startup paf file:                          default
  Next startup paf file:                     default
  Startup license file:                      default
  Next startup license file:                 default
  Startup patch package:                     NULL
  Next startup patch package:                NULL 
SlaveBoard:
  Configured startup system software:        flash:/basicsoftware.cc
  Startup system software:                   flash:/basicsoftware.cc
  Next startup system software:              flash:/basicsoftware.cc
  Startup saved-configuration file:          flash:/vrpcfg.zip
  Next startup saved-configuration file:     flash:/vrpcfg.zip
  Startup paf file:                          default
  Next startup paf file:                     default
  Startup license file:                      default
  Next startup license file:                 default
  Startup patch package:                     NULL
  Next startup patch package:                NULL 
表2-69  display startup命令输出信息描述

项目

描述

Configured startup system software

系统启动前,用户通过startup system-software命令配置的系统重新启动时使用的系统软件文件。

Startup system software

本次启动所使用的系统软件文件。

Next startup system software

用户通过startup system-software命令配置的系统重新启动时所使用的系统软件。

如果没有配置则显示为系统本次启动时所使用的系统软件。

Startup saved-configuration file

本次启动时使用的配置文件。

Next startup saved-configuration file

用户通过startup saved-configuration命令配置的系统重新启动时所使用的配置文件。

如果没有配置则显示为系统本次启动时所使用的配置文件。

Startup paf file

系统本次启动时所使用的PAF文件。

“default”表示系统启动前用户没有指定PAF文件或PAF文件没有生效。

Next startup paf file

下一次启动所使用的PAF文件。

如果没有配置则显示为“default”。

Startup license file

系统本次启动时所使用的License文件。

“default”表示系统启动前用户没有指定License文件或License文件没有生效。

Next startup license file

系统重新启动时所使用的License文件。

如果没有配置则显示为“default”。

Startup patch package

系统本次启动时所使用的补丁包文件。

“NULL”表示系统启动前用户没有指定补丁包文件或补丁包文件没有生效。

Next startup patch package

用户通过startup patch命令配置的系统重新启动时所使用的补丁包文件。

如果没有配置则显示为“NULL”。

reboot

命令功能

reboot命令用来重新启动设备。

命令格式

reboot [ fast | save diagnostic-information ]

参数说明

参数 参数说明 取值
fast 指定快速重启设备,不保存配置文件。 -
save diagnostic-information 指定重新启动设备前保存系统故障诊断信息。 -

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

该命令功能与设备关闭电源再开启电源的效果相同。在对设备进行远程维护时,不需到现场重新启动设备,只需执行本命令即可在远程重新启动设备。

  • 执行命令reboot后,如果下次启动的配置文件(即新的配置文件)和设备上保存的配置文件一致时,系统重启前将提示用户是否保存配置;如果下次启动的配置文件(即新的配置文件)和设备上保存的配置文件不一致时,系统重启前将不会提示用户是否保存配置,未保存的配置信息将丢失。

  • 执行命令reboot fast后,系统将快速重启设备,不提示用户是否保存配置,未保存的配置信息将丢失。

  • 执行命令reboot save diagnostic-information后,系统在重新启动前将诊断信息保存到默认存储器的根目录下。

注意事项

  • 执行该命令后,如果用户不对系统提示信息做响应,则超时后会退回到用户视图,不重新启动。

  • 为避免遇到故障时重新启动而丢失故障诊断信息,可以通过在设备重启时选择先自动保存诊断信息,从而保证故障诊断信息不丢失。

  • 在一般情况下,请勿使用该命令,否则将导致整个设备业务中断。

  • 在重启设备前,要确认配置文件是否已经保存。

  • 当用户需要将设备升级到V200R009C00或之后版本时,如果设备的配置文件中包含有WLAN特性的配置,重启设备时会提示用户配置文件与下次运行的版本冲突,导致设备升级失败。需要用户首先使用eDesk工具对配置文件中的配置进行转换,然后再将转换后的配置文件设置为下次启动配置文件。如果不转换配置文件,则系统重启升级后会导致配置丢失。
  • 多个用户同时执行reboot save diagnostic-information命令时,系统会提示该命令被其他用户锁定。
  • 执行reboot save diagnostic-information命令的同时,执行display diagnostic-information命令,系统会提示该命令被其他用户锁定。
说明:

用eDesk工具对配置文件中的配置进行转换之后,请使用不保存配置的方式重启设备。如果保存配置,转换之后的配置文件将会无效。

使用实例

# 重新启动设备。

<HUAWEI> reboot
Info: The system is now comparing the configuration, please wait........
Warning: The configuration has been modified, and it will be saved to the next s
tartup saved-configuration file flash:/204.cfg. Continue? [Y/N]:y              
Info: If want to reboot with saving diagnostic information, input 'N' and then e
xecute 'reboot save diagnostic-information'.                                    
System will reboot! Continue?[Y/N]:y

# 快速重新启动设备。

<HUAWEI> reboot fast

reset boot password

命令功能

reset boot password命令用来重置Bootload菜单的密码为Admin@huawei.com。

缺省情况下,V100R006及之前版本的设备,BootROM菜单密码为9300V100R006之后版本的设备,Bootload菜单密码为Admin@huawei.com。

命令格式

reset boot password [ slot slot-id ]

参数说明

参数

参数说明

取值

slot slot-id

重置指定槽位号的Bootload菜单密码。

不指定此参数时,重置所有槽位号的Bootload菜单密码。

整数形式,根据设备实际硬件情况选取。

视图

所有视图

缺省级别

3:管理级

使用指南

当用户因为忘记Bootload菜单的密码而不能进入Bootload菜单时,可以使用此命令重置密码为Admin@huawei.com,用户可以通过重置后的密码进入菜单。

使用实例

# 重置Bootload菜单的密码。

<HUAWEI> reset boot password
The password used to enter the boot menu by clicking Ctrl+B will be restored to the default password, continue? [Y/N] y

reset factory-configuration

命令功能

reset factory-configuration命令用来将设备恢复至出厂配置状态。

命令格式

reset factory-configuration

参数说明

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

当用户希望清除所有的业务配置和数据文件时,可以执行reset factory-configuration命令,还原设备出厂配置。

注意事项

执行reset factory-configuration命令后,系统会提示是否需要重启设备。输入y后,设备将重启并清除设备上的业务配置和数据文件。清除的配置和文件主要有:
  • 配置文件中的配置。
  • flash中的配置,如集群配置。
  • NETCONF中的数据库文件。
  • 文件系统中的数据文件。
说明:
  • 下次启动的大包、补丁、模块和License文件不会被清除。
慎重执行该命令,最好在技术支持人员指导下使用。

使用实例

# 将设备恢复至出厂配置状态。

<HUAWEI> reset factory-configuration
Warning: The command will delete all the configurations and files (except the startup, patch, module, and license files) from the de
vice. Continue? [Y/N]:y                                                                                                             
Warning: The system will reboot after configurations and files are deleted. Continue? [Y/N]:y                                       

reset saved-configuration

命令功能

reset saved-configuration命令用来清空设备下次启动使用的配置文件内的内容,并取消指定系统下次启动时使用的配置文件。

命令格式

reset saved-configuration

参数说明

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

  • 设备软件升级之后,设备中原有的配置文件可能与新版本软件不匹配,这时可以用reset saved-configuration命令清空原有的配置文件,然后使用startup saved-configuration命令重新指定一个配置文件。

  • 将一台已经使用过的设备用于新的应用环境,原有的配置文件不能适应新环境需求,需要对设备重新配置,这时可以清空原配置文件,重新启动,还原设备出厂配置。

注意事项

  • reset saved-configuration命令会清空设备配置的下次启动配置文件,并取消指定系统下次启动时使用的配置文件。如果当前启动配置文件与下次启动配置文件相同,当前启动的配置文件也会被清空。
  • 取消指定系统下次启动时使用的配置文件后,如果不使用startup saved-configuration命令重新指定新的配置文件,或者不保存配置文件,重启设备后,设备就会以缺省配置启动。
  • 如果当前启动配置文件为空,下次启动配置文件不为空,执行该命令后,则正常清除下次启动配置文件的设置。

  • 如果下次启动配置文件为空,当前启动配置文件不为空,执行该命令后,系统将提示错误,并且不做任何清除操作。

  • 慎重执行该命令,最好在技术支持人员指导下使用。

使用实例

# 清空存储设备中的下次启动配置文件中的配置信息,并取消指定系统下次启动时使用的配置文件。

<HUAWEI> reset saved-configuration
Warning: The action will delete the saved configuration in the device.          
The configuration will be erased to reconfigure. Continue? [Y/N]:y              
Warning: Now clearing the configuration in the device.                          
Info: Succeeded in clearing the configuration in the device. 

save

命令功能

save命令用来保存当前配置信息到系统默认的存储路径中。

命令格式

save [ all ] [ configuration-file ]

参数说明

参数 参数说明 取值
all 保存所有的配置到系统下次启动配置文件中。
说明:
无论是否指定参数all,都会保存所有配置,包括不在位的板卡的配置。
-
configuration-file 配置文件的文件名。 字符串形式,不支持空格,区分大小写,绝对路径的长度范围是5~48

视图

用户视图

缺省级别

2:配置级

使用指南

应用场景

用户通过命令行可以修改设备的当前配置,而这些配置是暂时的,如果要使当前配置在系统下次重启时仍然有效,在重启设备前,需要将当前配置保存到配置文件中。

当完成一组配置,并且已经达到预定功能,则应将当前配置文件保存到存储设备中。

如果不加configuration-file参数,save [ all ]命令会将当前配置信息保存到存储设备中的系统下一次启动的配置文件中。display startup命令回显中的“Next startup saved-configuration file”字段值就是系统下一次启动的配置文件。

save [ all ] configuration-file命令用来备份当前配置信息到存储设备中configuration-file所指定的文件中。该命令通常情况下不影响系统当前的启动配置文件;除非当configuration-file与系统下次启动的存储路径及配置文件完全相同时,则此命令的作用等同于不加configuration-file参数的save命令。

无论是否指定参数all,都会保存当前所有的配置信息,包括不在位的单板配置信息。

在第一次保存配置文件时,如果不指定可选参数configuration-file,则设备将提示是否将文件名保存为“vrpcfg.zip”。“vrpcfg.zip”是系统缺省的配置文件,初始状态是空配置。

注意事项

  • 该命令为覆盖式命令,如果保存时文件名已经存在,原文件的内容将被替换。

  • 在系统启动阶段,如果业务板还没有正常运行,即配置文件还未完全恢复到内存中,此时执行save命令保存,内存中不完整的配置信息将会覆盖配置文件中的配置信息,造成部分配置信息丢失。
  • 配置文件必须以*.zip或者*.cfg作为扩展名,其中:
    • *.cfg为纯文本格式,可直接查看其内容。指定为配置文件后,启动时系统对里面的命令逐条进行恢复。
    • *.zip是*.cfg的压缩,占用空间较小。指定为配置文件后,启动时先解压成*.cfg格式,然后逐条恢复。
  • 设备在保存配置文件时,不允许其他用户进行配置。同样,如果当前用户正在进行配置,其他用户也不允许进行保存配置操作。

使用实例

# 未设置下次启动配置文件时,保存当前配置文件到默认存储设备中。

<HUAWEI> save
The current configuration will be written to the device.
Are you sure to continue?[Y/N]y
Now saving the current configuration to the slot 0..
Save the configuration successfully.

# 设置了下次启动配置文件时,保存当前配置文件到系统下次启动的配置文件中。

<HUAWEI> save
The current configuration will be written to flash:/vrpcfg.zip.
Are you sure to continue?[Y/N]y
Now saving the current configuration to the slot 4.
Info: Save the configuration successfully.

schedule reboot

命令功能

schedule reboot命令用来配置设备的定时重启功能,可以设置具体的重启时间或重启前的等待时间。

undo schedule reboot命令用来取消定时重启功能。

缺省情况下,没有配置设备定时重启功能。

命令格式

schedule reboot { at time | delay interval [ force ] }

undo schedule reboot

参数说明

参数 参数说明 取值
at time 指定设备重启的时间。 time的格式为hh:mm YYYY/MM/DD,必须大于设备的当前时间,且与当前时间的差值范围小于720小时。YYYY/MM/DD表示年月日,为可选参数。其中:
  • hh表示小时,取值范围是0~23。
  • mm表示分钟,取值范围是0~59。
  • YYYY为整数形式,取值范围是2000~2099
  • MM为整数形式,取值范围是1~12。
  • DD为整数形式,取值范围是1~31。
delay interval 指定设备重启前等待的时间。 interval的格式为hh:mmmm,等待的时间最大不超过720小时。
  • hh:mmhh表示小时,取值范围是0~720。mm表示分钟,取值范围是0~59。
  • mm表示分钟,取值范围是0~43200。
force 指定强制定时重启设备。 -

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

在设备升级或其他需要重新启动设备的场景下,为了不影响当前设备的运行,可以设置在未来的某一时刻重新启动设备,此时可以使用该命令将设备设置在业务量少的时间点进行定时重新启动。

注意事项

  • 如果schedule reboot at命令设置了具体的日期(YYYY/MM/DD)参数,而且参数表示的是将来的日期,则设备将在设定时间点重新启动。如果没有指定具体的日期参数,分为两种情况:设置的时间点在当前时间之后,设备在当天的该时间点重新启动;设置的时间点在当前时间之前,设备在第二天的该时间点重新启动。

  • 设置的日期与当前日期相比,差值不能大于720小时。另外,如果以前有相应的设置,则直接覆盖原有信息。

  • 执行schedule reboot delay interval命令设置设备重启前等待的时间时,如果不指定force参数,系统首先会将当前配置与配置文件进行比较,如果不一致,则会提示是否保存当前配置,用户进行选择后系统又将提示用户确认设置的定时重启时间,键入“Y”或者“y”后,设置生效。如果指定force参数,则系统不会出现任何提示,强制设置生效,当前配置不会被比较及保存。
  • 当设备通过schedule reboot命令设置了定时重启功能,如果通过clock datetime命令修改系统时间在定时重启时间点之后,且时间差大于10分钟,此时系统会取消定时重启功能;如果时间差小于或等于10分钟,设备会立即重启,并且配置不会保存。

  • 在一般情况下,请勿使用该命令,否则时间到达定时重启时间点后,设备进行重启将导致整个设备业务中断。

  • 在重启设备时,要确认配置文件是否已经保存了。

使用实例

# 设置设备在当天晚上22:00重新启动。

<HUAWEI> schedule reboot at 22:00
Info: The system is now comparing the configuration, please wait.
Warning: The configuration has been modified, and it will be saved to the next startup saved-configuration file flash:/vrpcfg.cfg. Continue? [Y/N]:y
Now saving the current configuration to the slot 7....
Save the configuration successfully.
Now saving the current configuration to the slot 8.
Save the configuration successfully.
Info: Reboot system at 22:00:00 2012/06/10 UTC+06:00(in 6 hours and 6 minutes)
confirm?[Y/N]:y 

set save-configuration

命令功能

set save-configuration命令用来设置系统定时保存配置的功能。

undo set save-configuration命令用来取消定时保存配置的功能。

缺省情况下,系统不启动定时保存配置的功能。

命令格式

set save-configuration [ interval interval | cpu-limit cpu-usage | delay delay-interval ] *

undo set save-configuration [ interval | cpu-limit | delay ] *

undo set save-configuration [ interval interval | cpu-limit cpu-usage | delay delay-interval ] *

参数说明

参数 参数说明 取值
interval interval 指定定时保存配置时间间隔。 整数形式,取值范围是30~43200,单位是分钟。缺省值是30分钟。
cpu-limit cpu-usage

指定定时自动保存时CPU占用率阈值。

整数形式,取值范围是1~60。缺省值是50。
delay delay-interval 指定配置变更发生后,系统自动备份配置的延时时间。 整数形式,取值范围是1~60,单位是为分钟。缺省值是5分钟。delay-interval的取值必须小于interval的值。

视图

系统视图

缺省级别

3:管理级

使用指南

应用场景

为了防止设备掉电或者意外重启导致配置文件的丢失,通过本命令可设置自动保存配置文件功能。

如果没有执行命令set save-configuration,则系统不启动自动保存功能。

如果执行了命令set save-configuration,系统在定时保存配置之前会比较配置文件,如果配置没有改变则不会执行定时保存。

  • 如果需要指定定时保存配置时间间隔,则指定参数interval interval,如果有配置发生变更但没有保存配置,则系统保存当前配置,否则不保存。缺省情况下,系统自动保存配置的时间间隔是0,即不启动定时自动保存配置功能。使能自动保存功能后,如果不指定interval,缺省值是30分钟。

  • 为了防止自动保存影响系统性能,可以配置参数cpu-limit cpu-usage自动保存时系统CPU使用率上限。在自动保存定时器触发时,检测到系统的CPU占用率高于配置的值,系统就会取消本次自动保存。缺省情况下,配置自动保存时系统CPU的使用率上限是50%。
  • 若需要指定系统自动备份配置的延时时间,则选择参数delay delay-interval,当配置发生变化时,系统将在设置的延时时间后自动保存配置。缺省值是5分钟。

如果执行命令undo set save-configuration,表示去使能自动保存功能。如果后面带有关键字,则表示将相应的参数值恢复为默认值,其他自动保存功能依然生效。

后续任务

可执行命令display saved-configuration configuration,查看到系统定时保存功能的相关配置情况。

注意事项

系统在定时保存配置文件之前,会查看配置文件情况,发生如下情况会触发定时保存:
  • 配置文件与上次保存的不同。
  • 配置文件与上次保存的相同,但是期间有过改动。例如执行了某条命令后,又删除了该命令,配置文件虽然与之前相同,但是也会触发定时保存。
配置系统定时自动保存功能后,将会把配置文件保存在下次启动配置文件中,配置文件内容会因配置变化而变化。当出现如下情况时,系统会取消定时保存配置文件的操作:
  • 当前存在写配置文件操作。
  • 接口板正在进行配置恢复。
  • CPU利用率较高。

自动保存时,如果接口板不在位,相关的配置可能会丢失。

使用实例

# 配置系统定时保存新配置的时间间隔为60分钟。

<HUAWEI> system-view
[HUAWEI] set save-configuration interval 60

# 设置系统配置发生变化3分钟后,以10小时为保存间隔,自动保存新配置,且CPU使用率上限为60%。

<HUAWEI> system-view
[HUAWEI] set save-configuration interval 600 delay 3 cpu-limit 60

set save-configuration backup-to-server server

命令功能

set save-configuration backup-to-server server命令用来设置定时保存配置文件至服务器。

undo set save-configuration backup-to-server server命令用来取消设置定时保存配置文件至服务器。

缺省情况下,系统关闭定时保存配置文件至服务器功能。

命令格式

set save-configuration backup-to-server server server-ip [ vpn-instance vpn-instance-name ] transport-type { ftp | sftp } [ port port-number ] user user-name password password [ path path ]

set save-configuration backup-to-server server server-ip [ vpn-instance vpn-instance-name ] transport-type tftp [ path path ]

undo set save-configuration backup-to-server server [ server-ip [ vpn-instance vpn-instance-name ] ]

参数说明

参数

参数说明

取值

server server-ip 指定定时保存系统配置的服务器IP地址。 -
vpn-instance vpn-instance-name 指定VPN实例的名称。 必须是已存在的VPN实例名称。
port port-number 指定服务器的端口号。

整数形式,取值范围是1~65535。缺省情况下,FTP服务器的端口是21,SFTP服务器的端口号是22。

transport-type 指定配置文件传输到服务器的方式。 取值可以是ftp、sftp或tftp。为了保证传输文件的安全性,请使用sftp文件传输方式。
user user-name 指定访问服务器的用户名。 字符串形式,不支持空格,区分大小写,长度范围是1~64。

当输入的字符串两端使用双引号时,可在字符串中输入空格。

password password 指定访问服务器的用户密码。 字符串形式,不支持空格,区分大小写,简单口令长度范围是1~16,密文密码长度范围是24、32或48

当输入的字符串两端使用双引号时,可在字符串中输入空格。

path path 指定服务器存储的相对路径。

如果不指定该参数,则缺省为服务器开启FTP、SFTP或TFTP服务的根路径。

字符串形式,不支持空格,区分大小写,长度范围是1~64。

当输入的字符串两端使用双引号时,可在字符串中输入空格。

视图

系统视图

缺省级别

3:管理级

使用指南

应用场景

为防止未能及时保存配置,而导致的系统配置丢失等相关情况,用户可以定时保存配置文件至服务器。

系统在定时保存配置之前会比较配置文件,如果配置没有改变则不会执行定时保存。

注意事项

服务器存储路径如果不存在,配置文件将发送不成功,系统将向网管上报告警,并在设备上记录日志。

访问服务器的用户名和密码为以FTP或SFTP方式登录服务器的用户名和密码。

说明:
  • 执行本命令保存配置文件至服务器时,系统只支持二进制传输模式,服务器端需支持二进制传输模式。
  • 配置此命令前,需执行命令set save-configuration启动定时保存配置的功能,否则不会保存配置文件至服务器。
  • FTP和TFTP为不安全的传输协议,建议配置SFTP协议。
  • 一个服务器IP地址可以与多个VPN实例绑定;当删除指定VPN实例的配置时,必须指定vpn-instance-name参数,如果不指定vpn-instance-name参数,则会删除不带VPN实例的配置。

使用实例

# 设置自动保存的服务器信息,传输方式为SFTP。

<HUAWEI> system-view
[HUAWEI] set save-configuration backup-to-server server 10.1.1.1 transport-type sftp user admin1234 password Helloworld@6789

snmp-agent trap enable feature-name configuration

命令功能

snmp-agent trap enable feature-name configuration命令用来打开Configuration模块的告警开关。

undo snmp-agent trap enable feature-name configuration命令用来关闭Configuration模块的告警开关。

缺省情况下,Configuration模块告警开关的状态请参见命令display snmp-agent trap feature-name configuration all

命令格式

snmp-agent trap enable feature-name configuration [ trap-name { hwcfgb2soperate | hwcfgb2stransferfail | hwcfgmaneventlog | hwcfgoperatecompletion | hwcfgrestorefail } ]

undo snmp-agent trap enable feature-name configuration [ trap-name { hwcfgb2soperate | hwcfgb2stransferfail | hwcfgmaneventlog | hwcfgoperatecompletion | hwcfgrestorefail } ]

参数说明

参数

参数说明

取值

trap-name Configuration模块的指定类型事件的告警开关。 -
hwcfgb2soperate 使能设备开始将配置文件备份到服务器时发送Trap信息。 -
hwcfgb2stransferfail 使能设备备份当前配置文件到服务器失败时发送Trap信息。 -
hwcfgmaneventlog 使能设备当系统配置发生事件改变时发送Trap信息。 -
hwcfgoperatecompletion 使能设备当系统配置备份完成时发送Trap信息。 -
hwcfgrestorefail 使能设备当系统配置保存失败时发送Trap信息。 -

视图

系统视图

缺省级别

2:配置级

使用指南

Configuration没有海量告警开关。如果只打开某个或几个事件的告警开关时,请选择trap-name

用户可通过display snmp-agent trap feature-name configuration all查看配置结果。

使用实例

# 使能设备当系统配置发生事件改变时发送Trap信息。

<HUAWEI> system-view
[HUAWEI] snmp-agent trap enable feature-name configuration trap-name hwcfgmaneventlog

snmp-agent trap enable feature-name datasync

命令功能

snmp-agent trap enable feature-name datasync命令用来打开DataSync模块的告警开关。

undo snmp-agent trap enable feature-name datasync命令用来关闭DataSync模块的告警开关。

缺省情况下,DataSync模块的告警开关处于打开状态。

命令格式

snmp-agent trap enable feature-name datasync [ trap-name hwcfgchgnotify ]

undo snmp-agent trap enable feature-name datasync [ trap-name hwcfgchgnotify ]

参数说明

参数 参数说明 取值
trap-name DataSync模块的指定类型事件的告警开关。 -
hwcfgchgnotify 使能设备当系统配置变更时发送Trap信息。 -

视图

系统视图

缺省级别

2:配置级

使用指南

DataSync没有海量告警开关。如果只打开某个或几个事件的告警开关时,请选择trap-name

使用实例

# 使能设备当系统配置变更时发送Trap信息。

<HUAWEI> system-view
[HUAWEI] snmp-agent trap enable feature-name datasync trap-name hwcfgchgnotify

startup saved-configuration

命令功能

startup saved-configuration命令用来配置系统下次启动时使用的配置文件。

命令格式

startup saved-configuration configuration-file [ slot slot-id | chassis chassis-number ]

参数说明

参数 参数说明 取值
configuration-file 指定配置文件的文件名,此文件必须存在。

字符串形式,不支持空格,区分大小写,命名规范为*.zip或者*.cfg,长度范围是5~48

文件名不能包含%。

slot slot-id

指定槽位号。

整数形式,取值范围以实际设备为准。
chassis chassis-number

指定集群ID。

整数形式,取值范围为1~2。

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

由于软件升级等原因,导致原配置文件不再适用时,可以执行startup saved-configuration命令,重新指定系统下次启动时使用的配置文件,而且系统启动配置文件必须存放在存储设备的根目录下。

后续任务

执行reboot命令或者schedule reboot命令重新启动设备。

注意事项

  • 系统下次启动指定的配置文件必须存在。

  • 配置文件必须以“.zip”或者“.cfg”作为扩展名,其中:
    • “.cfg”为纯文本格式,可直接查看其内容。指定为配置文件后,启动时系统对里面的命令逐条进行恢复。
    • “.zip”是“.cfg”的压缩格式,占用空间较小。指定为配置文件后,启动时先解压成“.cfg”格式,然后逐条恢复。
  • 当指定的配置文件,在备用主控板上已经存在同名文件时,系统会提示是否覆盖已有文件。
  • 用户请勿自行手动修改配置文件,并指定为下次启动时的配置文件,否则可能会造成设备启动异常。

使用实例

# 配置下次启动使用的配置文件。

<HUAWEI> startup saved-configuration vrpcfg.cfg
Info: Succeeded in setting the configuration for booting system.

startup system-software

命令功能

startup system-software命令用来配置系统下次启动时使用的系统软件。

命令格式

startup system-software system-file [ all | slot slot-id | slave-board | chassis chassis-number { master | slave } ]

参数说明

参数 参数说明 取值
system-file 指定系统软件的文件名。

字符串形式。格式为[ drive-name ][ file-name ],长度范围是4~48。不支持空格和“%”,区分大小写。如果未指定drive-name,则此值为默认的存储器名。

all 指定所有主控板下次启动时使用的系统软件。 -
slave-board 指定备用主控板下次启动时使用的系统软件。 -
slot slot-id

指定槽位号。

整数形式,取值范围以实际设备为准。
chassis chassis-number 指定集群机框ID。 整数形式,取值范围为1~2。
master 指定框的主用主控板。 -
slave 指定框的备用主控板。 -

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

在进行系统软件升级或降级场景中,需要执行此命令指定下次启动时使用的系统软件。

后续任务

执行reboot命令或者schedule reboot命令重新启动设备。

注意事项

  • 如果指定的系统软件是V200R010及之前版本,BootLoad密码需要恢复为默认值,否则会降级失败。通过startup system-software命令行操作时,设备会有提示并在用户确认后方才清除现有密码。
  • 系统软件必须以“.cc” 作为扩展名,而且必须存放在存储器的根目录下。
  • 使用startup system-software命令设置设备下一次启动的系统软件时,设备会对系统软件的完整性进行校验。如果系统软件的数字签名不合法,设置将会失败。请确保系统软件来源的合法性。
  • 当使用slave-board参数指定备用主控板,或者使用all参数指定所有主控板的系统软件时,设备会自动从主用主控板拷贝系统软件至备用主控板,无需再执行copy source-filename destination-filename命令进行拷贝。如果指定的系统软件在备用主控板上已存在,设备会提示是否覆盖,但是已经指定为设备下次启动使用的系统软件禁止覆盖,设备会放弃自动拷贝。
  • 当使用startup system-software 命令指定备用主控板下次启动使用的系统软件时,如果备用主控板存储空间不足,设备会自动删除无用系统软件。
  • 若版本间不能进行升级或降级,系统会给出提示信息,请按相关提示操作。
  • 对于主用主控板、备用主控板,要求系统软件的文件名一致,否则无法重启。指定主、备板的系统软件文件名时,不区分大小写,即便用户输入的是大写字母,系统会自动以小写字母识别进行保存。
  • 如果是双主控,必须在主用主控板和备用主控板上同时配置下次启动使用的系统软件。
说明:

设置系统下次启动使用的系统软件文件名时,需要对系统文件进行校验,因此需要等待一段时间。

使用实例

# 配置下次启动使用的系统软件。

<HUAWEI> startup system-software basicsoft.cc

startup patch

命令功能

startup patch命令用来指定设备下次启动时使用的补丁文件。

命令格式

startup patch patch-name [ all | slave-board | slot slot-id | chassis chassis-number { master | slave } ]

参数说明

参数 参数说明 取值
patch-name

指定下次启动的补丁文件名。

字符串形式,区分大小写,不支持空格,格式为[ drive-name ] [ path ] [ file-name ],长度范围是5~48。如果未指定drive-name,则此值为默认的存储器名。

slave-board

指定备用主控板下次启动时使用的补丁文件。

-
all 指定所有集群机框 -
slot slot-id 指定槽位号。 整数形式,取值范围以实际设备为准。
chassis chassis-number 指定集群机框ID。 整数形式,取值范围为1~2。
master 指定框的主用主控板。 -
slave 指定框的备用主控板。 -

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

如果用户希望设备重新启动后加载运行补丁文件,并使之生效,则可以执行本命令指定下次启用的补丁文件。

后续任务

执行reboot命令或者schedule reboot命令重新启动设备。

注意事项

  • 补丁文件以“.pat”为扩展名,且必须将下次启动的补丁文件保存至根目录。
  • 本命令是可覆盖型命令,如果用户再次使用本命令重新指定下次启用的补丁,则上一次的信息将被覆盖。
  • 指定补丁文件名后,可执行命令display patch-information查看补丁文件。
    • 如果下次启动补丁文件不为空,则下次启动后系统会自动加载该补丁。
    • 如果下次启动补丁文件为空,则下次启动后系统无法加载补丁。
  • 执行完本命令,当设备重新启动后,系统将在所有单板上加载补丁并运行补丁。如果用户希望系统重新启动后不自动启用该补丁文件,则可以使用以下两种方法:

使用实例

# 指定下次启动的补丁文件。

<HUAWEI> startup patch patch.pat
翻译
下载文档
更新时间:2019-04-08

文档编号:EDOC1100065708

浏览量:10060

下载量:198

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页