所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R013C00 命令参考

本文档介绍了设备中各特性的配置命令,包括每条命令的功能、格式、参数、视图、缺省级别、使用指南、举例和相关命令。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
VLAN配置命令

VLAN配置命令

命令支持情况

默认所有款型均支持本章节命令,如有个别命令行或参数存在差异,请详见具体命令行中的说明。

bandwidth(VLANIF接口视图)

命令功能

bandwidth命令用来设置VLANIF接口的带宽。

undo bandwidth命令用来取消配置的VLANIF接口的带宽。

缺省情况下,网管在MIB上获取的接口带宽与接口类型有关,VLANIF接口的带宽是1000兆比特/秒。

命令格式

bandwidth bandwidth

undo bandwidth

参数说明

参数 参数说明 取值
bandwidth 指定VLANIF接口的带宽。 整数形式,单位是兆比特/秒,取值范围是1~1000000。

视图

VLANIF接口视图

缺省级别

2:配置级

使用指南

应用场景

该命令配置主要用于网管在MIB上获取带宽,不改变接口实际带宽。网管可以通过IF-MIB中的ifSpeedifHighSpeed两个节点查看此配置:
  • 如果配置的带宽值小于4000兆比特/秒,则MIB节点ifSpeedifHighSpeed分别显示bandwidth×1000×1000和bandwidth

  • 如果配置的带宽值大于4000兆比特/秒,则MIB节点ifSpeedifHighSpeed分别显示4294967295(0XFFFFFFFF)和bandwidth

注意事项

此配置为覆盖式配置,以最后一次配置为准。

使用实例

# 设置VLANIF2接口的带宽为10000兆比特/秒。

<HUAWEI> system-view
[HUAWEI] vlan 2
[HUAWEI-vlan2] quit
[HUAWEI] interface vlanif 2
[HUAWEI-Vlanif2] bandwidth 10000

damping time

命令功能

damping time命令用来配置由于VLAN变为Down状态而触发VLANIF变为Down的延迟时间。

undo damping time命令用来恢复VLANIF变为Down的延迟时间为0秒。

缺省情况下,延迟时间为0秒,即当VLAN Down时立即触发VLANIF变为Down状态。

命令格式

damping time delay-time

undo damping time

参数说明

参数

参数说明

取值

delay-time

VLANIF变为Down的延迟时间。

整数形式,取值范围是0~20,单位是秒。缺省值为0。

视图

VLANIF接口视图

缺省级别

2:配置级

使用指南

应用场景

交换机升级或者主备倒换等情况容易导致VLANIF接口状态变化频繁,从而引起的网络震荡,在VLANIF接口上使用damping time命令配置VLAN Damping功能可以抑制这种情况。

当VLAN中所有成员接口变为Down状态后,设备会延迟delay-time秒后再将Down事件上报给VLANIF接口。

注意事项

在VLAN中所有成员接口变为Down状态后delay-time秒内,VLAN中有成员接口状态又变为Up,则VLANIF接口状态保持Up不变。

使用display interface vlanif命令可查看VLANIF变为Down的延迟时间。

在同一接口下多次使用damping time命令配置延迟时间,按最后一次配置生效。

使用实例

# 配置VLAN10向VLANIF10上报Down的延迟时间为10秒。

<HUAWEI> system-view
[HUAWEI] vlan 10
[HUAWEI-vlan10] quit
[HUAWEI] interface vlanif 10
[HUAWEI-Vlanif10] damping time 10

description(VLAN视图)

命令功能

description命令用来配置VLAN的描述信息。

undo description命令用来恢复VLAN的描述信息为缺省值。

缺省情况下,VLAN的描述信息中体现了VLAN的编号,例如VLAN2的描述信息为:“VLAN 0002”。

命令格式

description description

undo description

参数说明

参数

参数说明

取值

description

配置VLAN的描述信息。

字符串形式,支持空格,区分大小写,长度范围是1~80。

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

为了方便管理和识别VLAN,也为了方便用户记忆,可以使用description命令配置描述信息来标识VLAN。

使用display vlan vlan-id verbose查看指定VLAN的描述信息。

注意事项

为了方便用户区分VLAN,不同的VLAN应该配置不同的描述信息。

该命令为覆盖式命令,在同一VLAN接口视图下多次使用description命令配置描述信息,按最后一次配置生效。

使用实例

# 配置VLAN2的描述信息为“Huawei”。

<HUAWEI> system-view
[HUAWEI] vlan 2
[HUAWEI-vlan2] description Huawei
相关主题

description(VLANIF接口视图)

命令功能

description命令用来配置VLANIF接口的描述信息。

undo description命令用来恢复VLANIF接口的描述信息为缺省值。

命令格式

description description

undo description

参数说明

参数

参数说明

取值

description

配置VLANIF接口的描述信息。

字符串形式,支持空格,区分大小写,长度范围是1~242。

视图

VLANIF接口视图

缺省级别

2:配置级

使用指南

应用场景

为了方便用户管理和识别VLANIF接口,也为了方便用户记忆,可以使用description(VLANIF接口视图)命令配置描述信息来标识VLANIF接口,记录VLANIF接口的用途。

使用display interface vlanif命令可查看VLANIF接口的描述信息。

注意事项

为了方便用户识别VLANIF接口,建议用户输入的描述信息应具有一定的意义。

为了方便用户区分VLANIF接口,不同的VLANIF接口应该配置不同的描述信息。

该命令为覆盖式命令,在同一VLANIF接口视图下多次使用description命令配置描述信息,按最后一次配置生效。

使用实例

# 配置接口VLANIF2的描述信息为“Huawei”。

<HUAWEI> system-view
[HUAWEI] vlan 2
[HUAWEI-vlan2] quit
[HUAWEI] interface vlanif 2
[HUAWEI-Vlanif2] description Huawei

display default-parameter vlan

命令功能

display default-parameter vlan命令用来查看VLAN的缺省配置参数。

命令格式

display default-parameter vlan vlan-id

参数说明

参数 参数说明 取值
vlan-id 显示指定VLAN的缺省配置参数。 整数形式,取值范围是1~4094

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

设备上创建了大量VLAN,且各个VLAN中配置了不同特性。用户需要了解VLAN的缺省配置参数,此时可通过本命令查询指定VLAN的缺省配置参数值。

前置条件

查询的指定VLAN已经成功创建。

注意事项

VLAN的缺省配置参数不会随VLAN的配置发生变化。

使用实例

# 查看VLAN10的缺省配置参数。

<HUAWEI> display default-parameter vlan 10
  VLAN ID             : 10
  Type                : Common
  Status              : undo shutdown
  Broadcast           : Forward
  Unknown-Multicast   : Forward
  Unknown-Unicast     : Forward
  Statistics          : Disable
  MAC learning        : Enable
  Property            : Default
  Description         : VLAN 0010
表5-40  display default-parameter vlan命令输出信息描述

项目

描述

VLAN ID

标识VLAN ID。

Type

标识VLAN类型。

Common:普通VLAN

Status

标识VLAN的使能状态。

undo shutdown:VLAN处于使能状态。

Broadcast

标识广播报文的处理方式。

Forward:转发广播报文。

Unknown-Multicast

标识未知组播报文的处理方式。

Forward:转发未知组播报文。

Unknown-Unicast

标识未知单播报文的处理方式。

Forward:转发未知单播报文。

Statistics

标识VLAN的统计功能:

Disable:去使能VLAN统计功能。

MAC learning

标识MAC地址学习功能。

Enable:使能MAC地址学习功能。

Property

标识VLAN属性。

Default:普通VLAN。

Description

标识VLAN的描述信息。

display interface vlanif

命令功能

display interface vlanif命令用来查看VLANIF接口的状态信息、配置信息和统计信息。

命令格式

display interface vlanif [ vlan-id | main ]

参数说明

参数

参数说明

取值

vlan-id

指定查看VLANIF接口对应的VLAN编号。

整数形式,取值范围根据已创建的VLANIF接口范围而定,可键入“?”获取。

main

显示VLANIF接口的状态和统计信息。

VLANIF接口没有子接口,无论是否指定main参数,都会显示VLANIF接口的状态信息和统计信息。

-

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

在监控接口的状态或检查接口的故障原因时,可执行display interface vlanif命令获取接口的状态信息、配置信息和统计信息。用户可以根据这些信息进行接口的故障诊断等。

前置条件

已在设备上创建VLANIF接口。

注意事项

执行display interface vlanif命令时,如果不指定任何参数,表示查看所有VLANIF接口的信息。

使用实例

# 查看接口VLANIF3的状态信息。

<HUAWEI> display interface vlanif 3
Vlanif3 current state : UP
Line protocol current state : UP
Last line protocol up time : 2012-08-03 03:54:16
Description: 
Route Port,The Maximum Transmit Unit is 1500
Internet Address is 192.168.1.1/24 
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 000b-0913-fc0b
Current system time: 2012-02-10 11:24:14 
Last 300 seconds input rate 0 bits/sec, 0 packets/sec                           
Last 300 seconds output rate 0 bits/sec, 0 packets/sec                          
Input:  0 packets, 0 bytes                                                      
Output:  0 packets, 0 bytes
    Input bandwidth utilization  : --                                           
    Output bandwidth utilization : --                                                     
                             
表5-41  display interface vlanif命令输出信息描述表

项目

描述

current state

VLANIF接口状态:
  • DOWN表示关闭VLANIF接口。
  • UP打开表示开启VLANIF接口。

Line protocol current state

VLANIF接口的链路层协议状态:
  • DOWN表示关闭VLANIF接口的链路层协议。
  • UP表示开启VLANIF接口的链路层协议。

Last line protocol up time

接口的协议状态最近一次变为Up的时间。

Description

VLANIF接口的描述信息。

该参数可以通过命令description(接口视图)配置。

Route Port

显示接口是三层接口。

The Maximum Transmit Unit

VLANIF接口的最大传输单元。

该参数可以通过命令mtu(接口视图)配置。

Internet Address

IP地址。当VLANIF接口上未配置IP地址时,系统显示“Internet protocol processing : disabled”。

该参数可以通过命令ip address配置。

IP Sending Frames' Format

IP协议发送帧格式,包括PKTFMT_ETHNT_2,Ethernet_802.3,Ethernet_SNAP。

Hardware address

MAC地址。

Last 300 seconds input/output rate

前300秒内通过接口接收和发送的比特速率和报文速率。

说明:
只有使用statistic enable(VLANIF接口视图)命令配置了VLANIF接口流量统计功能后,该字段才显示。

Current system time

当前系统时间。

如果配置了时区且处于夏令时,时间显示格式为YYYY/MM/DD HH:MM:SS±HH:MM。

Input/Output

通过接口发送和接收的字节数和报文数。

说明:
只有使用statistic enable(VLANIF接口视图)命令配置了VLANIF接口流量统计功能后,该字段才显示。

Input/Output bandwidth utilization

接口接收/发送方向带宽利用率。

display ip-subnet-vlan vlan

命令功能

display ip-subnet-vlan vlan命令用来查看VLAN上所配置的IP子网信息。

命令格式

display ip-subnet-vlan vlan { all | vlan-id1 [ to vlan-id2 ] }

参数说明

参数

参数说明

取值

all

查看所有VLAN上所配置的IP子网信息。

-

vlan-id1 [ to vlan-id2 ]

查看指定VLAN上所配置的IP子网信息。 其中:
  • vlan-id1表示第一个VLAN的编号。
  • to vlan-id2表示最后一个VLAN的编号。vlan-id2的取值必须大于等于vlan-id1的取值,它和vlan-id1共同确定一个范围。如果不指定to vlan-id2参数,则只查看编号为vlan-id1的VLAN。
  • vlan-id1为整数形式,取值范围是1~4094
  • vlan-id2为整数形式,取值范围是1~4094

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

配置基于IP子网划分VLAN的功能后,通过display ip-subnet-vlan vlan命令可检查IP子网VLAN的配置是否正确。

可查看的信息包括:基于IP子网划分的VLAN ID、IP子网的索引、IP子网的地址、IP子网的掩码。

执行本命令时:

  • 如果选择参数all,查看所有VLAN上所配置的IP子网信息。
  • 如果选择参数vlan vlan-id,查看指定VLAN上所配置的IP子网信息。
  • 如果选择参数vlan-id1 to vlan-id2 ,查看指定范围的VLAN上所配置的IP子网信息。

注意事项

如果没有使用ip-subnet-vlan命令配置VLAN与IP子网关联,则执行display ip-subnet-vlan vlan命令时不显示任何数据。

使用实例

# 查看当前所有IP子网VLAN的信息。

<HUAWEI> display ip-subnet-vlan vlan all
----------------------------------------------------------------
 Vlan    Index   IpAddress           SubnetMask          Priority
 ----------------------------------------------------------------
 2       12      192.168.1.1         255.255.255.0       3
 ----------------------------------------------------------------
 ip-subnet-vlan count: 1                  total count: 1
表5-42  display ip-subnet-vlan vlan命令输出信息描述

项目

描述

Vlan

基于IP子网划分的VLAN ID。

该参数可以通过命令ip-subnet-vlan配置。

Index

IP子网的索引。

该参数可以通过命令ip-subnet-vlan配置。

IpAddress

IP子网的地址。

该参数可以通过命令ip-subnet-vlan配置。

SubnetMask

IP子网的掩码。

该参数可以通过命令ip-subnet-vlan配置。

Priority

指定IP地址或网段对应VLAN的802.1p优先级。

该参数可以通过命令ip-subnet-vlan配置。

display lnp

命令功能

display lnp interface命令用来查看运行LNP协议的二层接口自协商的状态信息。

命令格式

display lnp { interface interface-type interface-number | summary }

参数说明

参数 参数说明 取值
interface interface-type interface-number

查看指定二层以太网接口链路类型自协商的状态信息。

-
summary

查看二层设备上所有接口链路类型自协商的简要状态信息。

-

视图

所有视图

缺省级别

1:监控级

使用指南

链路类型自协商功能使能后,如果需要查看协商后的二层接口类型、流量统计等信息,可通过display lnp查看。

在监控使能了链路类型自协商功能的二层接口的状态或检查该接口的故障原因时,可通过命令display lnp获取该接口的状态信息和用户报文的统计信息。根据获取的接口状态信息和用户报文统计信息进行故障诊断。

使用实例

# 查看指定二层接口自协商的状态信息。

<HUAWEI> display lnp interface gigabitethernet1/0/1
LNP information for GigabitEthernet1/0/1:
  Port link type: trunk
  Negotiation mode: desirable
  Hello timer expiration(s): 19
  Negotiation timer expiration(s): 0
  Trunk timer expiration(s): 289
  FSM state: trunk

  Packets statistics
  4 packets received
    0 packets dropped
      bad version: 0, bad TLV(s): 0, bad port link type: 0,
      bad negotiation state: 0, other: 0
  5 packets output
    0 packets dropped
      other: 0
表5-43  display lnp interface命令输出信息描述

项目

描述

LNP information for

查看链路类型自协商的状态信息的二层以太网接口。

Port link type

二层以太网接口链路类型。包括:
  • Trunk
  • Access
  • Hybrid
  • dot1q-tunnel

Negotiation mode

链路类型自协商的方式,可通过命令port link-type设置。包括:
  • desirable
  • auto
  • on
  • off

Hello timer expiration(s)

Hello定时器超时时间。

Negotiation timer expiration(s)

协商定时器超时时间。

Trunk timer expiration(s)

Trunk定时器超时时间。

FSM state

LNP状态机状态。

Packets statistics

LNP报文统计信息。

packets received

接收的LNP报文数。

packets dropped

丢弃的LNP报文数。

bad version

丢弃的错误版本的LNP报文数。

bad TLV(s)

丢弃的错误TLV的LNP报文数。

bad port link type

丢弃的协商结果错误的LNP报文数。

bad negotiation state

丢弃的协商状态错误的LNP报文数。

other

丢弃的其他类型的错误的LNP报文数。

packets output

发送的LNP报文数。

# 查看二层设备上所有接口自协商的状态信息。

<HUAWEI> display lnp summary
Global LNP : Negotiation enable
------------------------------------------------------------------------------- 
C: Configured; N: Negotiated; *: Negotiation disable;                           
Port         link-type(C)   link-type(N)   InDropped   OutDropped  FSM          
------------------------------------------------------------------------------- 
GE1/0/0   desirable      access                 0            0  off          
GE1/0/1   desirable      access                 0            0  off          
GE1/0/2   desirable      access                 0            0  off          
GE1/0/3   desirable      access                 0            0  off          
GE1/0/4   desirable      access                 0            0  off          
GE1/0/5   desirable      access                 0            0  off          
GE1/0/6   desirable      access                 0            0  off          
GE1/0/7   desirable      access                 0            0  off          
GE1/0/8   desirable      access                 0            0  off          
GE1/0/9   desirable      access                 0            0  off          
GE1/0/10  desirable      access                 0            0  off          

表5-44  display lnp summary命令输出信息描述

项目

描述

Global LNP

系统视图下LNP使能状态,可通过命令lnp disable设置。

Port

查看链路类型自协商的状态信息的二层以太网接口。

link-type(C)

链路类型自协商的方式,可通过命令port link-type设置。

link-type(N)

二层以太网接口链路类型自协商的结果。

InDropped

二层以太网接口入方向丢弃的LNP报文数。

OutDropped

二层以太网接口出方向丢弃的LNP报文数。

FSM

LNP状态机状态。有四种状态:access、trunk、on、off。

display mac-vlan

命令功能

display mac-vlan命令用来查看基于MAC地址划分VLAN的配置信息。

命令格式

display mac-vlan { mac-address { all | mac-address [ mac-address-mask | mac-address-mask-length ] } | vlan vlan-id }

参数说明

参数

参数说明

取值

all

显示所有MAC地址VLAN划分信息。

-

mac-address mac-address

显示指定MAC地址的VLAN划分信息。

格式为H-H-H,其中H为1至4位的十六进制数。

mac-address-mask

MAC地址掩码。

格式为H-H-H,其中H为1至4位的十六进制数。

mac-address-mask-length

MAC地址掩码长度。

整数形式,取值范围是1~48。

vlan vlan-id

显示指定MAC-VLAN的配置信息。

整数形式,取值范围是1~4094

视图

所有视图

缺省级别

1:监控级

使用指南

在基于MAC地址划分VLAN后,可以通过display mac-vlan命令检查MAC-VLAN的配置是否正确。

执行本命令时:

  • 如果选择参数mac-address mac-address,可以按MAC地址查看对应MAC-VLAN的配置信息。
  • 如果选择参数mac-address all,可以查看到所有MAC-VLAN配置信息。
  • 如果选择参数vlan vlan-id,可以查看到指定MAC-VLAN配置信息。

使用实例

# 查看所有MAC地址划分VLAN的配置信息。

<HUAWEI> display mac-vlan mac-address all
---------------------------------------------------------------
MAC Address     MASK            VLAN    Priority
---------------------------------------------------------------
0022-0033-0044  ffff-ffff-ffff  200     0

Total MAC VLAN address count: 1

表5-45  display mac-vlan命令输出信息描述

项目

描述

MAC Address

MAC地址。

该参数可以通过命令mac-vlan mac-address配置。

MASK

MAC地址的掩码。

该参数可以通过命令mac-vlan mac-address配置。

VLAN

基于MAC地址划分的VLAN。

该参数可以通过命令mac-vlan mac-address配置。

Priority

指定MAC地址对应VLAN的802.1p优先级。

该参数可以通过命令mac-vlan mac-address配置。

display policy-vlan

命令功能

display policy-vlan命令用来查看策略VLAN的配置信息。

命令格式

display policy-vlan { all | vlan vlan-id }

参数说明

参数

参数说明

取值

all

显示所有策略VLAN的配置信息。

-

vlan vlan-id

显示指定VLAN的配置信息。

整数形式,取值范围是1~4094

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

在基于MAC地址和IP地址组合策略划分VLAN(配置策略VLAN)后,可以使用本命令查看相关配置信息是否正确。可查看的信息包括:源MAC地址、源IP地址、应用策略VLAN的接口、策略VLAN ID、策略VLAN的优先级。

执行本命令时:

  • 如果选择参数all,查看所有策略VLAN的配置信息。
  • 如果选择参数vlan vlan-id,查看指定策略VLAN的配置信息。

注意事项

如果没有使用policy-vlan命令配置策略VLAN,则执行display policy-vlan命令时没有任何显示信息。

使用实例

# 查看策略VLAN的配置信息。

<HUAWEI> display policy-vlan all
 ------------------------------------------------------------------------
 MacAddress      IPAddress         Port                  Vlan    Priority
 ------------------------------------------------------------------------
 0003-0003-0003  10.2.2.2          GigabitEthernet1/0/1  6       4
 0002-0002-0002  10.1.1.1          NA                    8       6
 ------------------------------------------------------------------------
Total Policy-VLAN count: 2 
表5-46  display policy-vlan命令输出信息描述

项目

描述

MacAddress

指定策略VLAN依据的源MAC地址。

该参数可以通过命令policy-vlan配置。

IPAddress

指定策略VLAN依据的源IP地址。

该参数可以通过命令policy-vlan配置。

Port

指定应用MAC地址和IP地址组合策略的接口。

该参数可以通过命令policy-vlan配置。

Vlan

基于MAC地址和IP地址组合策略划分的VLAN ID。

该参数可以通过命令policy-vlan配置。

Priority

指定MAC地址和IP地址组合策略对应VLAN的802.1p优先级。

该参数可以通过命令policy-vlan配置。

相关主题

display port vlan

命令功能

display port vlan命令用来查看VLAN中包含的接口信息。

命令格式

display port vlan [ interface-type interface-number | active ] *

参数说明

参数 参数说明 取值
interface-type interface-number 显示VLAN中包含指定接口类型和编号的接口信息。

如果不指定接口,则显示VLAN中包含的所有接口信息。

-

active 显示VLAN中包含动态表项的接口信息。

设备上VLAN-PORT的实时关系,该关系由Voice VLAN、GVRP(GARP VLAN registration protocol )等业务或协议决定。

-

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

当需要查看当前接口所属的VLAN是静态配置还是通过动态协议或业务分配,可通过display port vlan命令获取接口、VLAN对应信息。当指定接口出现故障,用户可以根据这些信息进行接口的故障诊断。

前置条件

已经成功创建VLAN,且二层接口已经成功加入指定VLAN。

注意事项

当设备上存在大量的接口、VLAN对应信息,使用本命令查看信息时,推荐通过指定接口或参数active对显示信息进行过滤。否则可能因为显示信息内容过多而导致:
  • 终端屏幕不停地刷新而无法获取需要的信息。
  • 系统长时间的信息遍历和检索,造成系统无响应。

使用实例

# 查询设备上所有VLAN包含的接口信息。

<HUAWEI> display port vlan
Port                           Link Type    PVID  Trunk VLAN List
-------------------------------------------------------------------------------
GigabitEthernet1/0/1           hybrid       1     -
GigabitEthernet1/0/2           hybrid       1     -
# 查询设备上所有动态表项信息。
<HUAWEI> display port vlan active
T=TAG U=UNTAG
-------------------------------------------------------------------------------
Port             Link Type    PVID    VLAN List
-------------------------------------------------------------------------------
GE1/0/3          hybrid       2        T: 10
GE1/0/4          trunk        10       T: 100
说明:

通过业务口连接方式组建集群时,将业务口配置为物理成员端口后,物理成员端口不会显示在display port vlandisplay port vlan active的回显中。

表5-47  display port vlan命令输出信息描述

项目

描述

Port

接口类型和编号。

Link Type

接口链路类型:
  • access
  • trunk
  • hybrid
  • dot1q-tunnel
  • desirable
  • auto

该参数可以通过命令port link-type配置。

说明:

对于Eth-Trunk成员接口,Link Type显示的值为“-”。

PVID

接口所属的缺省VLAN ID。缺省情况下,所有接口的缺省VLAN为VLAN1。

对于配置为Access类型和dot1q类型以及协商为Access类型的接口,可以通过命令port default vlan配置接口的缺省VLAN。对于配置为Hybrid类型的接口,可以通过命令port hybrid pvid vlan配置接口的缺省VLAN。对于配置为Trunk类型以及协商为Trunk类型的接口,可以通过命令port trunk pvid vlan配置接口的缺省VLAN。

说明:

对于Eth-Trunk成员接口,PVID显示的值为0。

Trunk VLAN List

  • 接口动态加入的VLAN ID。
  • 静态配置允许通过的VLAN ID。

VLAN List

静态配置允许通过的VLAN ID。

display protocol-vlan interface

命令功能

display protocol-vlan interface命令用来查看接口关联基于协议划分VLAN的配置信息。

命令格式

display protocol-vlan interface { all | interface-type interface-number }

参数说明

参数

参数说明

取值

all

查看所有接口关联基于协议划分VLAN的配置信息。

-

interface-type interface-number

查看指定接口关联基于协议划分VLAN的配置信息。
  • interface-type:表示接口类型。
  • interface-number:表示接口编号。

-

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

接口关联协议VLAN配置成功后,通过本命令可以按照指定接口类型和编号查看接口关联基于协议划分VLAN的配置信息。

注意事项

如果没有使用protocol-vlan vlan命令配置接口关联协议VLAN,则执行display protocol-vlan interface命令时没有任何显示信息。

使用实例

# 查看接口GE1/0/1关联基于协议划分VLAN的配置信息。

<HUAWEI> display protocol-vlan interface gigabitethernet 1/0/1
-------------------------------------------------------------------------------
 Interface                VLAN    Index        Protocol Type           Priority
-------------------------------------------------------------------------------
 GigabitEthernet1/0/1     2       2            ipv4                    4   
表5-48  display protocol-vlan interface命令输出信息描述

项目

描述

Interface

关联基于协议划分VLAN的接口。

该参数可以通过命令protocol-vlan vlan配置。

VLAN

基于协议划分的VLAN ID。

该参数可以通过命令protocol-vlan vlan配置。

Index

协议的索引值。

该参数可以通过命令protocol-vlan vlan配置。

Protocol Type

协议的类型。

该参数可以通过命令protocol-vlan配置。

Priority

指定协议对应VLAN的802.1p优先级。

该参数可以通过命令protocol-vlan配置。

display protocol-vlan vlan

命令功能

display protocol-vlan vlan命令用来查看VLAN上所配置的协议及协议索引。

命令格式

display protocol-vlan vlan { all | vlan-id1 [ to vlan-id2 ] }

参数说明

参数

参数说明

取值

all

查看所有基于协议划分的VLAN信息。

-

vlan-id1 [ to vlan-id2 ]

查看基于协议划分的指定VLAN信息。

  • vlan-id1表示第一个VLAN的编号。
  • vlan-id2表示最后一个VLAN的编号。

vlan-id1为整数形式,取值范围是1~4094。

vlan-id2为整数形式,取值范围是1~4094。vlan-id2的取值必须大于等于vlan-id1的取值。

视图

所有视图

缺省级别

1:监控级

使用指南

基于协议划分VLAN功能配置成功后,可以通过本命令查看protocol-VLAN显示表项信息。

使用实例

# 查看当前所有协议VLAN的协议信息及协议的索引。

<HUAWEI> display protocol-vlan vlan all
----------------------------------------------------------------
 VLAN           Protocol Index    Protocol Type
----------------------------------------------------------------
 2              2                 ipv4                              
表5-49  display protocol-vlan vlan命令输出信息描述

项目

描述

VLAN

基于协议划分的VLAN ID。

该参数可以通过命令protocol-vlan配置。

Protocol Index

协议的索引值。

该参数可以通过命令protocol-vlan配置。

Protocol Type

协议的类型。

该参数可以通过命令protocol-vlan配置。

display vlan

命令功能

display vlan命令用来查看VLAN的相关信息。

命令格式

display vlan [ vlan-id [ verbose | statistics [ slot slot-id ] ] ]

display vlan [ vlan-id1 [ to vlan-id2 ] ]

display vlan summary [ slot slot-id ]

display vlan vlan-name vlan-name [ statistics | verbose ]

参数说明

参数

参数说明

取值

vlan-id

查看编号是vlan-id的VLAN的信息。

整数形式,取值范围是1~4094

vlan-id1 [ to vlan-id2 ]

查看编号是vlan-id1 [ to vlan-id2 ]的VLAN段的信息。

其中:
  • vlan-id1表示第一个VLAN的编号。
  • to vlan-id2表示最后一个VLAN的编号。vlan-id2的取值必须大于等于vlan-id1的取值,它和vlan-id1共同确定一个范围。如果不指定to vlan-id2参数,则只查看编号为vlan-id1的VLAN。
  • vlan-id1为整数形式,取值范围是1~4094
  • vlan-id2为整数形式,取值范围是1~4094

slot slot-id

显示指定槽位的VLAN流量统计或汇总信息。

整数形式,根据系统提示的在位槽位号确定。

statistics

查看指定VLAN的接口流量统计信息。

如果在VLAN视图下使能了流量统计功能,使用命令display vlan vlan-id statistics能查看到VLAN的流量统计信息。

-

summary

查看所有VLAN的汇总信息。

-

verbose

查看指定VLAN的详细信息。如果不指定verbose,显示VLAN的简要信息。

-

vlan-name vlan-name 显示指定VLAN名称的VLAN信息。

字符串形式,区分大小写,不支持空格,取值范围是1~31。

当输入的字符串两端使用双引号时,可在字符串中输入空格。

视图

所有视图

缺省级别

1:监控级

使用指南

应用场景

当需要查看VLAN的配置信息,或需了解通过接口的报文收发情况时,使用本命令。

display vlan vlan-id命令查看的是实际生效的端口,配置的端口可使用display vlan vlan-id verbose命令查看。

前置条件

执行display vlan vlan-id statistics命令在查看VLAN的接口流量统计信息前,需要先在该VLAN视图下执行statistic enable(VLAN视图)命令打开VLAN的流量统计功能。

注意事项

如果不指定任何可选参数,则显示所有VLAN的基本信息。

使用实例

# 查看所有已经创建的VLAN的基本信息。

<HUAWEI> display vlan
The total number of VLANs is : 4                                              
--------------------------------------------------------------------------------
U: Up;         D: Down;         TG: Tagged;         UT: Untagged;               
MP: Vlan-mapping;               ST: Vlan-stacking;                              
#: ProtocolTransparent-vlan;    *: Management-vlan;                             
--------------------------------------------------------------------------------
                                                                                
VID  Type    Ports                                                              
--------------------------------------------------------------------------------
1    common  UT:GE1/0/1(D)    GE1/0/2(D)    GE1/0/3(D)    GE1/0/4(D)    GE1/0/5(D)    GE1/0/6(D)    GE1/0/7(D)    GE1/0/8(D)    GE1/0/9(D)    GE1/0/10(D)    GE1/0/11(D)     
9    common  TG:GE1/0/11(U)    GE1/0/12(D)    GE1/0/13(D)    Eth-Trunk1(U)   
                Eth-Trunk2(D)                                                   
40   common                                                                     
50   mux     TG:GE1/0/14(D)     GE1/0/15(D)                                      

VID  Status  Property      MAC-LRN Statistics Description                       
--------------------------------------------------------------------------------
1    enable  default       enable  disable    VLAN 0001                         
9    enable  default       enable  disable    VLAN 0009                  
40   enable  default       enable  disable    VLAN 0040                         
50   enable  default       enable  disable    VLAN 0050                         

# 查看VLAN100的详细信息。

<HUAWEI> display vlan 100 verbose
* : Management-VLAN
---------------------
  VLAN ID                     : 100
  VLAN Name                   :
  VLAN Type                   : Common
  Description                 : VLAN 0100
  Status                      : Enable
  Broadcast                   : Enable
  MAC Learning                : Enable
  Smart MAC Learning          : Disable
  Current MAC Learning Result : Enable
  Statistics                  : Disable
  Property                    : Default
  VLAN State                  : Down
  ----------------
  Tagged        Port: GigabitEthernet1/0/1
  ----------------
  Active  Tag   Port: GigabitEthernet1/0/1
-------------------
Interface            Physical
GigabitEthernet1/0/1                   DOWN

#查看VLAN10的接口流量统计信息。如果VLAN10内没有加入任何接口,则Slot部分不会显示。

<HUAWEI> display vlan 10 statistics
 Total                                                                          
 VLAN : 10                                                                      
 -------------------------------------------------------------------------------
 Item                                        Packets                       Bytes
                                                 pps                         bps
 -------------------------------------------------------------------------------
 Inbound                                           0                           0
                                                   0                           0
 Outbound                                          0                           0
                                                   0                           0
 -------------------------------------------------------------------------------
 Slot : 1                                                                       
 VLAN : 10                                                                      
 -------------------------------------------------------------------------------
 Item                                        Packets                       Bytes
                                                 pps                         bps
 -------------------------------------------------------------------------------
 Inbound                                           0                           0
                                                   0                           0
 Outbound                                          0                           0
                                                   0                           0
 -------------------------------------------------------------------------------

# 查看系统中所有VLAN的汇总信息。

<HUAWEI> display vlan summary
Static VLAN:                                                                    
Total 3 static VLAN.                                                            
  1 9 to 10                                                                     
                                                                                
Dynamic VLAN:                                                                   
Total 0 dynamic VLAN.                                                           
                                                                                
Reserved VLAN:
Total 5 reserved VLAN.
  Rrpp reserved:
  3000 to 3001
  Sep reserved:
  3100
  VLAN-switch reserved:
  123
  Subif reserved:
  211
表5-50  display vlan命令输出信息描述

项目

描述

VID或VLAN ID

VLAN编号。

Type或VLAN Type

VLAN类型:
  • mux:MUX VLAN中的主VLAN。

  • mux-sub:MUX VLAN中的从VLAN。

  • super:VLAN聚合中的Super VLAN。

  • sub:VLAN聚合中的子VLAN。

  • common:普通VLAN。

  • *Common:管理VLAN。

  • #:协议透传VLAN。

  • dynamic:动态VLAN。

Ports

加入该VLAN的接口。

VLAN Name

标识VLAN名称。

Description

VLAN的描述信息。

Status

当前VLAN状态,VLAN状态为Enable

Broadcast

广播功能:
  • Disable表示禁止在本VLAN内广播。
  • Enable表示允许在本VLAN内广播。

MAC Learning或MAC-LRN

标识是否使能MAC地址学习功能:
  • Disable:去使能MAC地址学习功能。

  • Enable:使能MAC地址学习功能。

Smart MAC Learning

标识是否使能MAC地址灵活学习功能:
  • Disable:去使能MAC地址灵活学习功能。

  • Enable:使能MAC地址灵活学习功能。

Current MAC Learning Result

标识当前MAC地址学习结果。

Statistics

流量统计功能:
  • Disable表示关闭流量统计功能。
  • Enable表示开启流量统计功能。

Property

VLAN属性:
  • Default表示缺省VLAN。
  • MulticastVlan表示组播VLAN。
  • UserVlan表示用户VLAN。

VLAN State

标识VLAN的状态。
  • Up
  • Down

VLAN的状态由VLAN中的成员口的状态决定。只有当VLAN中成员口的状态为Up,VLAN的状态才为Up。

Tagged/Untagged Port

手动加入本VLAN的接口,分为Tagged和Untagged方式。

Active Tag/Active Untag Port

加入本VLAN的活动的接口,分为Tagged和Untagged。

Inbound

入方向总的流量。

Outbound

出方向总的流量。

Static VLAN

设备上静态创建的VLAN。

Dynamic VLAN

设备上动态学习到的VLAN。

Reserved VLAN

保留VLAN,即用于其他功能的VLAN。

VLAN-switch reserved

被VLAN Switch功能占用的VLAN。只有设备上存在用于VLAN Switch功能的VLAN时,才会显示该字段。

Subif reserved

被子接口占用的VLAN。只有设备上存在被子接口占用的VLAN时,才会显示该字段。

Rrpp reserved

被RRPP功能占用的VLAN。只有设备上存在被RRPP功能占用的VLAN时,才会显示该字段。

Sep reserved

被SEP功能占用的VLAN。只有设备上存在被SEP功能占用的VLAN时,才会显示该字段。

interface vlanif

命令功能

interface vlanif命令用来创建VLANIF接口并进入VLANIF接口视图。

undo interface vlanif命令用来删除VLANIF接口。

缺省情况下,VLANIF接口没有被创建。

命令格式

interface vlanif vlan-id

undo interface vlanif vlan-id

参数说明

参数

参数说明

取值

vlan-id

指定待创建VLANIF接口所对应的VLAN的编号。

整数形式,取值范围是1~4094

设备支持4094个VLANIF接口。

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

当设备需要与网络层的设备通信时,可以在设备上创建基于VLAN的逻辑接口,即VLANIF接口。VLANIF接口是网络层接口,可以配置IP地址。借助VLANIF接口,设备就能与其它网络层的设备互相通信。

后续任务

使用ip address配置VLANIF接口的IP地址。

注意事项

  • VLANIF接口Up的必要条件是:
    • VLANIF接口对应的VLAN,必须已经创建。
    • 必须有Up的物理接口或Eth-Trunk接口加入VLANIF对应的VLAN。
  • 创建某VLAN对应的VLANIF接口后,该VLAN不能再用作子接口配置的VLAN。

  • 如果VLANIF接口已经存在,interface vlanif命令只用来进入VLANIF接口视图。
  • 当VLANIF接口作为telnet连接设备的管理VLANIF时,用户接入VLAN和管理VLAN不能共用,否则可能会导致设备telnet连接不上。

使用实例

# 创建接口VLANIF2,并进入VLANIF2接口视图。

<HUAWEI> system-view
[HUAWEI] vlan 2
[HUAWEI-vlan2] quit 
[HUAWEI] interface vlanif 2
[HUAWEI-Vlanif2]

ip-subnet-vlan

命令功能

ip-subnet-vlan命令用来基于IP子网划分VLAN。

undo ip-subnet-vlan命令用来删除基于IP子网划分的VLAN。

缺省情况下,没有配置基于IP子网划分VLAN。

命令格式

ip-subnet-vlan [ ip-subnet-index ] ip ip-address { mask | mask-length } [ priority priority ]

undo ip-subnet-vlan { ip-subnet-index [ to ip-subnet-end ] | all }

参数说明

参数

参数说明

取值

ip-subnet-index

指定IP子网索引值。子网索引可以由用户指定,也可由系统根据IP子网划分VLAN的顺序自动编号产生。

整数形式,取值范围是1~12。

ip ip-address { mask | mask-length }

指定基于IP子网划分VLAN依据的源IP地址或网络地址。其中:
  • ip-address表示源IP地址或网络地址。

  • mask表示子网掩码。

  • mask-length表示掩码长度。

  • ip-address:采用点分十进制格式。

  • mask:采用点分十进制格式。

  • mask-length:采用整数形式,取值范围是0~32。

priority priority

指定IP地址或网段对应VLAN的802.1p优先级。

整数形式,取值范围是0~7,值越大优先级越高。缺省值是0。

to ip-subnet-end

指定IP子网索引的终止值。

整数形式,取值范围是1~12。其值必须大于等于ip-subnet-index的值。

all

指定该VLAN关联的所有IP子网。

-

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

基于IP子网划分VLAN,将指定网段或IP地址与VLAN相关联,使该网段或IP地址发出的报文在相应的VLAN中传输。当网络中同一子网的业务类型相同时,基于IP子网划分VLAN可以大大减少了人工配置VLAN的工作量,同时可以自由地增加、移动和修改用户。

后续任务

配置接口允许基于IP子网的VLAN通过、使能接口基于IP子网划分VLAN功能。

注意事项

该命令为累增式命令,多次使用ip-subnet-vlan命令关联IP地址与VLAN,配置结果按多次累加生效。

说明:
  • 基于IP子网划分的VLAN一定不能是RRPP的控制VLAN。

  • IP网段或IP地址不能配置为组播网段或组播地址。

使用实例

# 将VLAN3配置为基于IP子网划分的VLAN,与10.10.10.0/24网段进行关联,使得源地址为该网段的报文可以分发到VLAN3中传输。

<HUAWEI> system-view
[HUAWEI] vlan 3
[HUAWEI-vlan3] ip-subnet-vlan ip 10.10.10.0 255.255.255.0

ip-subnet-vlan enable

命令功能

ip-subnet-vlan enable命令用来使能接口基于IP子网划分VLAN的功能。

undo ip-subnet-vlan enable命令用来去使能接口基于IP子网划分VLAN的功能。

缺省情况下,接口没有使能基于IP子网划分VLAN的功能。

命令格式

ip-subnet-vlan enable

undo ip-subnet-vlan enable

参数说明

视图

Ethernet接口视图、GE接口视图、XGE接口视图、端口组视图、Eth-Trunk视图、40GE接口视图、100GE接口视图

缺省级别

2:配置级

使用指南

应用场景

基于IP子网划分VLAN,将指定网段或IP地址与VLAN相关联,使该网段或IP地址发出的报文在相应的VLAN中传输。当网络中同一子网的业务类型相同时,基于IP子网划分VLAN可以大大减少了人工配置VLAN的工作量,同时可以自由地增加、移动和修改用户。

如果接口采用基于IP子网划分VLAN的机制:
  • 当接口收到Untagged报文时,会以报文的源IP为根据去匹配IP子网VLAN表项。如果匹配成功,则按照匹配到的VLAN ID和优先级进行转发。如果匹配失败,则按照优先级选择其它匹配原则进行匹配。
  • 当接口收到Tagged报文时,按照基于接口划分VLAN进行转发。

注意事项

在Access口和Trunk口上,只有基于IP子网划分的VLAN和PVID相同时,才可以正常使用。所以基于IP子网划分VLAN推荐在Hybrid口上配置。

设备同时支持多种方式划分VLAN时,按各种方式的优先级进行VLAN划分。

使用实例

# 使能基于IP子网划分VLAN的功能。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] ip-subnet-vlan enable

lnp disable

命令功能

lnp disable命令用来全局去使能链路类型自协商功能。

undo lnp disable命令用来全局使能链路类型自协商功能。

缺省情况下,二层设备上所有接口的链路类型自协商功能处于使能状态。

命令格式

lnp disable

undo lnp disable

参数说明

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

缺省情况下,二层设备上所有接口都使能了链路类型自协商功能。当支持链路类型自协商功能的二层设备和不支持链路类型自协商功能的二层设备互通时,支持链路类型自协商功能的二层设备会不断发送自协商报文,浪费带宽。如果需要将二层设备上所有接口的链路类型自协商功能去使能,可通过命令lnp disable基于设备去使能链路类型自协商功能。

也可在二层以太网接口视图下执行命令port negotiation disable,基于接口去使能链路类型自协商功能。

注意事项

  • V200R005C00之前版本升级到V200R005C00及后续版本时,设备将自动执行命令lnp disable全局去使能链路类型自协商功能。

  • 缺省情况下,二层设备上所有接口都使能了链路类型自协商功能。如果在系统视图下执行命令lnp disable,将去使能二层设备上所有接口的链路类型自协商功能。即使在二层以太网接口视图下执行命令undo port negotiation disable也无法使能链路类型自协商功能。

  • 在系统视图下执行命令lnp disable后,设备重启前对业务没有影响,设备重启后只有命令port default vlan指定的VLAN二层转发可通,其他VLAN二层转发不通。缺省情况下,接口的配置是port default vlan 1,即只有VLAN 1二层转发可通。

  • 为了保证链路类型自协商功能生效,必须保证设备和二层以太网接口的链路类型自协商功能都处于使能状态。

使用实例

# 全局去使能链路类型自协商功能。

<HUAWEI> system-view
[HUAWEI] lnp disable

mac-learning smart vlan enable

命令功能

mac-learning smart vlan enable命令用来使能指定VLAN内MAC地址灵活学习功能。

undo mac-learning smart vlan enable命令用来去使能指定VLAN内MAC地址灵活学习功能。

缺省情况下,去使能VLAN内MAC地址灵活学习功能。

命令格式

mac-learning smart vlan { vlan-id1 [ to vlan-id2 ] } &<1-10> enable

undo mac-learning smart vlan { vlan-id1 [ to vlan-id2 ] } &<1-10> enable

参数说明

参数 参数说明 取值
vlan-id1 指定VLAN ID的下限值。 整数形式,取值范围是1~4094
to vlan-id2 指定VLAN ID的上限值。 整数形式,取值范围是1~4094vlan-id2的值必须大于等于vlanid1

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

目前,在组建企业网时,网络拓扑结构通常采用环状或树形结构。不管采用哪种拓扑结构,都需要汇聚层设备能够支持学习大量的MAC地址表项,以满足大量下挂用户的需求。

随着网络中用户数量的不断增加,设备支持的MAC地址表项规格已经无法满足实际需求,导致部分用户的MAC地址无法被学习到,从而导致用户报文在VLAN内以广播形式传输报文,占用网络带宽,影响网络性能。

为了解决上述问题,可在系统视图下执行本命令使能指定VLAN内接口数量小于等于2个时,系统自动关闭该VLAN内的MAC地址学习功能,以节省学习MAC地址表项所占用的资源。

前置条件

若使本命令生效,必须完成以下操作:
  1. 通过命令vlan创建指定VLAN。若设备支持动态VLAN,则指定VLAN可以不通过命令vlan创建。
  2. 在VLAN视图下执行命令undo mac-address learning disable ,使能MAC地址学习功能。

注意事项

使能指定VLAN内MAC地址灵活学习功能后,系统将清除该VLAN内的MAC地址表项。当VLAN内接口数大于2个时,系统自动使能该VLAN内MAC地址学习功能。如果此VLAN配置为MUX-VLAN或此VLAN用于VLAN Stacking、VLAN Mapping功能中的外层VLAN,则VLAN内MAC地址灵活学习功能将不生效。

该命令是累增式命令,多次配置时,配置结果按多次累加生效。

使用实例

# 当VLAN10内接口个数小于等于2个时,关闭VLAN内MAC地址学习功能。

<HUAWEI> system-view
[HUAWEI] undo mac-learning smart vlan 10 enable
相关主题

mac-vlan enable

命令功能

mac-vlan enable命令用来使能接口的MAC VLAN功能。

undo mac-vlan enable命令用来去使能接口的MAC VLAN功能。

缺省情况下,接口的MAC VLAN功能未使能。

命令格式

mac-vlan enable

undo mac-vlan enable

参数说明

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、端口组视图、Eth-Trunk视图

缺省级别

2:配置级

使用指南

应用场景

当用户对安全和移动性需求较高时,可以使用mac-vlan mac-address命令配置基于MAC划分VLAN。用户在变换物理位置后不需要重新划分VLAN,提高了终端用户的安全性和接入的灵活性。若想使通过接口的报文按照基于MAC地址划分的VLAN转发,必须使用mac-vlan enable命令使能接口的MAC VLAN功能。

若接口接收的报文按照基于MAC地址划分的VLAN转发。
  • 当接口收到Untagged报文时,接口会以报文的源MAC地址去匹配MAC-VLAN表项。如果匹配成功,则按照匹配到的VLAN ID进行转发;如果匹配失败,则按照优先级选择其他匹配原则继续进行匹配。
  • 当收到Tagged报文时,按照基于接口划分VLAN进行转发。

注意事项

在Access口和Trunk口上,只有基于MAC划分的VLAN和PVID相同时,才可以正常使用。所以基于MAC地址划分VLAN推荐在Hybrid口上配置。

接口不能同时使能MAC VLAN功能和MUX VLAN功能。

接口不能同时使能MAC VLAN功能和MAC认证功能。

设备同时支持多种方式划分VLAN时,按各种方式的优先级进行VLAN划分。

使能接口的MAC VLAN功能与NAC功能相冲突,不能在同一接口下配置mac-vlan enablemac-authendot1x enableweb-auth-serverauthentication-profile命令。

使用实例

# 使能接口GE1/0/1的MAC VLAN功能。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] mac-vlan enable

mac-vlan mac-address

命令功能

mac-vlan mac-address命令用来配置MAC地址与VLAN关联。

undo mac-vlan mac-address命令用来取消MAC地址与VLAN关联。

缺省情况下,MAC地址与VLAN没有关联。

命令格式

mac-vlan mac-address mac-address [ mac-address-mask | mac-address-mask-length ] [ priority priority ]

undo mac-vlan mac-address { all | mac-address [ mac-address-mask | mac-address-mask-length ] }

参数说明

参数

参数说明

取值

mac-address

指定与VLAN关联的MAC地址。

格式为H-H-H。其中H为4位的十六进制数,可以输入1~4位,如00e0、fc01。当输入不足4位时,表示前面的几位为0,如:输入e0,等同于00e0。MAC地址不可设置为0000-0000-0000、FFFF-FFFF-FFFF和组播地址。

mac-address-mask

指定MAC地址掩码。

格式为H-H-H,其中H为1至4位的十六进制数。

mac-address-mask-length

指定MAC地址掩码长度。

整数形式,取值范围是1~48。

priority priority

指定MAC地址对应VLAN的802.1p优先级。

整数形式,取值范围是0~7,值越大优先级越高。缺省值是0。

all

指定与VLAN关联的所有MAC地址。

-

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

当用户对安全和移动性需求较高时,可以配置基于MAC划分VLAN。基于MAC划分VLAN指将MAC地址与VLAN关联,按照报文的源MAC地址来定义VLAN成员,将指定报文加入该VLAN的Tag后发送。用户在变换物理位置时,不需要重新划分VLAN,提高了终端用户的安全性和接入的灵活性。

可以指定MAC地址对应VLAN的802.1p优先级,用于当交换机阻塞时,优先发送优先级高的数据包。

后续任务

配置接口允许基于MAC地址的VLAN通过、使能接口基于MAC地址划分VLAN的功能。

注意事项

  • 使用mac-vlan mac-address命令关联VLAN和MAC地址,若多条配置指定的mac-address相同,则MAC-VLAN的匹配规则如下:在X系列单板上,按照掩码的最长匹配规则生效,48位掩码的MAC-VLAN优先级高于其他所有掩码的MAC-VLAN;在其他单板上,只有当掩码低于等于47位时MAC-VLAN按最长匹配规则生效,48位掩码的MAC-VLAN优先级低于其他所有掩码的MAC-VLAN

  • 一个MAC地址关联了MAC VLAN后,则不可以再用于配置其它MAC VLAN。

  • 多次使用mac-vlan mac-address命令关联MAC地址与VLAN,配置结果按多次累加生效。

  • 交换机整机支持1024个MAC-VLAN。其中带掩码的MAC-VLAN最多支持100个。MAC-VLAN总数 = 配置的MAC-VLAN数 * 下发接口数。

使用实例

# 配置MAC地址22-33-44与VLAN100关联。

<HUAWEI> system-view
[HUAWEI] vlan 100
[HUAWEI-vlan100] mac-vlan mac-address 22-33-44

management-vlan

命令功能

management-vlan命令用来将VLAN配置为管理VLAN。

undo management-vlan命令用来取消配置VLAN为管理VLAN。

缺省情况下,该VLAN没有配置为管理VLAN。

命令格式

management-vlan

undo management-vlan

参数说明

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

当用户通过远端网管集中管理设备时,需要在设备上通过VLANIF接口配置IP地址作为设备管理IP,通过管理IP来Stelnet到设备上进行管理。若设备上其他接口相连的用户加入该VLAN,也可以访问该设备,增加了设备的不安全因素。

使用management-vlan命令配置VLAN为管理VLAN后,不允许Access类型和Dot1q-tunnel类型接口加入该VLAN。由于Access类型和Dot1q-tunnel类型通常用于连接用户,限制这种类型接口加入管理VLAN后,与该接口相连的用户就无法访问该设备,从而增加了设备的安全性。

后续任务

配置管理VLAN的VLANIF接口、配置IP地址。

注意事项

VLAN1不能配置为管理VLAN。

执行命令display vlan,可以看到管理VLAN的配置信息,带有*的VLAN为管理VLAN。

配置VLAN为管理VLAN后,加入该VLAN的接口必须为Trunk或Hybrid类型。

使用实例

# 配置VLAN100为管理VLAN。

<HUAWEI> system-view
[HUAWEI] vlan 100
[HUAWEI-vlan100] management-vlan
相关主题

name(VLAN视图)

命令功能

name命令用来创建VLAN名称。

undo name命令用来删除已经创建的VLAN名称。

缺省情况下,没有创建VLAN的名称。

命令格式

name vlan-name

undo name

参数说明

参数 参数说明 取值
vlan-name 指定VLAN名称。 字符串形式,区分大小写,不支持空格,长度范围是1~31。当输入的字符串两端使用双引号时,可在字符串中输入空格。

视图

VLAN视图

缺省级别

2:配置级

使用指南

如果一台设备上同时部署了多个VLAN用于传输不同的业务,为了便于业务管理,可在对应的VLAN视图下通过name命令为VLAN命名以区分不同的业务。用户通过不同的VLAN名称能够快速了解业务的部署情况。

VLAN名称配置成功后,若用户需要查看或修改指定VLAN下的配置,用户可以通过在系统视图下执行命令vlan vlan-name直接进入对应的VLAN视图进行修改或查看。

使用实例

# VLAN2用于传输语音业务,为VLAN2创建名称是voice。

<HUAWEI> system-view
[HUAWEI] vlan 2
[HUAWEI-vlan2] name voice
相关主题

ping mac

命令功能

ping mac命令用来检测当前设备和目的设备之间的连通性,这种检测称为通用MAC Ping。

命令格式

ping mac mac-address vlan vlan-id [ interface interface-type interface-number | -c count | -s packetsize | -t timeout | -p priority-value ] *

参数说明

参数 参数说明 取值
mac-address 指定目的节点的MAC地址。
MP的MAC地址可以是桥MAC,也可以是MP所在接口的MAC。这取决于目的设备MP的MAC地址模式的配置。
  • 如果目的设备配置的MP的MAC地址模式为共享MAC模式,参数mac-address表示桥MAC。

  • 如果目的设备配置的MP的MAC地址模式为独立MAC模式,参数mac-address为MP所在接口的MAC或者桥MAC。

目的节点可以是MIP,也可以是MEP。格式为H-H-H,其中H为1至4位的十六进制数。不能为广播MAC地址或组播MAC地址。
vlan vlan-id 指定VLAN ID。 整数形式,VLAN ID的取值范围是1~4094
interface interface-type interface-number 指定本设备发送ping报文的出接口,其中:
  • interface-type表示接口类型。

  • interface-number表示接口编号。

如果指定本参数,且接口在指定VLAN内则直接从该接口发出Ping报文。

如果不指定本参数,设备首先根据指定的目的MAC地址VLAN查询MAC地址转发表,如果:

  • 如果查询到对应的转发表项,按该表项发送Ping报文;

  • 如果未查询到对应的转发表项,在该VLAN内广播Ping报文。

-
-c count 指定Ping的次数。 整数形式,取值范围是1~4294967295。缺省值是5。
-s packetsize 指定发送的Ping报文的大小。在802.1ag draft7版本中该大小是指去掉二层报文头后的报文大小。在standard2007版本中该大小为报文的大小。 整数形式,取值范围是95~9000,单位是字节,缺省值是95。
-t timeout 指定等待应答报文的超时时间。 整数形式,取值范围是1~65535,单位是ms,缺省值是2000ms。
-p priority-value Ping报文的优先级。 整数形式,取值范围是0~7。缺省值是7。

视图

所有视图

缺省级别

0:参观级

使用指南

应用场景

当需要使用通用MAC Ping检测设备之间连通性时,可以使用本命令。

前置条件

使用本命令时,通用MAC Ping功能必须处于使能状态,否则需首先使用ping mac enable命令使能通用MAC Ping功能。

注意事项

通用MAC Ping不需要由MEP发起,目的节点也不需要是MEP或MIP,即在源设备、中间设备和目的设备上均不需要配置MD、MA和MEP就可以进行通用MAC Ping。但是需要指定目的节点所属的VLAN。

使用实例

# Ping某个设备两次。Ping报文大小为112字节。该设备属于VLAN10。该设备的MAC地址是0001-0300-0204。

<HUAWEI> system-view
[HUAWEI] ping mac enable
[HUAWEI] ping mac 0001-0300-0204 vlan 10 -c 2 -s 112
Pinging 0001-0300-0204 with 112 bytes of data:
Reply from 0001-0300-0204: byte = 112 time = 9ms
Reply from 0001-0300-0204: byte = 112 time = 11ms
Packets: Sent = 2, Received = 2, Lost = 0 (0% Loss)
Minimum = 9ms, Maximum = 11ms, Average = 10ms
表5-51  ping mac命令输出信息描述表

项目

描述

Reply from 0001-0300-0204: byte = 112 time = 9ms

目的设备回复的应答报文的大小和响应时间。

当响应时间不足1ms时,显示time < 1ms。

Packets:Sent = 2,Received = 2,Lost = 0 (0% Loss)

发送Ping报文的数量;接收应答报文的数量;丢弃报文的数量和百分比。

Minimum

最小往返响应时间。

Maximum

最大往返响应时间。

Average

平均往返响应时间。

ping mac enable

命令功能

ping mac enable命令用来使能通用MAC Ping功能。

undo ping mac enable命令用来禁止通用MAC Ping功能。

缺省情况下,通用MAC Ping功能处于禁止状态。

命令格式

ping mac enable

undo ping mac enable

参数说明

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

当需要使用以下功能时,需要使用本命令使能通用MAC Ping功能。

  • 进行通用MAC Ping操作。

  • 使设备对接收到的通用MAC Ping报文进行回复。

使用实例

# 使能通用MAC Ping功能。

<HUAWEI> system-view
[HUAWEI] ping mac enable

policy-vlan

命令功能

policy-vlan命令用来基于策略划分VLAN,同时可配置划分后的VLAN的802.1p优先级。

undo policy-vlan命令用来删除基于策略划分的VLAN。

缺省情况下,没有配置基于策略划分VLAN。

命令格式

policy-vlan mac-address mac-address ip ip-address [ interface interface-type interface-number ] [ priority priority ]

undo policy-vlan { all | mac-address mac-address ip ip-address [ interface interface-type interface-number ] }

参数说明

参数

参数说明

取值

mac-address mac-address

指定策略VLAN依据的源MAC地址。

格式为H-H-H。其中H为4位的十六进制数,可以输入1~4位,如00e0、fc01。当输入不足4位时,表示前面的几位为0,如:输入e0,等同于00e0。MAC地址不可设置为0000-0000-0000、FFFF-FFFF-FFFF和组播地址。

ip ip-address

指定策略VLAN依据的源IP地址。

格式为点分十进制格式。

interface interface-type interface-number

指定应用MAC地址和IP地址组合策略的接口。
  • interface-type表示接口类型。

  • interface-number表示接口的编号。

如果不指定该参数,MAC地址和IP地址组合策略将应用到指定VLAN中所有的接口上;如果指定该参数,MAC地址和IP地址组合策略只应用到指定VLAN中指定的接口上。

-

priority priority

指定策略对应VLAN的802.1p优先级。

整数形式,取值范围是0~7,值越大优先级越高。缺省值是0。

all

指定MAC地址和IP地址组合策略划分的所有VLAN。

-

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

策略VLAN是一种基于MAC地址和IP地址组合策略的VLAN划分方式。当用户主机需要经常变换地点且网络安全性需求很高时,可以部署策略VLAN。

当接口收到Untagged报文时,接口会以报文的源IP地址和源MAC地址去匹配策略VLAN表项。

  • 如果匹配成功,则按照匹配到的VLAN ID和优先级进行转发。
  • 如果匹配失败,则按照其它匹配原则继续进行匹配。

基于策略划分VLAN仅对Untagged报文生效,当收到Tagged报文按照基于接口划分VLAN进行转发。

注意事项

一个MAC地址或IP地址关联了策略VLAN后,不可以再用于配置其它策略VLAN。

多次使用policy-vlan命令,配置结果按多次累加生效。

使用实例

# 配置基于组合策略划分VLAN依据的MAC地址是0–1–1,IP地址是10.1.1.1,对应VLAN的802.1p优先级是7。

<HUAWEI> system-view
[HUAWEI] vlan 2
[HUAWEI-vlan2] policy-vlan mac-address 0-1-1 ip 10.1.1.1 priority 7

port

命令功能

port命令用来配置接口的缺省VLAN并加入该VLAN。

undo port命令用来恢复接口缺省VLAN为缺省值并退出该VLAN。

缺省情况下,所有接口的缺省VLAN ID为1。

命令格式

port interface-type { interface-number1 [ to interface-number2 ] } &<1-10>

undo port interface-type { interface-number1 [ to interface-number2 ] } &<1-10>

参数说明

参数

参数说明

取值

interface-type { interface-number1 [ to interface-number2 ] }

配置缺省VLAN的接口,其中:
  • interface-type表示接口类型。
  • interface-number1表示第一个接口的编号。
  • interface-number2表示最后一个接口的编号。interface-number2的取值必须大于interface-number1的取值,它和interface-number1共同确定一个接口范围。

如果不指定to interface-number2参数,则只创建interface-number1所指定的接口。一条port命令中,最多可以使用10次to形式输入接口范围。

-

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

用户主机发出的帧都是Untagged帧,接口从对端设备收到的帧也有可能是Untagged的,但所有以太网帧在设备中都是以Tagged的形式处理转发的,因此设备必须给接口收到的Untagged帧加上Tag。为了实现此目的,必须配置接口的缺省VLAN。当该接口收到Untagged帧时给它加上该接口缺省VLAN的VLAN Tag。

如果配置了接口的缺省VLAN ID:
  • 当接口接收到不带VLAN Tag的报文时,对于Access类型和QinQ类型接口,均将该报文打上缺省的VLAN Tag。
  • 当接口接收到带VLAN Tag的报文时:
    • 对于Access类型接口,如果该报文的VLAN ID与接口缺省的VLAN ID相同,将转发该报文;如果该报文的VLAN ID与接口缺省的VLAN ID不相同,则丢弃该报文。
    • 对于QinQ类型接口,接收该报文,再打上一层缺省VLAN的Tag。
  • 当接口发送带有VLAN Tag的报文时,对于Access类型和QinQ类型接口,均去掉报文的VLAN Tag,然后再发送该报文。

前置条件

使用port命令配置接口缺省VLAN前,接口的类型不能为hybrid或trunk。

注意事项

Super VLAN不能配置为缺省VLAN。

使用undo port命令删除接口的缺省VLAN时,只有所列接口的缺省VLAN是当前VLAN时,接口的缺省VLAN才会被删除。

在同一VLAN视图下多次使用port命令配置接口的缺省VLAN,按多次配置累加结果生效。

该命令与port default vlan命令的执行效果相同。

使用实例

# 配置接口GE1/0/1GE1/0/4的缺省VLAN为3。
<HUAWEI> system-view
[HUAWEI] vlan 3
[HUAWEI-vlan3] port gigabitethernet 1/0/1 to 1/0/4

port default vlan

命令功能

port default vlan命令用来配置接口的缺省VLAN并同时加入这个VLAN。

undo port default vlan命令用来删除接口的缺省VLAN并同时退出这个VLAN。

缺省情况下,所有接口的缺省VLAN ID为1。

命令格式

port default vlan vlan-id [ step step-number [ increased | decreased ] ]

undo port default vlan

参数说明

参数

参数说明

取值

vlan-id

配置缺省VLAN的编号。

整数形式,取值范围是1~4094

step step-number [ increased | decreased ]

指定将端口组成员接口加入到以vlan-id为起始VLAN,以step-number为步长的VLAN中。

increased表示以VLAN ID递增的方式将接口加入到VLAN中,decreased表示以VLAN ID递减的方式将接口加入到VLAN中。

例如,vlan-id取值是10,step-number取值是20,选择以increased方式将接口加入到VLAN中,则端口组的成员接口1加入到VLAN10中,成员端口2加入到VLAN30中,以此类推。

说明:
  • 此参数只有在端口组视图下可以使用。

  • 选择step方式,vlan-id的取值必须保证所有接口加入的VLAN是可以使用的。

  • 如果不指定此参数,则端口组中的所有成员接口加入到同一个VLAN,即VLAN vlan-id

step-number是整数形式,取值范围是1~4093。

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

用户主机发出的帧都是Untagged帧,接口从对端设备收到的帧也有可能是Untagged的,但所有以太网帧在设备中都是以Tagged的形式处理转发的,因此设备必须给接口收到的Untagged帧加上Tag。为了实现此目的,必须配置接口的缺省VLAN。当该接口收到Untagged帧时给它加上该接口缺省VLAN的VLAN Tag。

如果配置了接口的缺省VLAN ID:
  • 当接口接收到不带VLAN Tag的报文时,对于Access类型和QinQ类型接口,均将该报文打上缺省的VLAN Tag。
  • 当接口接收到带VLAN Tag的报文时:
    • 对于Access类型接口,如果该报文的VLAN ID与接口缺省的VLAN ID相同,将转发该报文;如果该报文的VLAN ID与接口缺省的VLAN ID不相同,则丢弃该报文。
    • 对于QinQ类型接口,接收该报文,再打上一层缺省VLAN的Tag。
  • 当接口发送带有VLAN Tag的报文时,对于Access类型和QinQ类型接口,去掉报文的VLAN Tag,然后再发送该报文。

前置条件

使用port link-type命令将接口类型改为negotiation-desirable、negotiation-auto、AccessQinQ类型,negotiation-desirable或negotiation-auto类型接口只有当协商为access类型时,port default vlan配置的缺省VLAN才会生效

注意事项

  • 若配置未创建的VLAN为PVID,则收到的untagged报文加入的PVID为VLAN 1,当PVID VLAN全局创建后,接口的PVID值刷新为当前配置值。

  • 该命令与port命令的执行效果是等同的。
  • Super VLAN不能配置为缺省VLAN。
  • 本命令不可用于已经加入Eth-Trunk的物理接口。
  • 本命令为覆盖式命令,在同一接口下多次使用port default vlan命令配置接口的缺省VLAN,按最后一次配置生效。

使用实例

# 配置接口GE1/0/1的接口类型为Access,缺省VLAN为VLAN3(VLAN3已经存在)。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type access
[HUAWEI-GigabitEthernet1/0/1] port default vlan 3

port discard tagged-packet

命令功能

port discard tagged-packet命令用来配置接口丢弃入方向带VLAN Tag的报文。

undo port discard tagged-packet命令用来取消接口丢弃入方向带VLAN Tag的报文。

缺省情况下,接口不丢弃入方向带VLAN Tag的报文。

命令格式

port discard tagged-packet

undo port discard tagged-packet

参数说明

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

网络中主机用户发送的都为不带VLAN Tag的报文。当交换机某接口规划用作接入主机用户时,接口只需要处理不带VLAN Tag的报文。为了防止主机用户私自更改接口用途,接入其他交换设备,可以使用该命令配置接口丢弃入方向带VLAN Tag的报文。

注意事项

除X系列单板外,其他单板接口上配置dot1q tunnel后,相应接口上再配置port discard tagged-packet无法生效。

该命令只能在连接主机的接口上配置,如果在用于连接其他网络设备的接口上配置该命令,将会导致VLAN内用户无法通信。

使用实例

# 配置以太网接口GE1/0/1丢弃入方向带VLAN Tag的报文。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port discard tagged-packet
相关主题

port hybrid pvid vlan

命令功能

port hybrid pvid vlan命令用来设置Hybrid类型接口的缺省VLAN ID。

undo port hybrid pvid vlan命令用来恢复缺省情况Hybrid类型接口的缺省VLAN ID。

缺省情况下,所有接口的缺省VLAN ID为VLAN1。

命令格式

port hybrid pvid vlan vlan-id

undo port hybrid pvid vlan

参数说明

参数

参数说明

取值

vlan-id

指定Hybrid类型接口的缺省VLAN编号。

整数形式,取值范围是1~4094

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

接口从对端设备收到的帧有可能是Untagged的,但所有以太网帧在设备中都是以Tagged的形式处理转发的,因此设备必须给接口收到的Untagged帧加上Tag。为了实现此目的,必须配置接口的缺省VLAN。当该接口收到Untagged帧时给它加上该接口缺省VLAN的VLAN Tag。

对于Hybrid类型接口,如果配置了接口的缺省VLAN ID:
  • 当接口接收到不带VLAN Tag的报文时,打上缺省的VLAN ID。当缺省VLAN ID在允许通过的VLAN ID列表里时,接收该报文并打上缺省VLAN的Tag;当缺省VLAN ID不在允许通过的VLAN ID列表里时,丢弃该报文。
  • 当接口接收到带VLAN Tag的报文时,当VLAN ID在接口允许通过的VLAN ID列表里时,接收该报文,当VLAN ID不在接口允许通过的VLAN ID列表里时,丢弃该报文。
  • 当接口发送报文时,如果VLAN ID是该接口允许通过的VLAN ID时,发送该报文,可以配置发送报文时是否携带Tag。

前置条件

若接口不是hybrid类型,需使用port link-type hybrid命令将接口类型改为hybrid类型。

注意事项

  • 若配置未创建的VLAN为PVID,则收到的untagged报文加入的PVID为VLAN 1,当PVID VLAN全局创建后,接口的PVID值刷新为当前配置值。

  • 本命令不可用于已经加入Eth-Trunk的物理接口。

  • 使用port hybrid pvid vlan命令配置缺省VLAN,但是接口并没有同时加入该VLAN。

  • 在同一接口下多次使用port hybrid pvid vlan命令配置接口的缺省VLAN,按最后一次配置生效。

使用实例

# 配置接口GE1/0/1的缺省VLAN为VLAN5。

<HUAWEI> system-view
[HUAWEI] vlan 5
[HUAWEI-vlan5] quit
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] port hybrid pvid vlan 5

port hybrid tagged vlan

命令功能

port hybrid tagged vlan命令用来配置Hybrid类型接口加入的VLAN,这些VLAN的帧以Tagged方式通过接口。

undo port hybrid vlan命令用来删除Hybrid类型接口加入的VLAN。

缺省情况下,Hybrid接口以Untagged方式加入VLAN1。

命令格式

port hybrid tagged vlan { { vlan-id1 [ to vlan-id2 ] }&<1-10> | all }

undo port hybrid [ tagged ] vlan { { vlan-id1 [ to vlan-id2 ] }&<1-10> | all }

(仅端口组视图)port hybrid tagged vlan vlan-id3 [ step step-number [ increased | decreased ] ]

(仅端口组视图)undo port hybrid vlan vlan-id3 [ step step-number [ increased | decreased ] ]

参数说明

参数

参数说明

取值

vlan-id1 [ to vlan-id2 ]

指定Hybrid类型接口加入的VLAN,其中:
  • vlan-id1表示第一个VLAN的编号。
  • to vlan-id2表示最后一个VLAN的编号。vlan-id2的取值必须大于等于vlan-id1的取值。

vlan-id1为整数形式,取值范围是1~4094

vlan-id2为整数形式,取值范围是1~4094

all

指定Hybrid接口加入所有VLAN。

-

vlan-id3

指定端口组中成员接口与VLAN绑定的起始VLAN。

整数形式,取值范围是1~4094。
step step-number

指定VLAN ID递增或递减的步长。

此参数用于实现以vlan-id3为起始VLAN、step-number为步长、递增或递减的方式将端口组下成员接口与VLAN一一绑定,便于用户配置。如:

端口组下有10个成员接口,通过命令port hybrid tagged vlan设置vlan-id3为1、step-number为1、选择递增方式成功配置后,成员口1加入的VLAN ID为1、成员口2加入的VLAN ID为2,以此类推,成员口10加入的VLAN ID为10。

整数形式,取值范围是1~4093。
increased

指定以vlan-id3为起始VLAN、step-number为步长、递增的方式将端口组下成员接口与VLAN一一绑定。

缺省情况下,二层接口与VLAN以递增的方式绑定。
decreased

指定以vlan-id3为起始VLAN、step-number为步长、递减的方式将端口组下成员接口与VLAN一一绑定。

选择递减方式,vlan-id3的取值必须大于等于端口组下的成员接口数。

-

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

Hybrid接口既可以连接用户主机,也可以连接其他交换机的接口。Hybrid接口允许多个VLAN的帧通过,该命令是以Tagged形式将Hybrid类型接口加入VLAN中。

使用port hybrid tagged vlan命令配置以Tagged形式将Hybrid类型接口加入VLAN后,接口在发送帧时不将帧中的VLAN Tag去掉。

前置条件

若接口不是hybrid类型,需使用port link-type hybrid命令将接口类型改为hybrid类型。

注意事项

  • 本命令不可用于已经加入Eth-Trunk的物理接口。
  • 不能使用本命令将接口加入super类型的VLAN。
  • 如果在同一接口上多次使用port hybrid tagged vlan命令,那么该接口加入的VLAN是多次配置的累加。

使用实例

# 配置接口GE1/0/1属于VLAN3~VLAN5,并且接口GE1/0/1在发送以上这些VLAN的帧时不将帧中的Tag剥掉。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] port hybrid tagged vlan 3 to 5

port hybrid untagged vlan

命令功能

port hybrid untagged vlan命令用来配置Hybrid类型接口加入的VLAN,这些VLAN的帧以Untagged方式通过接口。

undo port hybrid vlan命令用来删除Hybrid类型接口加入的VLAN。

缺省情况下,Hybrid接口以Untagged方式加入VLAN1。

命令格式

port hybrid untagged vlan { { vlan-id1 [ to vlan-id2 ] }&<1-10> | all }

undo port hybrid [ untagged ] vlan{ { vlan-id1 [ to vlan-id2 ] }&<1-10> | all }

(端口组视图)port hybrid untagged vlan vlan-id3 [ step step-number [ increased | decreased ] ]

(端口组视图)undo port hybrid vlan vlan-id3 [ step step-number [ increased | decreased ] ]

参数说明

参数

参数说明

取值

vlan-id1 [ to vlan-id2 ]

指定Hybrid类型接口加入的VLAN,其中:
  • vlan-id1表示第一个VLAN的编号。
  • to vlan-id2表示最后一个VLAN的编号。vlan-id2的取值必须大于等于vlan-id1的取值。

vlan-id1为整数形式,取值范围是1~4094

vlan-id2为整数形式,取值范围是1~4094

all

指定Hybrid接口所属的所有VLAN。

-

vlan-id3

指定端口组中成员接口与VLAN绑定的起始VLAN。

整数形式,取值范围是1~4094。
step step-number

指定VLAN ID递增或递减的步长。

此参数用于实现以vlan-id3为起始VLAN、step-number为步长、递增或递减的方式将端口组下成员接口与VLAN一一绑定,便于用户配置。如:

端口组下有10个成员接口,通过命令port hybrid untagged vlan设置vlan-id3为1、step-number为1、选择递增方式成功配置后,成员口1加入的VLAN ID为1、成员口2加入的VLAN ID为2,以此类推,成员口10加入的VLAN ID为10。

整数形式,取值范围是1~4093。
increased

指定以vlan-id3为起始VLAN、step-number为步长、递增的方式将端口组下成员接口与VLAN一一绑定。

缺省情况下,二层接口与VLAN以递增的方式绑定。
decreased

指定以vlan-id3为起始VLAN、step-number为步长、递减的方式将端口组下成员接口与VLAN一一绑定。

选择递减方式,vlan-id3的取值必须大于等于端口组下的成员接口数。

-

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

Hybrid类型接口既可以连接用户主机,也可以连接其他交换机。当Hybrid接口用于连接主机时,由于主机不能处理带VLAN Tag的帧,所以必须配置接口发送Untagged帧给主机。

使用port hybrid untagged vlan命令配置以Untagged形式将Hybrid类型接口加入VLAN后,接口在发送帧时将帧中的VLAN Tag去掉。

前置条件

若接口不是hybrid类型,需使用port link-type hybrid命令将接口类型改为hybrid类型。

注意事项

  • 本命令不可用于已经加入Eth-Trunk的物理接口。
  • 不能使用本命令将接口加入super类型的VLAN。
  • 该命令为累增式命令,如果在同一接口上多次使用port hybrid untagged vlan命令,配置结果是多次配置的累加。

使用实例

# 配置接口GE1/0/1属于VLAN3~VLAN5,并且接口GE1/0/1在发送以上这些VLAN的帧时将帧中的Tag剥掉。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] port hybrid untagged vlan 3 to 5

port hybrid vlan 1

命令功能

port hybrid vlan 1命令用来将Hybrid接口以Untagged的方式加入到VLAN1中。

undo port hybrid vlan 1命令用来将Hybrid接口从VLAN1中删除。

缺省情况下,Hybrid接口以Untagged方式加入VLAN1。

命令格式

port hybrid vlan 1

undo port hybrid vlan 1

参数说明

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

设备所有的接口都缺省加入VLAN1,其中Hybrid接口缺省以Untagged方式加入VLAN1。当网络中存在VLAN1的未知单播、组播或者广播报文时,可能会引起广播风暴。因此对于不需要加入VLAN1的Hybrid接口要及时通过命令undo port hybrid vlan 1退出VLAN1,以避免环路。当网络发生变化,需要Hybrid接口重新以Untagged方式加入VLAN1时,可以通过命令port hybrid vlan 1实现。

前置条件

若接口不是hybrid类型,需使用port link-type hybrid命令将接口类型改为hybrid类型。

注意事项

本命令不可用于已经加入Eth-Trunk的物理接口。

使用实例

# 将接口GE1/0/1以Untagged的方式加入到VLAN1中。
<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] port hybrid vlan 1

port negotiation disable

命令功能

port negotiation disable命令用来基于接口去使能链路类型自协商功能。

undo port negotiation disable命令用来基于接口使能链路类型自协商功能。

缺省情况下,二层接口的链路类型自协商功能处于使能状态。

命令格式

port negotiation disable

undo port negotiation disable

参数说明

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

缺省情况下,二层设备上所有接口都使能了链路类型自协商功能。当支持链路类型自协商功能的二层设备和不支持链路类型自协商功能的二层设备互通时,支持链路类型自协商功能的二层设备会不断发送自协商报文,浪费带宽。此时,可通过命令port negotiation disable基于二层接口去使能链路类型自协商功能。

如果需要将二层设备上所有接口的链路类型自协商功能都去使能,可在系统视图下通过命令lnp disable实现。

前置条件

执行port negotiation disable命令前,必须保证对应的接口已经是二层接口。如果接口是三层接口,可执行命令portswitch将三层接口切换为二层接口。

注意事项

缺省情况下,二层设备上所有接口都使能了链路类型自协商功能。如果在系统视图下执行命令lnp disable,将去使能二层设备上所有接口的链路类型自协商功能。即使在二层以太网接口视图下执行命令undo port negotiation disable也无法使能链路类型自协商功能。

为了保证链路类型自协商功能生效,必须保证设备和二层以太网接口的链路类型自协商功能都处于使能状态。

使用实例

# 去使能二层接口的链路类型自协商功能。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port negotiation disable

port trunk allow-pass vlan

命令功能

port trunk allow-pass vlan命令用来配置Trunk类型接口加入的VLAN。

undo port trunk allow-pass vlan命令用来删除Trunk类型接口加入的VLAN。

缺省情况下,Trunk类型接口加入了VLAN1。

命令格式

port trunk allow-pass vlan { { vlan-id1 [ to vlan-id2 ] }&<1-10> | all }

undo port trunk allow-pass vlan { { vlan-id1 [ to vlan-id2 ] }&<1-10> | all }

(端口组视图)port trunk allow-pass vlan vlan-id3 [ step step-number [ increased | decreased ] ]

(端口组视图)undo port trunk allow-pass vlan vlan-id3 [ step step-number [ increased | decreased ] ]

参数说明

参数

参数说明

取值

vlan-id1 [ to vlan-id2 ]

指定Trunk类型接口加入的VLAN,其中:
  • vlan-id1表示第一个VLAN的编号。
  • to vlan-id2表示最后一个VLAN的编号。vlan-id2的取值必须大于等于vlan-id1的取值。

vlan-id1为整数形式,取值范围是1~4094

vlan-id2为整数形式,取值范围是1~4094

all

指定Trunk接口加入所有VLAN。

-

vlan-id3

指定端口组中成员接口与VLAN绑定的起始VLAN。

整数形式,取值范围是1~4094。
step step-number

指定VLAN ID递增或递减的步长。

此参数用于实现以vlan-id3为起始VLAN、step-number为步长、递增或递减的方式将端口组下成员接口与VLAN一一绑定,便于用户配置。如:

端口组下有10个成员接口,通过命令port trunk allow-pass vlan设置vlan-id3为1、step-number为1、选择递增方式成功配置后,成员口1加入的VLAN ID为1、成员口2加入的VLAN ID为2,以此类推,成员口10加入的VLAN ID为10。

整数形式,取值范围是1~4093。
increased

指定以vlan-id3为起始VLAN、step-number为步长、递增的方式将端口组下成员接口与VLAN一一绑定。

缺省情况下,二层接口与VLAN以递增的方式绑定。
decreased

指定以vlan-id3为起始VLAN、step-number为步长、递减的方式将端口组下成员接口与VLAN一一绑定。

选择递减方式,vlan-id3的取值必须大于等于端口组下的成员接口数。

-

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

Trunk类型接口可以加入多个VLAN,一般用于网络设备之间连接。若想让一个或多个VLAN的报文通过Trunk接口,需要使用port trunk allow-pass vlan命令将Trunk类型接口加入这些VLAN。

前置条件

接口类型已配置为Trunk或协商类型

注意事项

如果VLAN不存在,则接口会加入到VLAN中,但配置不生效。

如果当前接口已加入Eth-Trunk,本命令不可用。

在同一接口上多次使用port trunk allow-pass vlan命令,那么该接口加入的VLAN是多次配置的合集。

使用实例

# 配置接口GE1/0/1属于VLAN10~VLAN30。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type trunk
[HUAWEI-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 to 30

port trunk allow-pass only-vlan

命令功能

port trunk allow-pass only-vlan命令用来配置通过LNP协议自协商后为trunk类型的接口只允许通过的VLAN。

undo port trunk allow-pass only-vlan命令用来配置LNP协议自协商后为trunk类型的接口允许通过所有VLAN为缺省值。

缺省情况下,若二层以太网接口的链路类型协商结果为trunk,接口允许所有VLAN通过。

命令格式

port trunk allow-pass only-vlan { { vlan-id1 [ to vlan-id2 ] } &<1-10> | none }

undo port trunk allow-pass only-vlan

参数说明

参数 参数说明 取值
vlan-id1 [ to vlan-id2 ]
指定协商后的接口允许通过的VLAN,其中:
  • vlan-id1表示协商后的接口允许通过的第一个VLAN。
  • to vlan-id2表示协商后的接口允许通过的最后一个VLAN。vlan-id2的取值必须大于等于vlan-id1的取值,它和vlan-id1共同确定一个范围。
  • 如果不指定to vlan-id2参数,则协商后的接口只加入vlan-id1所指定的VLAN。

一条port trunk allow-pass only-vlan命令中,最多可以使用10次to形式输入10个VLAN范围。

整数形式,取值范围是1~4094。
none

指定协商后的接口不允许任何VLAN通过。

-

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

链路类型协商协议LNP(Link-type Negotiation Protocol)用来动态协商二层以太网接口的链路类型为Access或者Trunk。

日常维护过程中,网络管理员需要更新协商后的接口允许通过的VLAN,需要在对应的接口视图下执行如下步骤实现:

  1. 执行命令undo port trunk allow-pass vlan all删除协商后的接口允许通过的VLAN。
  2. 执行命令port trunk allow-pass only-vlan { { vlan-id1 [ to vlan-id2 ] } &<1-10> | none }更新协商后的接口允许通过的VLAN。

为了简化配置,减少网络管理员日常维护工作量,可直接通过命令port trunk allow-pass only-vlan更新协商后的接口允许通过的VLAN。

前置条件

执行port trunk allow-pass only-vlan命令前,需要支持LNP功能,并且已经执行port link-type negotiation命令配置以太网接口的链路类型的自协商方式。

使用实例

# 设置通过LNP协议协商后类型为trunk的接口允许通过的VLAN是VLAN10~VLAN20。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet1/0/1
[HUAWEI-GigabitEthernet1/0/1] port trunk allow-pass only-vlan 10 to 20

port trunk pvid vlan

命令功能

port trunk pvid vlan命令用来设置Trunk类型接口的缺省VLAN。

undo port trunk pvid vlan命令用来恢复Trunk类型接口的缺省VLAN。

缺省情况下,Trunk类型接口的缺省VLAN为VLAN1。

命令格式

port trunk pvid vlan vlan-id

undo port trunk pvid vlan

参数说明

参数

参数说明

取值

vlan-id

指定Trunk类型接口的缺省VLAN编号。

整数形式,取值范围是1~4094

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、VE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

接口从对端设备收到的帧有可能是Untagged帧,但所有以太网帧在设备中都是以Tagged的形式处理转发的,因此设备必须给接口收到的Untagged帧加上Tag。为了实现此目的,必须配置接口的缺省VLAN。当该接口收到Untagged帧,则给它加上该接口缺省VLAN的VLAN Tag。

后续任务

将Trunk类型接口加入VLAN。

注意事项

  • 若配置未创建的VLAN为PVID,则收到的untagged报文加入的PVID为VLAN 1,当PVID VLAN全局创建后,接口的PVID值刷新为当前配置值。

  • 缺省VLAN不一定是接口允许通过的VLAN。只有使用命令port trunk allow-pass vlan将接口加入缺省VLAN,才能转发缺省VLAN的报文。

  • 本命令为覆盖式命令,在同一接口下多次使用port trunk pvid vlan命令,按最后一次配置生效。

使用实例

# 配置接口GE1/0/1的缺省VLAN为VLAN5。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type trunk
[HUAWEI-GigabitEthernet1/0/1] port trunk pvid vlan 5

protocol-transparent

命令功能

protocol-transparent命令用来使能VLAN内协议报文透传功能。

undo protocol-transparent命令用来去使能VLAN内协议报文透传功能。

缺省情况下,没有使能VLAN内协议报文透传功能。

命令格式

protocol-transparent

undo protocol-transparent

参数说明

视图

VLAN视图、VLAN-Range视图

缺省级别

2:配置级

使用指南

应用场景

当设备作为用户的业务网关时,或者作为二层交换机但使能了DHCP/IGMP/MLD Snooping等Snooping功能时,设备需要解析处理相应的协议报文(例如ARP、DHCP、IGMP报文等),即接口上收到的协议报文会上送到CPU进行处理。而接口在上送协议报文时,是不区分VLAN的。即如果部署了上述功能后,则所有VLAN的协议报文都会上送CPU处理。

如果设备只是某些VLAN的业务网关,或者只对某些VLAN部署了Snooping功能。那么对于其他VLAN中的协议报文,设备是不需要处理的,协议报文上送到CPU之后,CPU需要将其重新转发到其他设备进行处理。这种经过CPU处理的转发机制称为软转发,软转发增加了协议报文的处理环节,会对报文的转发速度和效率造成较大影响。

针对上述场景,可以在不需要处理协议报文的VLAN中,部署VLAN内协议报文透传功能,此时这些VLAN的协议报文不会再上送CPU处理,而是直接透传转发到其他设备进行处理,可以提高转发速度和效率。

支持透传的协议报文类型有CFM/ARP/BFD/DHCP/DHCPV6/HTTP/IGMP/MLD/ND/PIM/PIMv6/PPPoE/TACACS。

注意事项

  • 执行protocol-transparent命令前,需确保该VLAN的IGMP/MLD Snooping功能已去使能,否则配置失败。
  • 使用protocol-transparent命令使能某VLAN内协议报文透传功能后,交换机将不参与该VLAN内的协议计算。

使用实例

# 使能VLAN100的VLAN内协议报文透传功能。

<HUAWEI> system-view
[HUAWEI] vlan 100
[HUAWEI-vlan100] protocol-transparent

# 使能VLAN10到VLAN20的VLAN内协议报文透传功能。

<HUAWEI> system-view
[HUAWEI] vlan batch 10 to 20
[HUAWEI] vlan range 10 to 20
[HUAWEI-vlan-range] protocol-transparent
相关主题

protocol-vlan

命令功能

protocol-vlan命令用来配置基于协议划分VLAN,并指定关联的协议。

undo protocol-vlan命令用来取消配置基于协议划分VLAN。

命令格式

protocol-vlan [ protocol-index ] { at | ipv4 | ipv6 | ipx { ethernetii | llc | raw | snap } | mode { ethernetii-etype etype-id1 | llc dsap dsap-id ssap ssap-id | snap-etype etype-id2 } }

undo protocol-vlan { all | protocol-index1 [ to protocol-index2 ] }

参数说明

参数

参数说明

取值

protocol-index

指定协议的索引值。如果不手工配置协议索引值,则系统会根据协议与VLAN关联的先后顺序自动产生编号。

整数形式,取值范围是0~15。

at

基于AppleTalk协议划分VLAN。

-

ipv4

基于IPv4协议划分VLAN。

-

ipv6

基于IPv6协议划分VLAN。

-

ipx

基于IPX协议划分VLAN。IPX的封装类型是ethernetii、llc、raw和snap。

-

ethernetii

以太网报文的封装格式为Ethernet II。

-

llc

以太网报文的封装格式为llc。

-

raw

以太网报文的封装格式为raw。

-

snap

以太网报文的封装格式为Snap。

-

mode

指定自定义协议。

-

ethernetii-etype etype-id1

匹配Ethernet II封装格式的协议类型值。

取值范围是0x600~ffff(除800、809b、8137、86dd以外的值)。

dsap dsap-id

配置目的服务接入点。

取值范围是0x0~ff。

ssap ssap-id

配置源服务接入点。

取值范围是0x0~ff。

snap-etype etype-id2

匹配snap封装格式的协议类型值。

取值范围是0x600~ffff(除800、809b、8137、86dd以外的值)。

all

指定与vlan-id绑定的所有协议索引。

-

protocol-index1

指定协议的索引值。

整数形式,取值范围是0~15。

protocol-index2

指定协议的索引值。

整数形式,取值范围是0~15。

protocol-index2的取值必须大于等于protocol-index1的取值。

视图

VLAN视图

缺省级别

2 :配置级

使用指南

应用场景

基于协议划分VLAN将指定协议类型与VLAN相关联,根据关联关系来确定不同协议类型的报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。主要应用在根据不同协议类型采用不同传输路径的网络中。

后续任务

配置接口允许基于协议的VLAN通过、配置接口关联协议VLAN。

注意事项

  • 基于协议划分的VLAN不能是RRPP或ERPS的控制VLAN。

  • atipv4ipv6协议可以直接配置与VLAN关联,配置其他协议与VLAN关联时需要指定封装类型。

  • 配置源和目的服务接入点时,需要注意以下几点:

    • dsap-idssap-id不能同时设置为0xaa,0xaa对应的是snap封装格式。

    • dsap-idssap-id不能同时设置为0xe0,0xe0对应的是IPX报文的llc封装格式。

    • dsap-idssap-id不能同时设置为0xff,0xff对应的是IPX报文的raw封装格式。

该命令为累增式命令,多次使用protocol-vlan命令配置协议类型与VLAN关联,配置结果按多次累加生效。

使用实例

# 配置基于IPv4协议报文划分到VLAN3。

<HUAWEI> system-view
[HUAWEI] vlan 3
[HUAWEI-vlan3] protocol-vlan ipv4

protocol-vlan vlan

命令功能

protocol-vlan vlan命令用来配置接口关联协议VLAN。

undo protocol-vlan vlan命令用来取消接口关联协议VLAN。

缺省情况下,接口未关联任何协议VLAN。

命令格式

protocol-vlan vlan vlan-id { all | protocol-index1 [ to protocol-index2 ] } [ priority priority ]

undo protocol-vlan { all | vlan vlan-id { all | protocol-index1 [ to protocol-index2 ] } }

参数说明

参数

参数说明

取值

all

根据all的位置不同,分别表示:
  • 所有协议索引值。
  • 所有协议VLAN。

-

vlan vlan-id

指定基于协议划分的VLAN ID。

整数形式,取值范围是1~4094。

protocol-index1 [ to protocol-index2 ]

指定协议的索引值。如果不手工配置协议索引值,则系统会根据协议与VLAN关联的先后顺序自动产生编号。

整数形式,取值范围是0~15。

protocol-index2的取值必须大于等于protocol-index1的取值。

priority priority

指定协议对应VLAN的802.1p优先级。

整数形式,取值范围是0~7,值越大优先级越高。缺省值是0。

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2 :配置级

使用指南

应用场景

基于协议划分VLAN将指定协议类型与VLAN相关联,使该协议类型的报文在相应的VLAN中传输。主要应用在根据不同协议类型采用不同传输路径的网络中。

如果接口采用基于协议划分VLAN的机制:

  • 当接口收到untagged报文时,接口会以报文的协议去匹配协议VLAN表项。如果匹配成功,则按照匹配到的VLAN ID和优先级进行转发。如果匹配失败,则按照其它匹配原则继续进行匹配。
  • 当收到tagged报文时,按照基于接口划分VLAN进行转发。

前置条件

配置接口关联协议VLAN前,必须先使用protocol-vlan创建该协议VLAN。

注意事项

在Access口和Trunk口上,只有基于协议划分的VLAN和PVID相同时,才可以正常使用。所以基于协议划分VLAN推荐在Hybrid口上配置。

如果接口采用基于协议划分VLAN的机制,当接口收到报文时,交换机需要解析报文的协议类型并进行相应转换。

使用实例

# 配置接口GE1/0/1关联协议VLAN2(协议的索引值为0)。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet1/0/1] protocol-vlan vlan 2 0

reset lnp statistics

命令功能

reset lnp statistics命令用来清除LNP报文统计信息。

命令格式

reset lnp statistics [ interface interface-type interface-number ]

参数说明

参数 参数说明 取值
interface interface-type interface-number

清除指定接口的LNP报文统计信息。

-

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

当需要统计一定时间内LNP报文信息,这时必须在统计开始前通过命令reset lnp statistics清除原有的LNP报文统计信息,使系统重新进行统计,保证统计的信息正确。

注意事项

执行reset lnp statistics命令后,LNP报文收发统计数目将清零,清除的统计信息不可恢复。在执行本命令前请务必仔细确认是否需要执行本命令。

使用实例

# 清除LNP报文统计信息。

<HUAWEI> reset lnp statistics interface gigabitethernet 1/0/1

reset vlan statistics

命令功能

reset vlan statistics命令用来清除指定VLAN的统计信息。

命令格式

reset vlan vlan-id statistics [ slot slot-id ]

参数说明

参数

参数说明

取值

slot slot-id

清除指定槽位的VLAN统计信息。

整数形式,根据系统提示的在位槽位号确定。

vlan-id

指定VLAN的编号。

整数形式,取值范围是1~4094

视图

用户视图

缺省级别

3:管理级

使用指南

应用场景

在需要重新统计VLAN的统计信息时使用本命令。清除VLAN的统计信息成功后,VLAN的统计信息将被清零。

前置条件

执行reset vlan statistics清除指定VLAN的统计信息前,必须已经使用statistic enable(VLAN视图)命令打开了该VLAN的流量统计功能。

注意事项

清除流量统计信息后,以前的统计信息将无法恢复,请于清除之前仔细确认。

使用实例

# 清除VLAN3的流量统计信息。

<HUAWEI> reset vlan 3 statistics

shutdown(VLANIF接口视图)

命令功能

shutdown命令用来关闭当前VLANIF接口。

undo shutdown命令用来开启当前VLANIF接口。

缺省情况下,VLANIF接口是开启的。

命令格式

shutdown

undo shutdown

参数说明

视图

VLANIF接口视图

缺省级别

2:配置级

使用指南

应用场景

当需要屏蔽某VLANIF接口或某VLANIF接口出故障时,可使用shutdown命令关闭当前VLANIF接口。

注意事项

VLANIF接口对应的VLAN中只要存在一个物理接口处于Up状态,则VLANIF接口也处于Up状态。

在VLANIF接口下执行shutdown命令之后,即使在VLANIF接口下有物理接口Up,该VLANIF接口状态也会变为Down。

关闭VLANIF接口后,所有通过该VLANIF接口IP地址作为网关的用户都不能进行三层通信,该接口的IP地址也不参与路由计算。

关闭VLANIF接口后,若该接口IP地址由ARP动态学习到,则老化ARP表中包含该IP地址的条目。若该IP地址用于静态ARP配置,则不会删除对应的静态ARP表。

使用实例

# 开启接口VLANIF2。

<HUAWEI> system-view
[HUAWEI] interface vlanif 2
[HUAWEI-Vlanif2] undo shutdown

statistic enable(VLAN视图)

命令功能

statistic enable命令用来打开VLAN的流量统计功能。

undo statistic enable命令用来关闭VLAN的流量统计功能。

缺省情况下,VLAN的流量统计功能处于关闭状态。

命令格式

statistic enable

undo statistic enable

参数说明

视图

VLAN视图

缺省级别

2:配置级

使用指南

应用场景

当需要检查网络状况或处理网络故障时,可以在设备上打开VLAN的流量统计功能,统计通过VLAN的流量信息。

使用statistic enable打开VLAN的流量统计功能后,便开始对通过该VLAN的单播、组播和广播报文流量进行统计。

注意事项

  • 最多支持对256个VLAN做流量统计。
  • 流量统计信息是累增的,系统不会自动清除。如需清空VLAN的流量,可执行reset vlan statistics命令清除指定VLAN的统计信息。

  • 流量统计功能需要占用系统资源,系统资源不足可能会导致配置失败,请在不需要流量统计时及时关闭此功能。

  • 打开VLAN的流量统计功能后,可执行display vlan vlan-id statistics命令查看指定VLAN的流量统计信息。

使用实例

# 打开VLAN100的流量统计功能。

<HUAWEI> system-view
[HUAWEI] vlan 100
[HUAWEI-vlan100] statistic enable

statistic enable(VLANIF接口视图)

命令功能

statistic enable命令用来打开VLANIF接口的流量统计。

undo statistic enable命令用来关闭VLANIF接口的流量统计。

缺省情况下,VLANIF接口的流量统计处于关闭状态。

命令格式

statistic enable { both | inbound | outbound }

undo statistic enable { both | inbound | outbound }

参数说明

参数

参数说明

取值

both

统计接口双向流量。

-

inbound

统计接口入方向流量。

-

outbound

统计接口出方向流量。

-

视图

VLANIF接口视图

缺省级别

2:配置级

使用指南

应用场景

当需要检查网络状况或处理网络故障时,可以打开VLANIF的流量统计功能,统计通过VLANIF的流量信息。

注意事项

  • 除了X系列单板,若VLANIF接口对应的VLAN下使能了流量统计功能,则该VLANIF接口outbound方向的流量统计功能不生效。

  • 使用undo statistic enable命令关闭VLANIF的流量统计功能后,将终止对VLANIF流量的统计,以前统计的流量信息会被清空。

  • VLANIF接口的流量统计功能需要占用系统ACL资源,由于系统ACL资源有限,打开过多的流量统计将会导致其它功能申请不到ACL资源。最多支持对500个VLANIF接口进行流量统计。

  • VLANIF接口的流量统计功能不支持统计错误报文。

  • VLANIF接口的流量统计功能不支持统计设备本身产生发送出的报文(如ping报文)。

  • VLANIF接口的流量统计功能不支持对MPLS报文的流量统计。

  • 打开VLANIF接口的流量统计功能后,可执行display interface vlanif命令查看指定VLANIF的流量统计信息。

  • 配置流量统计功能的VLANIF接口越多,设备的CPU使用率越高。

使用实例

# 使能VLANIF接口双向流量统计功能。

<HUAWEI> system-view
[HUAWEI] interface vlanif 100
[HUAWEI-Vlanif100] statistic enable both

trace mac

命令功能

trace mac命令用来定位当前设备和目的设备之间的连通性故障,这种操作称为通用MAC Trace。

命令格式

trace mac mac-address vlan vlan-id [ interface interface-type interface-number | -t timeout | -h ]*

参数说明

参数 参数说明 取值
mac-address 指定目的节点的MAC地址。目的节点可以是MIP,也可以是MEP。
MP的MAC地址可以是桥MAC,也可以是MP所在接口的MAC。这取决于目的设备MP的MAC地址模式的配置。
  • 如果目的设备配置的MP的MAC地址模式为共享MAC模式,参数mac-address表示桥MAC。

  • 如果目的设备配置的MP的MAC地址模式为独立MAC模式,参数mac-address为MP所在接口的MAC或者桥MAC。

格式为H-H-H,其中H为1至4位的十六进制数。不能为广播MAC地址或组播MAC地址。
vlan vlan-id 指定VLAN ID。 整数形式,VLAN ID的取值范围是1~4094
interface interface-type interface-number 指定本设备发送Trace报文的出接口,其中:
  • interface-type表示接口类型。

  • interface-number表示接口编号。

  • 指定本参数,设备直接从该接口发出Trace报文。

  • 不指定本参数,首先根据指定的目的MAC地址、VLAN或VSI查询MAC地址转发表,如果:

    查询到对应的转发表项,按该表项发送Trace报文;

    未查询到对应的转发表项。如果找不到出接口但是VLAN内有唯一的接口,会直接从该接口转发出去,如果多于一个接口则直接丢弃。

-
-t timeout 指定等待应答的超时时间。 整数形式,取值范围是1~65535,单位是ms,缺省值是2000ms。
-h 指定显示每一跳的主机名与IP地址信息。 -

视图

所有视图

缺省级别

0:参观级

使用指南

应用场景

当需要进行通用MAC Trace操作时,可以使用本命令。

前置条件

使用本命令时,通用MAC Trace功能必须处于使能状态,否则需首先使用trace mac enable命令使能通用MAC Trace功能。

注意事项

通用MAC Trace不需要由MEP发起,中间节点和目的节点也不需要是MEP或MIP,即在源设备、中间设备和目的设备上均不需要配置MD、MA和MEP就可以进行通用MAC Trace,所有中间设备均回应LTR消息。

使用实例

# Trace MAC地址为aa99-6600-5600的目的设备,该设备属于VLAN2。

<HUAWEI> system-view
[HUAWEI] trace mac enable
[HUAWEI] trace mac aa99-6600-5600 vlan 2
Tracing the route to aa99-6600-5600 over a maximum of 255 hops:
 Hops  Ingress MAC    Ingress Port                Ingress Action    Relay Action
       Egress MAC     Egress Port                 Egress Action
 1     aa99-6600-5600 GigabitEthernet1/0/1        IngOK             RlyHit
       --             --                          --
Info: Succeed in tracing the destination address aa99-6600-5600.   

# Trace MAC地址为0025-9efb-923d的目的设备,该设备属于VLAN2。

<HUAWEI> system-view
[HUAWEI] trace mac enable
[HUAWEI] trace mac 0025-9efb-923d vlan 2 -h
Tracing the route to 0025-9efb-923d over a maximum of 255 hops:
 Hops  Host Name (IP Address)
       Ingress MAC    Ingress Port                Ingress Action    Relay Action
       Egress MAC     Egress Port                 Egress Action
 1     173 (10.137.126.173)
       0025-9efb-923d GigabitEthernet1/0/1        IngOK             RlyHit
       --             --                          --
Info: Succeed in tracing the destination address 0025-9efb-923d.    
表5-53  trace mac命令输出信息描述表

项目

描述

Hops

跳数。

Ingress Action

入接口对Trace报文的处理。
  • IngOK表示入接口成功转发Trace报文。

  • 本字段为空表示入接口转发Trace报文不成功。

Relay Action

本设备对Trace报文的回复,取值包括:
  • RlyFDB:报文在此设备被成功转发到下一跳设备。

  • RlyHit:报文到达目的设备。

Egress Action

出接口对Trace报文的处理,取值包括:
  • EgrOK表示出接口成功转发Trace报文。

  • 本字段为空表示出接口未转发Trace报文或转发不成功。

trace mac enable

命令功能

trace mac enable命令用来使能通用MAC Trace功能。

undo trace mac enable命令用来禁止通用MAC Trace功能。

缺省情况下,通用MAC Trace功能使能状态。

命令格式

trace mac enable

undo trace mac enable

参数说明

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

当需要使用以下功能时,需要使用本命令使能通用MAC Trace功能。

  • 进行通用MAC Trace操作。

  • 使设备对接收到的通用MAC Trace报文进行回复。

使用实例

# 使能通用MAC Trace功能。

<HUAWEI> system-view
[HUAWEI] trace mac enable

vlan

命令功能

vlan命令用来创建VLAN并进入VLAN视图,如果VLAN已存在,直接进入该VLAN的视图。

undo vlan用来删除指定VLAN。

缺省情况下,将所有接口都加入到一个缺省的VLAN中,该VLAN标识为1。

命令格式

vlan vlan-id

vlan batch { vlan-id1 [ to vlan-id2 ] } &<1-10>

undo vlan vlan-id

undo vlan batch { vlan-id1 [ to vlan-id2 ] } &<1-10>

参数说明

参数 参数说明 取值
vlan-id 指定VLAN ID。 整数形式,取值范围是1~4094
batch 指定批量创建VLAN。 -
vlan-id1 to vlan-id2 指定批量创建的VLAN ID,其中:
  • vlan-id1表示第一个VLAN的编号。

  • vlan-id2表示最后一个VLAN的编号。

    vlan-id2的取值必须大于等于vlan-id1,它与vlan-id1共同确定一个VLAN范围。

  • 如果不指定to vlan-id2参数,则只创建vlan-id1所指定的VLAN。

vlan-id1vlan-id2是整数形式,取值范围是1~4094

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

在复杂的网络环境中,为了减少广播域,增加用户的安全性,可以创建VLAN,将多个没有互访需求的主机进行隔离。当需要创建多个VLAN时,使用vlan batch命令批量创建VLAN,可以简化配置过程。

后续任务

创建VLAN后,即可根据组网情况划分VLAN。

注意事项

VLAN 1是系统自带的VLAN,不需要创建,也不可以删除。

使用vlan命令,可以创建VLAN并进入VLAN视图。如果该VLAN已存在,则直接进入该VLAN的视图。多次使用vlan命令创建VLAN,按多次创建的累加结果生效。如果该VLAN已经存在,不会再重新创建,保留原来的VLAN和相关配置。

使用vlan batch命令可以批量创建多个VLAN。如果该VLAN已经存在,不会再重新创建,保留原来的VLAN和它的相关配置。多次使用vlan batch命令创建VLAN,配置按多次创建的累加结果生效。

使用实例

# 创建编号是100的VLAN并进入VLAN100视图。如果该VLAN100已存在,则直接进入该VLAN100视图。

<HUAWEI> system-view
[HUAWEI] vlan 100
[HUAWEI-vlan100]

vlan configuration

命令功能

vlan configuration命令用来进入VLAN配置视图。当VLAN未创建时,该命令不会创建VLAN。

undo vlan configuration命令用来删除VLAN配置视图。

缺省情况下,未创建VLAN配置视图。

命令格式

vlan vlan-id configuration

undo vlan vlan-id configuration

参数说明

参数 参数说明 取值
vlan-id 指定VLAN ID。 整数形式,取值范围是1~4094。

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

如下场景可使用到该命令:
  • 如果用户需要仅在VLAN下进行配置,而不创建VLAN,创建VLAN由VCMP的Server统一进行,可使用该命令直接进入VLAN配置视图进行配置。

  • 在VCMP的Server上删除VLAN后,Client会通过VCMP协议同步删除VLAN,但VLAN下的配置不会同步删除。此时如果用户需要删除或修改VLAN下的配置,而不创建VLAN,可通过该命令直接进入VLAN配置视图,在VLAN配置视图下删除或修改配置。

通过vlan vlan-id configuration命令,可实现不创建VLAN也能够完成VLAN下的配置。

注意事项

执行vlan configuration命令只能进入VLAN配置视图,对应的VLAN不生效,VLAN下的配置也不生效。如需VLAN下的配置生效,必须通过命令vlan创建VLAN。

以下情况中设备上会出现vlan vlan-id configuration的显示信息。
  • 当使用vlan vlan-id configuration命令进入VLAN视图配置VLAN下的业务时;
  • 当通过VCMP协议删除VLAN时。

使用实例

# 进入ID是10的VLAN配置视图。

<HUAWEI> system-view
[HUAWEI] vlan 10 configuration
[HUAWEI-vlan10]

vlan precedence

命令功能

vlan precedence命令用来在同时匹配mac-vlan和ip-subnet-vlan的情况下,优先选择以何种方式将接口加入VLAN。

undo vlan precedence命令用来恢复该配置到缺省值。

缺省情况下,优先根据MAC地址来匹配VLAN。

说明:

X系列单板不支持该命令。

命令格式

vlan precedence { ip-subnet-vlan | mac-vlan }

undo vlan precedence

参数说明

参数

参数说明

取值

ip-subnet-vlan

配置优先根据IP子网来匹配VLAN。

-

mac-vlan

配置优先根据MAC地址来匹配VLAN。

-

视图

GE接口视图、XGE接口视图、40GE接口视图、100GE接口视图、Eth-Trunk接口视图、端口组视图

缺省级别

2:配置级

使用指南

应用场景

交换机同时支持多种方式划分VLAN,缺省的优先级由高到低依次为:策略VLAN、MAC VLAN、IP VLAN、协议VLAN、接口VLAN。

用户可通过本命令改变MAC VLAN和IP VLAN的优先级,从而决定优先划分VLAN的方式。例如:执行命令vlan precedence ip-subnet-vlan以后,交换机的VLAN划分优先级改变为:IP-SUBNET-VLAN优先于MAC-VLAN。

目前,最常用的方式是基于接口划分VLAN的方式。

注意事项

该命令只能改变MAC VLAN和IP VLAN的优先级,不能改变其它几种VLAN划分的优先级。

由于根据MAC地址和根据IP子网分别划分的VLAN可能不同,因此变更此规则后可能导致VLAN不通。

使用该本命令调整优先级时,只对不带掩码的MAC-VLAN生效。

在同一接口视图下多次使用vlan precedence命令,按最后一次配置生效。

使用实例

# 配置优先根据IP子网来匹配VLAN。

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] vlan precedence ip-subnet-vlan

vlan range

命令功能

vlan range命令用来创建临时VLAN组,并进入VLAN-Range视图。

缺省情况下,没有创建临时VLAN组。

命令格式

vlan range { vlan-id1 [ to vlan-id2 ] } &<1-10>

参数说明

参数 参数说明 取值
vlan-id1 [ to vlan-id2 ]
指定批量创建的VLAN ID,其中:
  • vlan-id1表示第一个VLAN的编号。

  • vlan-id2表示最后一个VLAN的编号。

    vlan-id2的取值必须大于等于vlan-id1,它与vlan-id1共同确定一个VLAN范围。

  • 如果不指定to vlan-id2参数,则只创建vlan-id1所指定的VLAN。

整数形式,取值范围是1~4094。

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

在大型二层网络中需要维护大量的VLAN信息,如果仅靠网络管理员手工配置或维护,不仅工作量大,同时也不能保证配置的一致性。为了提高维护效率,简化配置过程,可执行vlan range命令创建临时VLAN组,在VLAN-Range视图下配置相关业务。业务配置成功后会批量下发到VLAN组中的所有VLAN。

注意事项

执行vlan range命令后,系统不会生成配置文件。只有在VLAN-Range视图下配置相关业务后,VLAN组中所有成员VLAN会生成对应的配置文件。

指定的VLAN如果是动态VLAN或未创建的VLAN,临时VLAN组会创建失败。已经加入临时VLAN组的VLAN,如果被删除,会自动退出临时VLAN组。

配置影响

该命令是累增式命令,多次配置时,配置结果按多次累加生效。

使用实例

# 创建ID为10~20的临时VLAN组,并进入VLAN-Range视图。

<HUAWEI> system-view
[HUAWEI] vlan batch 10 to 20
[HUAWEI] vlan range 10 to 20
[HUAWEI-vlan-range]

vlan statistics interval

命令功能

vlan statistics interval命令用来配置VLAN的流量统计的时间间隔。

undo vlan statistics interval命令用来恢复VLAN的流量统计时间间隔为缺省值。

缺省情况下,VLAN的流量统计时间间隔为300秒。

命令格式

vlan statistics interval interval-time

undo vlan statistics interval

参数说明

参数

参数说明

取值

interval-time

VLAN流量统计的时间间隔

整数形式,取值范围为60~600,单位为秒。

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

当需要检查网络状况或处理网络故障时,可以打开VLAN的流量统计功能,统计通过VLAN的流量信息。

使用statistic enable(VLAN视图)命令打开VLAN的流量统计功能后,便开始对通过该VLAN的单播、组播和广播报文流量进行统计。

此时可以使用vlan statistics interval命令配置流量统计的时间间隔。

使用实例

# 配置VLAN的流量统计时间间隔为500秒。

<HUAWEI> system-view
[HUAWEI] vlan statistics interval 500

vlan vlan-name

命令功能

vlan vlan-name命令用来通过VLAN名称进入VLAN视图。

undo vlan vlan-name命令用来通过VLAN名称删除VLAN(包括VLAN名称)。

命令格式

vlan vlan-name vlan-name

undo vlan vlan-name vlan-name

参数说明

参数 参数说明 取值
vlan-name 指定VLAN名称。 字符串形式,区分大小写,不支持空格,长度范围是1~31。当输入的字符串两端使用双引号时,可在字符串中输入空格。

视图

系统视图

缺省级别

2:配置级

使用指南

应用场景

通过命令name配置VLAN名称后,为了便于用户操作,用户可在系统视图下执行命令vlan vlan-name直接进入对应的VLAN视图进行修改或查看。

如果设备上存在多个VLAN且每个VLAN都配有名称,若用户需要删除传输语音业务的VLAN,但是用户无法确定传输语音业务的VLAN ID时,可执行命令undo vlan vlan-name通过VLAN名称删除传输语音业务的VLAN。

前置条件

执行本命令前,必须已经通过命令name成功创建VLAN名称。

注意事项

通过VLAN名称删除VLAN时,VLAN下的相关业务都将被删除。重新创建相同ID的VLAN,删除的业务也不可恢复。执行undo vlan vlan-name命令前,请务必确认是否需要删除VLAN下的所有业务。

使用实例

# 通过名称user1进入对应的VLAN视图。
<HUAWEI> system-view
[HUAWEI] vlan vlan-name user1
[HUAWEI-vlan2]
翻译
下载文档
更新时间:2019-04-08

文档编号:EDOC1100065708

浏览量:11136

下载量:202

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页