所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IOAM示例

配置IOAM示例

组网需求

图17-7所示,某网络中Server1和Server2之间有多条转发路径,用户希望对Server1发送至Server2的流量转发路径及状态进行监测。

图17-7 配置IOAM组网图
表17-5 接口的IP地址

设备

接口

IP地址

SwitchA

100GE1/0/1

192.168.10.1/24

100GE1/0/2

192.168.20.1/24

100GE1/0/3

192.168.30.1/24

SwitchB

100GE1/0/1

192.168.40.1/24

100GE1/0/2

192.168.20.2/24

100GE1/0/3

192.168.50.2/24

SwitchC

100GE1/0/1

192.168.40.2/24

100GE1/0/2

192.168.60.2/24

100GE1/0/3

192.168.30.2/24

SwitchD

100GE1/0/1

192.168.70.1/24

100GE1/0/2

192.168.50.1/24

100GE1/0/3

192.168.60.1/24

100GE1/0/4

192.168.80.1/24

配置思路

采用如下的思路配置:
  1. 配置接口IP地址及路由协议,实现各节点间路由互通。
  2. 配置SwitchA作为Ingress节点,采集并复制从Server1发送至Server2的业务流量。
  3. 配置SwitchB、SwitchC作为传输节点,传输IOAM报文。
  4. 配置SwitchD作为Egress节点,将IOAM报文发送至分析器。

操作步骤

  1. 配置接口IP地址及路由协议,实现各节点间路由互通。具体配置过程略,配置结果请参考配置文件
  2. 配置SwitchA作为Ingress节点,采集并复制从Server1发送至Server2的业务流量。设备不支持对IPv4分片非首片报文添加IOAM报文头。在配置Ingress节点时,在同一ACL规则里配置高优先级rule规则匹配非首片报文,动作为deny。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] acl 3001
    [*SwitchA-acl4-advance-3001] rule 5 deny ip fragment-type fragment
    [*SwitchA-acl4-advance-3001] rule 10 permit ip source 192.168.10.10 24 destination 192.168.70.10 24
    [*SwitchA-acl4-advance-3001] quit
    [*SwitchA] traffic classifier c1
    [*SwitchA-classifier-c1] if-match acl 3001
    [*SwitchA-classifier-c1] quit
    [*SwitchA] traffic behavior b1
    [*SwitchA-behavior-b1] ioam enable sampling-rate 10
    [*SwitchA-behavior-b1] quit
    [*SwitchA] traffic policy p1
    [*SwitchA-trafficpolicy-p1] classifier c1 behavior b1
    [*SwitchA-trafficpolicy-p1] quit
    [*SwitchA] interface 100ge 1/0/1
    [*SwitchA-100GE1/0/1] traffic-policy p1 inbound
    [*SwitchA-100GE1/0/1] quit
    [*SwitchA] commit
    [~SwitchA] ioam device-id 1 add-metadata
    [*SwitchA] commit

  3. 配置SwitchB、SwitchC作为传输节点,传输IOAM报文。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] ioam device-id 2 add-metadata
    [*SwitchB] commit
    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] ioam device-id 3 add-metadata
    [*SwitchC] commit

  4. 配置SwitchD作为Egress节点,将IOAM报文发送至分析器。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchD
    [*HUAWEI] commit
    [~SwitchD] ioam device-id 4 termination 192.168.80.10 5000
    [*SwitchD] commit

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    acl number 3001
     rule 5 deny ip fragment-type fragment
     rule 10 permit ip source 192.168.10.0 0.0.0.255 destination 192.168.70.0 0.0.0.255
    #
    traffic classifier c1 type or
     if-match acl 3001
    #
    traffic behavior b1
     ioam enable sampling-rate 10
    #
    traffic policy p1
     classifier c1 behavior b1 precedence 5
    #
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
    #
    interface 100GE1/0/1
     port default vlan 10
     traffic-policy p1 inbound
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.20.1 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.30.1 255.255.255.0
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 1 add-metadata
    #
    ospf 1
     area 0.0.0.0
      network 192.168.10.0 0.0.0.255
      network 192.168.20.0 0.0.0.255
      network 192.168.30.0 0.0.0.255
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    interface 100GE1/0/1
     undo portswitch
     ip address 192.168.40.1 255.255.255.0
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.20.2 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.50.2 255.255.255.0
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 2 add-metadata
    #
    ospf 1
     area 0.0.0.0
      network 192.168.20.0 0.0.0.255
      network 192.168.40.0 0.0.0.255
      network 192.168.50.0 0.0.0.255
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    interface 100GE1/0/1
     undo portswitch
     ip address 192.168.40.2 255.255.255.0
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.60.2 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.30.2 255.255.255.0
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 3 add-metadata
    #
    ospf 1
     area 0.0.0.0
      network 192.168.30.0 0.0.0.255
      network 192.168.40.0 0.0.0.255
      network 192.168.60.0 0.0.0.255
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 192.168.70.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.80.1 255.255.255.0
    #
    interface 100GE1/0/1
     port default vlan 20
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.50.1 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.60.1 255.255.255.0
    #
    interface 100GE1/0/4
     port default vlan 30
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 4 termination 192.168.80.10 5000
    #
    ospf 1
     area 0.0.0.0
      network 192.168.50.0 0.0.0.255
      network 192.168.60.0 0.0.0.255
      network 192.168.70.0 0.0.0.255
      network 192.168.80.0 0.0.0.255
    #
    return
    
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13047

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页