所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置NetStream Top Talkers示例

配置NetStream Top Talkers示例

组网需求

图14-9所示,企业用户部门1与部门2通过SwitchA接入到Internet网络,网络中没有部署NetStream服务器。用户希望了解两个部门与Internet网络的通信情况,可在SwitchA的10GE1/0/3接口部署NetStream Top Talkers功能,对接口的出、入方向的流量进行统计、排序、显示。

图14-9 NetStream Top Talkers组网图

配置思路

采用如下配置思路:

  1. 配置SwitchA各接口的IP地址。
  2. 配置NetStream Top Talkers模板。
  3. 配置NetStream采样功能。
  4. 在接口上应用NetStream Top Talkers模板。
  5. 启动NetStream Top Talkers功能。

操作步骤

  1. 配置SwitchA各接口IP地址

    # 配置SwitchA各接口IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 101 102
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 101
    [*SwitchA-Vlanif101] ip address 10.1.2.1 24
    [*SwitchA-Vlanif101] quit
    [*SwitchA] interface vlanif 102
    [*SwitchA-Vlanif102] ip address 10.1.3.1 24
    [*SwitchA-Vlanif102] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 101
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 101
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk pvid vlan 102
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 102
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

  2. 配置NetStream Top Talkers模板

    # 创建名称为“test”的NetStream Top Talkers模板,根据目的IP地址进行流量过滤,并配置NetStream Top Talkers模板可记录top talkers的数目为200,统计时间为1200000毫秒(20分钟),按照报文数对top talkers进行排序。

    [~SwitchA] netstream top-talkers test ip
    [*SwitchA-netstream-top-talkers-test] match ip destination-address 10.1.3.2 24
    [*SwitchA-netstream-top-talkers-test] top number 200
    [*SwitchA-netstream-top-talkers-test] cache-timeout 1200000
    [*SwitchA-netstream-top-talkers-test] sort-by packets
    [*SwitchA-netstream-top-talkers-test] quit
    [*SwitchA] commit
    

  3. 配置NetStream采样功能

    # 配置10GE1/0/3接口出、入流量的NetStream采样功能,采样间隔为8192。

    [~SwitchA] interface 10ge 1/0/3
    [~SwitchA-10GE1/0/3] netstream sampler random-packets 8192 inbound
    [*SwitchA-10GE1/0/3] netstream sampler random-packets 8192 outbound
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

  4. 在接口上应用NetStream Top Talkers模板

    # 使能10GE1/0/3接口出、入方向的NetStream Top Talkers功能。

    [~SwitchA] interface 10ge 1/0/3
    [~SwitchA-10GE1/0/3] netstream top-talkers test ip inbound
    [*SwitchA-10GE1/0/3] netstream top-talkers test ip outbound
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    [~SwitchA] quit
    

  5. 启动NetStream Top Talkers功能

    # 立即启动NetStream Top Talkers功能。

    <SwitchA> netstream top-talkers test ip starting

  6. 验证配置结果

    # 配置成功后,查看接口10GE1/0/3上NetStream Top Talkers模板对top talkers进行统计和排序的结果。

    <SwitchA> display netstream top-talkers test ip interface 10ge 1/0/3 slot 1
    Top-Talkers Name   : test
    Flow Type          : IPv4
    Top Number         : 200
    Sort-By            : PACKETS
    Cache-Timeout      : 1200000
    BeginCache Time    : 2014-12-10 09:59:44
    match DstIP/Mask   : 10.1.3.2/255.255.255.0
     -------------------------------------------------------------------------------
     SrcIP                     SrcPort  Bytes               BPS         BPM
     DstIP                     DstPort  Packets             PPS         PPM
     Interface                 Protocol Direction
     -------------------------------------------------------------------------------
    
     10.1.1.2                   0        62762800            2096200     125777100
     10.1.3.2                   0        729800              24300       1462500
     10GE1/0/3                  114      Inbound
    
     10.1.2.2                   0        61894200            2067200     124036400
     10.1.3.2                   0        719700              24000       1442200
     10GE1/0/3                  114      Inbound
    
     -------------------------------------------------------------------------------
     2 of 200 top talkers shown. 2 flows processed.
     -------------------------------------------------------------------------------

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
netstream top-talkers test ip
 match ip destination-address 10.1.3.2 255.255.255.0
 top number 200
 sort-by packets
 cache-timeout 1200000
#
vlan batch 100 to 102 
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif101
 ip address 10.1.2.1 255.255.255.0
#
interface Vlanif102
 ip address 10.1.3.1 255.255.255.0 
#
interface 10GE1/0/1
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100
#
interface 10GE1/0/2
 port link-type trunk
 port trunk pvid vlan 101
 port trunk allow-pass vlan 101
#
interface 10GE1/0/3
 port link-type trunk
 port trunk pvid vlan 102
 port trunk allow-pass vlan 102
 netstream sampler random-packets 8192 inbound
 netstream sampler random-packets 8192 outbound
 netstream top-talkers test ip inbound
 netstream top-talkers test ip outbound
#
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13545

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页