所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RMON示例

配置RMON示例

组网需求

图2-2所示,要求对交换机的接口10GE1/0/1连接的子网进行监控,包括:

  • 流量和各种类型包数量的实时和历史统计信息。

  • 当每分钟的流量超过设定值时,记录日志。

  • 监控此子网的广播和组播信息流量,当超过设定值时,主动向NMS上报告警信息。

图2-2 配置RMON组网图

配置思路

通过配置RMON统计功能可以实现流量和各种类型包数量的实时和历史统计信息的监控。配置RMON告警功能可以实现当流量超过设定值时,记录日志和主动向NMS上报告警信息的功能。

采用如下的思路配置RMON:

  1. 配置交换机接口的IP地址和网管端路由可达。
  2. 配置允许向NMS发送Trap报文。

  3. 使能统计功能并配置统计表和历史控制表,实现RMON统计功能。

  4. 配置事件表、告警表,实现RMON告警功能。

操作步骤

  1. 配置交换机接口的IP地址和路由

    <HUAWEI> system-view
    [~HUAWEI] vlan 100
    [*HUAWEI-vlan100] quit
    [*HUAWEI] interface vlanif 100
    [*HUAWEI-Vlanif100] ip address 10.1.2.1 24
    [*HUAWEI-Vlanif100] quit
    [*HUAWEI] quit
    [*HUAWEI] interface 10ge 1/0/2
    [*HUAWEI-10GE1/0/2] port link-type trunk
    [*HUAWEI-10GE1/0/2] port trunk pvid vlan 100
    [*HUAWEI-10GE1/0/2] port trunk allow-pass vlan 100
    [*HUAWEI-10GE1/0/2] quit
    [*HUAWEI] vlan 110
    [*HUAWEI-vlan110] quit
    [*HUAWEI] interface vlanif 110
    [*HUAWEI-Vlanif110] ip address 10.1.3.1 24
    [*HUAWEI-Vlanif110] quit
    [*HUAWEI] quit
    [*HUAWEI] interface 10ge 1/0/1
    [*HUAWEI-10GE1/0/1] port link-type trunk
    [*HUAWEI-10GE1/0/1] port trunk pvid vlan 110
    [*HUAWEI-10GE1/0/1] port trunk allow-pass vlan 110
    [*HUAWEI-10GE1/0/1] quit
    [*HUAWEI] ospf
    [*HUAWEI-ospf-1] area 0
    [*HUAWEI-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*HUAWEI-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*HUAWEI-ospf-1-area-0.0.0.0] quit
    [*HUAWEI-ospf-1] quit
    

  2. 配置允许向NMS发送Trap报文

    # 使能SNMP发送Trap的功能。

    [*HUAWEI] snmp-agent trap enable

    # 配置向指定的网管发送Trap。

    [*HUAWEI] snmp-agent target-host trap address udp-domain 10.1.1.1 params securityname nms-admin v3 privacy

  3. 配置统计功能

    # 使能RMON接口统计功能。

    [*HUAWEI] interface 10GE 1/0/1
    [*HUAWEI-10GE1/0/1] rmon-statistics enable
    

    # 配置统计表。

    [*HUAWEI-10GE1/0/1] rmon statistics 1 owner Test300
    

    # 配置历史控制表,设置RMON对子网中的流量信息采样,采样间隔为30秒钟,并保存最近10次数据。

    [*HUAWEI-10GE1/0/1] rmon history 1 buckets 10 interval 30 owner Test300
    [*HUAWEI-10GE1/0/1] quit

  4. 配置告警功能

    # 配置事件表,设置RMON的1号事件处理方式为记录日志,2号事件处理方式为向网管站发送Trap消息。

    [*HUAWEI] rmon event 1 log owner Test300
    [*HUAWEI] rmon event 2 description forUseofPrialarm trap public owner Test300
    

    # 配置告警表,设置采样间隔时间和触发告警事件1(告警OID为1.3.6.1.2.1.16.1.1.1.6.1)的阈值。

    [*HUAWEI] rmon alarm 1 1.3.6.1.2.1.16.1.1.1.6.1 30 absolute rising-threshold 500 1 falling-threshold 100 1 owner Test300
    [*HUAWEI] commit
    [~HUAWEI] quit

  5. 检查配置结果

    # 查看配置效果。可以随时查看子网的数据流量信息。

    <HUAWEI> display rmon statistics 10ge 1/0/1
    Statistics entry 1 owned by Test300 is valid.
      Interface : 10GE1/0/1<ifIndex.16>
      Received  :
      Octets              :142915224 , Packets          :1749151
      Broadcast packets   :11603     , Multicast packets:756252
      Undersize packets   :0         , Oversize packets :0
      Fragments packets   :0         , Jabbers packets  :0
      CRC alignment errors:0         , Collisions       :0
      Dropped packet (insufficient resources):1795
      Packets received according to length (octets):
      64     :150183    ,  65-127  :150183    ,  128-255  :1383
      256-511:3698      ,  512-1023:0         ,  1024-1518:0
    

    # 查看配置效果。

    <HUAWEI> display rmon history
    History control entry 1 owned by Test300 is valid
      Samples interface     : 10GE1/0/1<ifIndex.16>
      Sampling interval     : 30(sec) with 10 buckets max
      Last Sampling time    : 0days 00h:19m:43s.49th
      Latest sampled values :
      Octets               :654       , Packets           :0
      Broadcast packets    :7         , Multicast packets :0
      Undersize packets    :6         , Oversize packets  :0
      Fragments packets    :0         , Jabbers packets   :0
      CRC alignment errors :0         , Collisions        :0
      Dropped packet       :0         , Utilization       :0

    # 查看RMON事件的配置信息。

    <HUAWEI> display rmon event
    Event table 1 owned by Test300 is valid.
      Description: null.
      Will cause log  when triggered, last triggered at 0days 00h:24m:10s.05th.
    Event table 2 owned by Test300 is valid.
      Description: forUseofPrialarm.
      Will cause snmp-trap when triggered, last triggered at 0days 00h:26m:10s.05th.

    # 查看RMON告警的配置信息。

    <HUAWEI> display rmon alarm 1
    Alarm table 1 owned by Test300 is valid.
    Samples  absolute value   : 1.3.6.1.2.1.16.1.1.1.6.1
    Sampling interval         : 30(sec)
    Rising threshold          : 500(linked with event 1)
    Falling threshold         : 100(linked with event 1)
    When startup enables      : risingOrFallingAlarm
    Latest value              : 1975

    # 查看事件日志信息。

    <HUAWEI> display rmon eventlog
    Event table 1 owned by Test300 is valid.
      Generates eventLog 1.1 at 0days 00h:39m:30s.01th.
      Description: The 1.3.6.1.2.1.16.1.1.1.6.1 defined in alarm table 1 is less than or equal to 100 with alarm value 0. Alarm sample type is absolute.

配置文件

#
vlan batch 100 110
#
interface Vlanif100
 ip address 10.1.2.1 255.255.255.0
#
interface Vlanif110
 ip address 10.1.3.1 255.255.255.0
#
interface 10GE1/0/2
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100
#
interface 10GE1/0/1
 port link-type trunk
 port trunk pvid vlan 110
 port trunk allow-pass vlan 110
 rmon-statistics enable
 rmon statistics 1 owner Test300
 rmon history 1 buckets 10 interval 30 owner Test300
#
ospf 1
 area 0.0.0.0
  network 10.1.2.0 0.0.0.255
  network 10.1.3.0 0.0.0.255
#
snmp-agent target-host trap address udp-domain 10.1.1.1 params securityname nms-admin v3 privacy
#
rmon event 1 description null log owner Test300
rmon event 2 description forUseofPrialarm trap public owner Test300
rmon alarm 1 1.3.6.1.2.1.16.1.1.1.6.1 30 absolute rising-threshold 500 1 falling-threshold 100 1 owner Test300
#
snmp-agent trap enable
#
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:12830

下载量:223

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页