所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置设备使用SNMP Proxy与网管通信示例

配置设备使用SNMP Proxy与网管通信示例

组网需求

SNMP提供了一种通过运行网络管理系统来管理网元的方法。当网元的数量比较多时,管理成本也会很高。

图1-18所示,为了解决上述问题,可以在主设备上部署SNMP Proxy对被管理设备进行管理。从NMS角度来看,主设备和被管理设备虚拟为一个独立的网元来管理,避免了网管需要管理多个网元,从而节约了管理成本。
图1-18 配置设备使用SNMP Proxy与网管通信组网图

配置思路

采用如下的思路配置设备使用SNMP Proxy与网管通信:

  • 配置主设备

    1. 配置接口IP地址,实现主设备分别和NMS、被管理设备之间三层互通。
    2. 配置SNMP Proxy,主设备将按照用户配置的参数接入被管理设备业务,实现对被管理设备的管理。
  • 配置被管理设备

    1. 配置接口IP地址,实现被管理设备和主设备之间三层互通。
    2. 配置SNMP协议,实现网管和被管理设备间的正常通信。

操作步骤

  1. 配置主设备的接口IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] vlan 200
    [*SwitchA-vlan200] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ip address 192.168.1.1 24
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 200
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 200
    [*SwitchA-10GE1/0/2] quit
    

  2. 配置主设备为SNMP Proxy

    [*SwitchA] snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3
    [*SwitchA] snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 authentication-mode sha
    Please configure the authentication password (8-255)                            
    Enter Password:               //输入认证密码,本例的认证密码为:Authe@1234。
    Confirm Password:             //确认认证密码,本例的认证密码为:Authe@1234。
    
    [*SwitchA] snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 privacy-mode aes256
    Please configure the privacy password (8-255)                                   
    Enter Password:              //输入加密密码,本例的加密密码为:Priva@1234。
    Confirm Password:            //确认加密密码,本例的加密密码为:Priva@1234。
    
    [*SwitchA] snmp-agent proxy rule proxy_rule_read read remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy
    [*SwitchA] snmp-agent proxy rule proxy_rule_write write remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy
    [*SwitchA] snmp-agent proxy target-host proxy_host@NMS address udp-domain 10.1.2.1 udp-port 162 params securityname snmpv3 v3 privacy
    [*SwitchA] commit
    [~SwitchA] quit

  3. 配置被管理设备

    配置SNMPv3详细过程,请参考配置设备使用SNMPv3与网管通信示例(USM用户)

  4. 验证配置结果

    # 查看SNMP协议报文代理规则。

    <SwitchA> display snmp-agent proxy rule
       Proxy rule name : proxy_rule_read
           Type             : read
           Remote engine ID : 800007DB0338EBD9210010
           Host name        : proxy_host
           Security name    : snmpv3
           Version          : v3
           Level            : Privacy
    
       Proxy rule name : proxy_rule_write
           Type             : write
           Remote engine ID : 800007DB0338EBD9210010
           Host name        : proxy_host
           Security name    : snmpv3
           Version          : v3
           Level            : Privacy

    # 查看SNMP Proxy的目的主机信息。

    <SwitchA> display snmp-agent proxy target-host
    Proxy target host NO. 1
    -----------------------------------------------------------
      Host name        : proxy_host@NMS
      IP address       : 10.1.2.1
      Port             : 162
      Timeout          : 15
      Source interface : -
      VPN instance     : -
      Security name    : snmpv3
      Version          : v3
      Level            : Privacy
    -----------------------------------------------------------

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 100 200
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif200
 ip address 192.168.1.1 255.255.255.0
#
interface 10GE1/0/1
 port link-type trunk                                                           
 port trunk pvid vlan 100                                                       
 port trunk allow-pass vlan 100      
#
interface 10GE1/0/2
 port link-type trunk                                                           
 port trunk pvid vlan 200                                                       
 port trunk allow-pass vlan 200      
#
snmp-agent                                                                      
snmp-agent local-engineid 800007DB03001974593301 
#
snmp-agent sys-info version v3  
#                                                                              
snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3         
snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 authentication-mode sha cipher %^%#>rWG1!T'uGx-eiWUd2o$|YX@W/Pnj9(di:TNF84B%^%#                         
snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 privacy-mode aes256 cipher %^%#2Qkp*gA$D~TXG^J$1/PG0[=57kq~JPj>hS,znsC*%^%#                             
#                                                                               
snmp-agent proxy target-host proxy_host@NMS address udp-domain 10.1.2.1 udp-port 162 params securityname snmpv3 v3 privacy                                
#                                                                               
snmp-agent proxy rule proxy_rule_read read remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy               
snmp-agent proxy rule proxy_rule_write write remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy             
#                                                    
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:12931

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页