所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置原始流统计信息的输出示例

配置原始流统计信息的输出示例

组网需求

图14-4所示,企业用户部门1与部门2通过SwitchA接入到Internet网络,用户希望掌握2个部门与Internet网络通信的流量统计信息,以便进行网络规划。

图14-4 NetStream组网图

配置思路

用户可以在SwitchA的10GE1/0/1接口部署IPv4原始流统计信息输出功能,统计接口的出、入方向的流量信息,并上送至NetStream服务器进行后续分析,以便进行网络规划。

采用如下配置思路:

  1. 配置SwitchA的接口IP地址。
  2. 配置NetStream采样功能。
  3. 配置NetStream的流老化。
  4. 配置NetStream原始流统计信息输出。
  5. 配置输出报文版本格式。
  6. 使能接口的原始流NetStream统计功能。

操作步骤

  1. 图14-4标注所示,配置SwitchA的接口IP地址

    # 配置SwitchA的接口IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 110
    [*SwitchA-vlan110] quit
    [*SwitchA] interface vlanif 110
    [*SwitchA-Vlanif110] ip address 10.1.1.1 24
    [*SwitchA-Vlanif110] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 110
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 110
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] vlan 120
    [*SwitchA-vlan120] quit
    [*SwitchA] interface vlanif 120
    [*SwitchA-Vlanif120] ip address 10.1.2.1 24
    [*SwitchA-Vlanif120] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 120
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 120
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] vlan 130
    [*SwitchA-vlan130] quit
    [*SwitchA] interface vlanif 130
    [*SwitchA-Vlanif130] ip address 10.1.3.1 24
    [*SwitchA-Vlanif130] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk pvid vlan 130
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 130
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] vlan 140
    [*SwitchA-vlan140] quit
    [*SwitchA] interface vlanif 140
    [*SwitchA-Vlanif140] ip address 10.1.4.1 24
    [*SwitchA-Vlanif140] quit
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port link-type trunk
    [*SwitchA-10GE1/0/4] port trunk pvid vlan 140
    [*SwitchA-10GE1/0/4] port trunk allow-pass vlan 140
    [*SwitchA-10GE1/0/4] quit

  2. 配置NetStream采样功能

    # 配置10GE1/0/1接口出、入流量的NetStream采样功能,采样间隔为8192。

    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] netstream sampler random-packets 8192 inbound
    [*SwitchA-10GE1/0/1] netstream sampler random-packets 8192 outbound
    [*SwitchA-10GE1/0/1] quit

  3. 配置NetStream的流老化

    # 配置非活跃流的老化时间为100秒,以及开启由TCP连接的FIN和RST报文触发老化。

    [*SwitchA] netstream timeout ip inactive 100
    [*SwitchA] netstream timeout ip tcp-session

  4. 配置NetStream原始流统计信息输出

    # 配置NetStream原始流统计信息输出报文源地址为10.1.2.1,目的地址和目的端口号分别为10.1.2.2和6000。

    [*SwitchA] netstream export ip source 10.1.2.1
    [*SwitchA] netstream export ip host 10.1.2.2 6000

  5. 配置输出报文版本格式

    # 配置输出报文版本为V9。

    [*SwitchA] netstream export ip version 9

  6. 使能接口的原始流NetStream统计功能

    # 使能10GE1/0/1接口出、入流量的NetStream统计功能。

    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] netstream outbound ip
    [*SwitchA-10GE1/0/1] netstream inbound ip
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

  7. 验证配置结果

    # 配置成功后,查看流量统计信息。

    [~SwitchA] display netstream statistics ip slot 1
     Time statistics were last cleared: -                                           
     -------------------------------------------------------------------------------
     Packet Length    : Number                                     
     -------------------------------------------------------------------------------
     1      ~    64   : 0                                                          
     65     ~    128  : 12                                                           
     129    ~    256  : 0                                                           
     257    ~    512  : 0                                                           
     513    ~    1024 : 0                                                           
     1025   ~    1500 : 0                                                           
     longer than 1500 : 0                                                           
     -------------------------------------------------------------------------------
     StreamType                                                                     
          Current           Aged        Created       Exported       Exported       
          (streams)         (streams)   (streams)     (streams)      (Packets)      
     -------------------------------------------------------------------------------
     origin                                                                         
                1              3              4              3              3       
     -------------------------------------------------------------------------------
     as                                                                             
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     as-tos                                                                         
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     protocol-port                                                                  
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     protocol-port-tos                                                              
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     source-prefix                                                                  
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     source-prefix-tos                                                              
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     destination-prefix                                                             
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     destination-prefix-tos                                                         
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     prefix                                                                         
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     prefix-tos                                                                     
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     mpls-label                                                                      
                0              0              0              0              0        
     -------------------------------------------------------------------------------
     vlan-id                                                                        
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     bgp-nexthop-tos                                                                
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     index-tos                                                                      
                0              0              0              0              0       
     -------------------------------------------------------------------------------
     source-index-tos                                                               
                0              0              0              0              0       
     -------------------------------------------------------------------------------

配置文件

SwitchA的配置文件

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 110 120 130 140 
# 
netstream timeout ip inactive 100                                               
netstream timeout ip tcp-session 
netstream export ip version 9
netstream export ip source 10.1.2.1
netstream export ip host 10.1.2.2 6000
#
interface Vlanif110                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif120                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif130                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif140                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                               
interface 10GE1/0/1                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 110                                                       
 port trunk allow-pass vlan 110 
 netstream inbound ip                                                           
 netstream outbound ip                                                          
 netstream sampler random-packets 8192 inbound                                  
 netstream sampler random-packets 8192 outbound  
#                                                                               
interface 10GE1/0/2                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 120                                                       
 port trunk allow-pass vlan 120  
#                                                                               
interface 10GE1/0/3                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 130                                                       
 port trunk allow-pass vlan 130 
#                                                                               
interface 10GE1/0/4                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 140                                                       
 port trunk allow-pass vlan 140 
#
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13681

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页