所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
通过VMware NSX控制器部署VXLAN二层网关及BFD for VXLAN示例

通过VMware NSX控制器部署VXLAN二层网关及BFD for VXLAN示例

组网需求

图6-8所示,某企业的数据中心网络中包含了多个厂商的设备,其中大部分是VMware的设备。用户希望通过VMware NSX控制器来统一管理和部署数据中心的Overlay网络,VMware的NSX OVS支持作为VTEP,可以被VMware NSX控制器管理。但是对于裸金属机,VMware NSX控制器是无法管理的,此时这些裸金属机可以通过CE交换机接入VMware NSX控制器部署的Overlay网络。当VM较多时,使用集中复制可以减小网关压力。为提高网络可靠性,在Leaf4堆叠系统与Replicator之间的VXLAN隧道上部署BFD,当Replicator出现故障时,VXLAN网关能够快速感知并切换到其他可用Replicator节点,避免故障感知较慢造成的流量丢失。

图6-8 VMware NSX控制器部署Overlay网络组网图

配置思路

采用如下思路实现通过VMware NSX控制器部署VXLAN二层网关及BFD for VXLAN。
  1. 配置Leaf4-1设备和Leaf4-2设备组成堆叠系统Leaf4。
  2. 在Leaf4堆叠系统中配置各接口IP地址,并通过OSPF发布路由。
  3. 在Leaf4堆叠系统中配置Eth-Trunk接口。
  4. 在Leaf4堆叠系统中配置SSL策略。
  5. 在Leaf4堆叠系统中创建NVE接口,并配置源端VTEP的IP地址。
  6. 在Leaf4堆叠系统中配置OVSDB功能。
  7. 通过VMware NSX控制器部署Leaf4堆叠系统作为VXLAN二层网关及BFD for VXLAN。

数据准备

为完成此配置例,需准备如下的数据:
  • Leaf4堆叠系统的堆叠端口stack-port 1/1包含Leaf4-1的接口10GE1/0/3~10GE1/0/6、Leaf4-2的接口10GE1/0/3~10GE1/0/6。
  • 通过Leaf4堆叠系统接入VXLAN网络的VM所属的VLAN ID为VLAN 10。
  • 网络中设备互连的接口IP地址。
  • 网络中使用的路由类型是OSPF。
  • VXLAN网络标识VNI ID是VNI 5000。
  • 广播域BD ID是BD 5000。通过VMware NSX控制器部署CE交换机的VXLAN时,会自动创建BD,该BD的ID与VNI ID一致。
  • VMware NSX控制器的IP地址192.168.60.240;服务器1的VTEP IP地址192.168.40.12;Replicator1的VTEP IP地址192.168.40.13;Replicator2的VTEP IP地址192.168.40.14。

操作步骤

  1. 配置Leaf4-1和Leaf4-2组成堆叠系统Leaf4。

    # 配置Leaf4-1的堆叠优先级为150,Domain ID为10。缺省情况下,设备的堆叠成员ID为1。此处默认Leaf4-1的堆叠成员ID为1,无需配置。

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf4-1
    [*HUAWEI] commit
    [~Leaf4-1] stack
    [~Leaf4-1-stack] stack member 1 priority 150
    [*Leaf4-1-stack] stack member 1 domain 10
    [*Leaf4-1-stack] quit
    [*Leaf4-1] commit

    # 配置Leaf4-2的堆叠成员ID为2,优先级为120,Domain ID为10。

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf4-2
    [*HUAWEI] commit
    [~Leaf4-2] stack
    [~Leaf4-2-stack] stack member 1 priority 120
    [*Leaf4-2-stack] stack member 1 domain 10
    [*Leaf4-2-stack] stack member 1 renumber 2 inherit-config
    Warning: The stack configuration of member ID 1 will be inherited to member ID 2 after the device resets. Continue? [Y/N]: y
    [*Leaf4-2-stack] quit
    [*Leaf4-2] commit

    # 将Leaf4-1和Leaf4-2的业务口10GE1/0/3~10GE1/0/6加入堆叠端口1/1。Leaf4-2的配置与Leaf4-1的配置类似。

    [~Leaf4-1] interface stack-port 1/1
    [*Leaf4-1-Stack-Port1/1] port member-group interface 10ge 1/0/3 to 1/0/6
    Warning: After the configuration is complete,
    1.The interface(s) (10GE1/0/3-1/0/6) will be converted to stack mode and be configured with the port crc-statistics trigger error-down command if the configuration does not exist. 
    2.The interface(s) may go Error-Down (crc-statistics) because there is no shutdown configuration on the interfaces.Continue? [Y/N]: y
    [*Leaf4-1-Stack-Port1/1] commit
    [~Leaf4-1-Stack-Port1/1] return

    # 上述配置完成后,执行命令display stack configuration查看配置是否与规划的一致,如果不一致,需要修改配置。以查看Leaf4-1为例。

    <Leaf4-1> display stack configuration
    Oper          : Operation
    Conf          : Configuration
    *             : Offline configuration
    Isolated Port : The port is in stack mode, but does not belong to any Stack-Port
    
    Attribute Configuration:
    ----------------------------------------------------------------------------
     MemberID      Domain         Priority       Switch Mode     Uplink Port
    Oper(Conf)   Oper(Conf)      Oper(Conf)      Oper(Conf)      Oper(Conf)
    ----------------------------------------------------------------------------
    1(1)         --(10)          100(150)        Auto(Auto)      6*40GE(6*40GE)
    ----------------------------------------------------------------------------
    
    Stack-Port Configuration:
    --------------------------------------------------------------------------------
    Stack-Port      Member Ports
    --------------------------------------------------------------------------------
    Stack-Port1/1   10GE1/0/3           10GE1/0/4           10GE1/0/5
                    10GE1/0/6
    --------------------------------------------------------------------------------

    # 保存Leaf4-1和Leaf4-2的配置,然后将设备下电。Leaf4-2的配置与Leaf4-1的配置类似。

    <Leaf4-1> save
    Warning: The current configuration will be written to the device. Continue? [Y/N]: y

    # 通过Console口或管理网口登录堆叠系统,使用命令display stack查看堆叠是否组建成功。当通过管理网口登录时,需要使用主交换机的IP地址。

    <Leaf4-1> display stack
    --------------------------------------------------------------------------------
    MemberID Role     MAC              Priority   DeviceType         Description
    --------------------------------------------------------------------------------
    +1       Master   0004-9f31-d520   150        CE6850-48S6Q-HI 
     2       Standby  0004-9f62-1f40   120        CE6850-48S6Q-HI 
    --------------------------------------------------------------------------------
    + indicates the device where the activated management interface resides.
    

    如上所示,显示两台交换机的信息,表示堆叠建立成功,且主交换机为成员ID为1的设备,即Leaf4-1。

  2. 在Leaf4堆叠系统中配置接口IP地址,并通过OSPF发布路由。

    <Leaf4-1> system-view
    [~Leaf4-1] interface loopback 1
    [*Leaf4-1-LoopBack1] ip address 1.1.1.1 32
    [*Leaf4-1-LoopBack1] quit
    [*Leaf4-1] interface loopback 2
    [*Leaf4-1-LoopBack2] ip address 2.2.2.2 32
    [*Leaf4-1-LoopBack2] quit
    [*Leaf4-1] ospf
    [*Leaf4-1-ospf-1] area 0
    [*Leaf4-1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*Leaf4-1-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*Leaf4-1-ospf-1-area-0.0.0.0] quit
    [*Leaf4-1-ospf-1] quit
    [*Leaf4-1] commit

    OSPF成功配置后,Leaf4堆叠系统与VMware NSX控制器、及其他服务器之间可以互相ping通。

  3. 在Leaf4堆叠系统中配置Eth-Trunk接口。

    [~Leaf4-1] interface eth-trunk 100
    [*Leaf4-1-Eth-Trunk100] trunkport 10ge 1/0/2
    [*Leaf4-1-Eth-Trunk100] trunkport 10ge 2/0/2
    [*Leaf4-1-Eth-Trunk100] quit
    [*Leaf4-1-Eth-Trunk100] commit

  4. 在Leaf4堆叠系统中配置SSL策略。
    1. 上传SSL证书到Leaf4-1的flash:/security目录下。
    2. 配置SSL策略。

      [~Leaf4-1] ssl policy nsx
      [*Leaf4-1-ssl-policy-nsx] certificate load pem-cert vtep-cert.pem key-pair rsa key-file vtep-privkey.pem auth-code cipher 123456
      [*Leaf4-1-ssl-policy-nsx] quit
      [*Leaf4-1] commit

  5. 在Leaf4堆叠系统中创建NVE接口,并配置源端VTEP的IP地址。

    通过VMware NSX控制器部署VXLAN网络时,仅支持创建接口编号为1的NVE接口作为VXLAN隧道相关信息的部署接口。

    [~Leaf4-1] interface nve 1
    [*Leaf4-1-Nve1] source 1.1.1.1
    [*Leaf4-1-Nve1] quit
    [*Leaf4-1] commit

  6. 在Leaf4堆叠系统中配置OVSDB功能。

    # 配置OVSDB功能。

    [~Leaf4-1] ovsdb server
    [*Leaf4-1-ovsdb-server] source ip 2.2.2.2
    [*Leaf4-1-ovsdb-server] controller ip 192.168.60.240
    [*Leaf4-1-ovsdb-server] ssl ssl-policy nsx
    [*Leaf4-1-ovsdb-server] smooth enable
    [*Leaf4-1-ovsdb-server] ovsdb server enable
    [*Leaf4-1-ovsdb-server] quit
    [*Leaf4-1] commit

  7. 通过VMware NSX控制器部署Leaf4堆叠系统作为VXLAN二层网关及BFD for VXLAN。

    # 添加逻辑交换机。

    1. 选择“Networking & Security > Logical Switches”,选择“NSX Manager”为192.168.60.240。

    2. 单击,出现“New Logical Switch”对话框。

      设置“Name”为Leaf4_vni5000,“TransportZone”为UCAST-ZONE,“Replication mode”为Unicast,勾选“Enable IP Discovery”。确认信息无误后,单击“OK”。

    # 添加硬件设备。

    1. 选择“Networking & Security > Service Definitions > Hardware Devices”,选择“NSX Manager”为192.168.60.240。

    2. 单击添加硬件设备,配置硬件设备名称,添加公钥,勾选“Enable BFD”功能。

      公钥获取方法:

      用记事本打开公钥vtep-cert.pem。 将-----BEGIN CERTIFICATE-----到-----END CERTIFICATE-----之间的内容(包括-----BEGIN CERTIFICATE-----和----END CERTIFICATE-----)复制到Certificate中。

    3. 确认信息无误后,单击“OK”,可以看到硬件设备与NSX控制器已建立连接,但是还未添加logical switch。

    # 将Leaf4上的接口绑定到逻辑交换机中。

    1. 选择“Networking & Security > Logical Switches”,选择“NSX Manager”为192.168.60.240。选中“Segment ID”为5000的Logical Switch,右击,选择“Manage Hardware Bindings”,出现“Leaf4_vni5000–Manage Hardware Bindings”对话框。

    2. 单击,出现上面添加的硬件设备。

    3. 单击“Select”,选择“Port”为Eth-Trunk100,设置“VLAN”为10。确认信息无误后,单击“OK”。

      如果服务器是通过VLAN接入网络,请用户将VLAN ID设置为对应的VLAN;如果服务器没有通过VLAN而是直接接入网络,请用户将VLAN ID设置为0。

      CE交换机对接VMware NSX控制器时,不支持配置VLAN 4094,请用户在规划网络时,不要选择VLAN 4094。

      此处设置的VLAN,不能与对应二层主接口允许通过的VLAN相同。

      当VLAN ID设置为非0时,表示封装类型为Dot1q;当VLAN ID设置为0时,表示封装类型为Untag。

    # 检查Leaf4堆叠系统与服务器1、Replicator1、Replicator2之间的VXLAN隧道是否建立成功。

    当State为up时,表示VXLAN隧道建立成功。

    [~Leaf4-1] display vxlan tunnel
    2018-04-07 19:48:13.264
    Number of vxlan tunnel : 3
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  2.2.2.2               192.168.40.12         up     static   03:52:21
    4026531842  2.2.2.2               192.168.40.13         up     static   03:52:21
    4026531843  2.2.2.2               192.168.40.14         up     static   03:52:21

    # 配置VXLAN集中复制列表。

    1. 选择“Networking & Security > Service Definitions > Hardware Devices”,选择“NSX Manager”为192.168.60.240。

    2. 选中添加的硬件交换机。选择“Replication Cluster> Edit”,出现“Edit Replication Cluster Configuration”对话框。确认无误后单击“OK”。

    # 检查BFD连接状态。

    [~Leaf4-1] display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    LDP: LDP session
    LSP: Label switched path
    TE: Traffic Engineering
    AUTO: Automatically negotiated session
    VXLAN: VXLAN session
    (w): State in WTR
    (*): State is invalid
    Total UP/DOWN Session Number : 2/0
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName 
    --------------------------------------------------------------------------------
    16385      16385      192.168.40.13   Up        S/AUTO-VXLAN       - 
    16386      16385      192.168.40.14   Up        S/AUTO-VXLAN       - 
    --------------------------------------------------------------------------------

    # 检查VXLAN的集中复制信息。

    [~Leaf4-1] display vxlan flood-vtep vni 5000
    Number of peers : 2
    Vni ID    Source             Destination       Type       Status
    ----------------------------------------------------------------------
    5000      1.1.1.1            192.168.40.13     static     primary          
    5000      1.1.1.1            192.168.40.14     static     backup   

配置文件

Leaf4堆叠系统的配置文件

#
sysname Leaf4-1
#
ssl policy nsx
 certificate load pem-cert vtep-cert.pem key-pair rsa key-file vtep-privkey.pem auth-code cipher %^%#<`c/:cbTs/'sK\S+ct)8ia_d!Ukn|&7pOM!5|dT6%^%#
#
ovsdb server
 ssl ssl-policy nsx
 controller ip 192.168.60.240 port 6640 max-backoff 8000 inactivity-probe 60000
 source ip 2.2.2.2
 ovsdb server enable
 smooth enable
#
bridge-domain 5000
 ovsdb enable
 vxlan vni 5000
#
stack
 #
 stack member 1 domain 10
 stack member 1 priority 150
 #
 stack member 2 domain 10
 stack member 2 priority 120
#
interface Eth-Trunk100.1 mode l2
 encapsulation dot1q vid 10
 bridge-domain 5000
#
interface Stack-Port1/1
#
interface Stack-Port2/1
#
interface 10GE1/0/2
 eth-trunk 100 
#
interface 10GE1/0/3
 port mode stack
 stack-port 1/1
 port crc-statistics trigger error-down
#
interface 10GE1/0/4
 port mode stack
 stack-port 1/1
 port crc-statistics trigger error-down
#
interface 10GE1/0/5
 port mode stack
 stack-port 1/1
 port crc-statistics trigger error-down
#
interface 10GE1/0/6
 port mode stack
 stack-port 1/1
 port crc-statistics trigger error-down
#
interface 10GE2/0/2
 eth-trunk 100 
#
interface 10GE2/0/3
 port mode stack
 stack-port 2/1
 port crc-statistics trigger error-down
#
interface 10GE2/0/4
 port mode stack
 stack-port 2/1
 port crc-statistics trigger error-down
#
interface 10GE2/0/5
 port mode stack
 stack-port 2/1
 port crc-statistics trigger error-down
#
interface 10GE2/0/6
 port mode stack
 stack-port 2/1
 port crc-statistics trigger error-down
#
interface LoopBack1
 ip address 1.1.1.1 255.255.255.255
#
interface LoopBack2
 ip address 2.2.2.2 255.255.255.255
#
interface Nve1
 source 1.1.1.1
 vni 5000 head-end peer-list 192.168.40.12
 vni 5000 head-end peer-list 192.168.40.13
 vni 5000 head-end peer-list 192.168.40.14
 vni 5000 flood-vtep 192.168.40.13
 vni 5000 flood-vtep 192.168.40.14
#
bfd vxlanc0a83c0a bind vxlan peer-ip 192.168.40.13 source-ip 1.1.1.1 peer-mac 0000-0000-0000 auto
#
bfd vxlanc0a83c0b bind vxlan peer-ip 192.168.40.14 source-ip 1.1.1.1 peer-mac 0000-0000-0000 auto
#
ospf 1
 area 0.0.0.0
  network 1.1.1.1 0.0.0.0
  network 2.2.2.2 0.0.0.0
#
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13389

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页