所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置OpenFlow Agent示例

配置OpenFlow Agent示例

组网需求

图5-7所示,Switch为OpenFlow兼容型交换机,控制器和Switch之间路由可达。当用户希望通过控制器对Switch进行控制和管理时,可以在控制器和Switch上分别配置OpenFlow连接参数,建立控制器和Switch之间的OpenFlow连接,实现控制器和Switch之间的信息交互。

图5-7 OpenFlow连接组网图

操作步骤

  1. 配置控制器OpenFlow连接参数。

    控制器OpenFlow连接参数的相关配置,请参见控制器相关指导书。

  2. 配置OpenFlow Agent。

    # 配置Switch接口IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 20
    [*Switch-vlan20] quit
    [*Switch] interface vlanif 20
    [*Switch-Vlanif20] ip address 10.1.1.2 24
    [*Switch-Vlanif20] quit
    [*Switch] interface 10ge 4/0/1
    [*Switch-10GE4/0/1] port link-type trunk
    [*Switch-10GE4/0/1] port trunk pvid vlan 20
    [*Switch-10GE4/0/1] port trunk allow-pass vlan 20
    [*Switch-10GE4/0/1] quit
    [*Switch] interface loopback 1
    [*Switch-LoopBack1] ip address 10.10.10.10 32
    [*Switch-LoopBack1] commit
    [~Switch-LoopBack1] quit

    # 配置Switch的OpenFlow Agent。

    [~Switch] sdn agent 
    [*Switch-sdn-agent] source-ip 10.10.10.10
    [*Switch-sdn-agent] controller-ip 10.1.2.1
    [*Switch-sdn-agent-ctrl-10.1.2.1] quit
    [*Switch-sdn-agent] quit
    [*Switch] commit
    

  3. 检查配置结果。

    配置完成后,可以在Switch上执行命令display sdn openflow session查看控制器和Switch的OpenFlow连接状态是否为“Registered”,如果是则说明OpenFlow连接建立成功。

    [~Switch] display sdn openflow session
    
    --------------------------------------------------------------------------------
    Agent           Controller      UpTime       State      Role      VPN-instance
    --------------------------------------------------------------------------------
    10.10.10.10     10.1.2.1        0d21h09m32s  Registered Master     _public_
    --------------------------------------------------------------------------------

配置文件

Switch的配置文件

#
sdn agent
 source-ip 10.10.10.10
 controller-ip 10.1.2.1
#
vlan batch 20
#
interface Vlanif20
 ip address 10.1.1.2 255.255.255.0
#
interface 10GE4/0/1
 port link-type trunk
 port trunk pvid vlan 20
 port trunk allow-pass vlan 20
#
interface LoopBack1
 ip address 10.10.10.10 255.255.255.255
#
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13018

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页