所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置设备使用SNMPv3与网管通信示例(AAA本地用户)

配置设备使用SNMPv3与网管通信示例(AAA本地用户)

组网需求

图1-16所示,网管对网络中的设备进行监管。由于设备上已经配置了AAA用户,用户希望SNMPv3使用AAA本地用户进行认证,这样就可以做到使用相同的用户名实现对设备的管理。

图1-16 配置设备使用SNMPv3与网管通信示例(AAA本地用户)

配置思路

采用如下的配置思路:

  1. 配置SwitchA的IP地址,使得SwitchA和NMS之间路由可达。

  2. 配置AAA本地用户以及用户组,AAA本地用户的服务类型为SNMP,用户组通过TASK授权。

  3. 配置SNMPv3使用该用户,并配置认证和加密以提高SwitchA和NMS数据传输的安全性。

  4. 配置NMS,实现设备和NMS的对接。

操作步骤

  1. 配置SwitchA的IP地址

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.2 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] commit

  2. 配置AAA用户及用户组

    # 配置AAA用户,服务类型为SNMP。

    [~SwitchA] aaa
    [~SwitchA-aaa] local-user usersnmp password irreversible-cipher SetUesrPasswd@123
    [*SwitchA-aaa] local-user usersnmp service-type snmp
    [*SwitchA-aaa] local-user usersnmp level 3
    

    # 配置AAA用户组,以及TASK授权,并将用户加入用户组。

    [*SwitchA-aaa] task-group tasksnmp
    [*SwitchA-aaa-task-group-tasksnmp] task snmp read write
    [*SwitchA-aaa-task-group-tasksnmp] quit
    [*SwitchA-aaa] user-group groupsnmp
    [*SwitchA-aaa-user-group-groupsnmp] task-group tasksnmp
    [*SwitchA-aaa-user-group-groupsnmp] quit
    [*SwitchA-aaa] local-user usersnmp user-group groupsnmp
    [*SwitchA-aaa] quit
    

  3. 配置SNMPv3应用AAA用户,采用交互式输入认证和加密密码

    [*SwitchA] snmp-agent local-user v3 usersnmp authentication-mode sha privacy-mode aes128
    Please configure the authentication password (8-255)
    Enter Password:               //输入认证密码,本例的认证密码为:Authe@1234。
    Confirm Password:             //确认认证密码,本例的认证密码为:Authe@1234。
    Please configure the privacy password (8-255)
    Enter Password:              //输入加密密码,本例的加密密码为:Priva@1234。
    Confirm Password:            //确认加密密码,本例的加密密码为:Priva@1234。
    
    [*SwitchA] commit
    [~SwitchA] quit

  4. 配置NMS

    以eSight V300R005C00为例,说明网管侧的配置。

    1. 在主菜单中选择“资源 > 资源添加 > 单个添加”,单击“网络设备”。
    2. 单击“SNMP协议 > 手动编辑SNMP参数”,配置SNMP版本为V3,安全名为usersnmp,鉴权协议为HMAC_SHA,认证密码为Authe@1234,私有协议为AES_128,加密密码为Priva@1234,端口号为161。

      此处网管侧配置的安全名、鉴权加密参数和端口号必须与设备侧配置用户名、鉴权加密参数和端口号保持一致,且设备侧需要使能网管侧配置的SNMP版本,否则将无法连接设备。

    3. 单击“确定”。
    图1-17 eSight网管SNMP配置界面

  5. 验证配置结果

    配置完成后,SwitchA和NMS能够进行通信,在NMS上可以对SwitchA进行管理。

    # 在设备上执行下面的命令,可以检查SNMPv3本地用户信息。

    <SwitchA> display snmp-agent local-user
       User name: usersnmp
           Engine ID: 800007DB03360102101100
           Authentication Protocol: sha
           Privacy Protocol: aes128
           State: Active   

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 100
#
aaa 
 local-user usersnmp password irreversible-cipher $1c$jq@D({%F%%$2_o]0cDbL0JfH-77MkA'g<A$.fCo::;5(,*&~}p($
 local-user usersnmp service-type snmp
 local-user usersnmp user-group groupsnmp
 # 
 task-group tasksnmp
  task interface-mgr read write execute
  task config read write execute
  task snmp read write
  task vlan read write execute
  task shell read write execute
  task cli read execute
 #   
 user-group groupsnmp    
  task-group tasksnmp  
#
 interface Vlanif100
 ip address 10.1.1.2 255.255.255.0
#
interface 10GE1/0/1
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100
#
snmp-agent
snmp-agent local-engineid 800007DB03360102101100
#
snmp-agent sys-info version v3  
# 
snmp-agent local-user v3 usersnmp authentication-mode sha cipher %^%#>rWG1!T'uGx-eiWUd2o$|YX@W/Pnj9(di:TNF84B%^%# privacy-mode aes128 cipher %^%#2Qkp*gA$D~TXG^J$1/PG0[=57kq~JPj>hS,znsC*%^%#
# 
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13119

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页