所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置设备使用SNMPv3与网管通信示例(USM用户)

配置设备使用SNMPv3与网管通信示例(USM用户)

组网需求

图1-14所示,现有网络中网管NMS1和NMS2对网络中的设备进行监管。由于网络规模较大,安全性较低,在规划时配置设备使用SNMPv3版本与网管进行通信,并配置认证加密功能保证安全性。现在由于扩容需要,新增一台交换机,并由网管对其进行监管。

用户希望通过利用现有的网络资源对交换机进行监管,并且在发生故障时能够快速对故障进行定位和排除。根据用户业务需要,网管站需要对交换机上除ISIS之外的节点进行管理。

图1-14 配置使用SNMPv3与网管通信组网图(USM用户)

配置思路

考虑到用户所在网络规模较大,安全性较低,因此新增设备依然使用SNMPv3版本。为减轻网管站的负担,选取NMS2来监管交换机,NMS1不监管交换机

采用如下的配置思路:

  1. 配置访问权限,使NMS2可以管理交换机上ISIS之外的节点。

  2. 配置用户组和用户,NMS2通过用户组和用户与设备建立连接。

  3. 配置告警主机,使交换机产生的告警能够发送至NMS2。为了方便对告警信息进行定位,避免过多的无用告警对处理问题造成干扰,仅允许缺省打开的模块可以发送告警。

  4. 配置网管站(仅NMS2)。

操作步骤

  1. 配置交换机的接口IP地址

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 100
    [*Switch] interface vlanif 100
    [*Switch-Vlanif100] ip address 10.1.2.1 24
    [*Switch-Vlanif100] quit
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port link-type trunk
    [*Switch-10GE1/0/1] port trunk allow-pass vlan 100
    [*Switch-10GE1/0/1] quit
    [*Switch] commit

  2. 配置交换机和网管站之间路由可达

    [~Switch] ospf
    [*Switch-ospf-1] area 0
    [*Switch-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*Switch-ospf-1-area-0.0.0.0] quit
    [*Switch-ospf-1] quit
    [*Switch] commit

  3. 配置访问权限

    # 配置ACL,只允许NMS2可以管理交换机

    [~Switch] acl 2001
    [*Switch-acl4-basic-2001] rule 5 permit source 10.1.1.2 0.0.0.0
    [*Switch-acl4-basic-2001] quit

    # 配置MIB视图,限制NMS2可以管理交换机上除ISIS之外的节点。

    [*Switch] snmp-agent mib-view excluded allextisis 1.3.6.1.3.37
    

  4. 配置用户组和用户

    # 配置用户组和用户,并配置认证和加密方式。

    [*Switch] snmp-agent group v3 admin privacy write-view allextisis acl 2001
    [*Switch] snmp-agent usm-user v3 nms2-admin group admin
    [*Switch] snmp-agent usm-user v3 nms2-admin authentication-mode sha
    Please configure the authentication password (8-255)
    Enter Password:               //输入认证密码,本例的认证密码为:Authe@1234。
    Confirm Password:             //确认认证密码,本例的认证密码为:Authe@1234。
    
    [*Switch] snmp-agent usm-user v3 nms2-admin privacy-mode aes128
    Please configure the privacy password (8-255)
    Enter Password:              //输入加密密码,本例的加密密码为:Priva@1234。
    Confirm Password:            //确认加密密码,本例的加密密码为:Priva@1234。
    

  5. 配置告警主机

    [*Switch] snmp-agent target-host host-name NMS2 trap address udp-domain 10.1.1.2 params securityname nms2-admin v3 privacy
    [*Switch] commit
    [~Switch] quit

  6. 配置网管站

    以eSight V300R005C00为例,说明网管侧的配置。

    1. 在主菜单中选择“资源 > 资源添加 > 单个添加”,单击“网络设备”。
    2. 单击“SNMP协议 > 手动编辑SNMP参数”,配置SNMP版本为V3,安全名为nms2-admin,鉴权协议为HMAC_SHA,认证密码为Authe@1234,私有协议为AES_128,加密密码为Priva@1234,端口号为161。

      此处网管侧配置的安全名、鉴权加密参数和端口号必须与设备侧配置用户名、鉴权加密参数和端口号保持一致,且设备侧需要使能网管侧配置的SNMP版本,否则将无法连接设备。

    3. 单击“确定”。
    图1-15 eSight网管SNMP配置界面

  7. 验证配置结果

    配置完成后,交换机和NMS2建立连接,在NMS2上可以对交换机进行管理,同时也可以接收到交换机发送的告警信息。

    执行下面的命令,检查部分配置内容。

    # 查看用户组信息。

    <Switch> display snmp-agent group admin
       Group name: admin
           Security model: USM AuthPriv
           Readview: ViewDefault
           Writeview: allextisis
           Notifyview: <no specified>
           Storage-type: nonVolatile
           Acl: 2001

    # 查看用户信息。

    <Switch> display snmp-agent usm-user
       User name: nms2-admin
           Engine ID: 800007DB0300259E0370C3 active
           Authentication Protocol: sha
           Privacy Protocol: aes128
           Group name: admin
           State: Active

    # 查看告警主机。

    <Switch> display snmp-agent target-host
    Target host NO. 1
    ---------------------------------------------------------------------------
      Host name                        : NMS2
      IP address                       : 10.1.1.2
      Source interface                 : -
      VPN instance                     : -
      Security name                    : nms2-admin
      Port                             : 162
      Type                             : trap
      Version                          : v3
      Level                            : Privacy
      NMS type                         : NMS
      With ext vb                      : No
      Notification filter profile name : -
      Heart beat required              : No
    ---------------------------------------------------------------------------

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100
#
acl number 2001
 rule 5 permit source 10.1.1.2 0
#
interface Vlanif100
 ip address 10.1.2.1 255.255.255.0
#
interface 10GE1/0/1
 port link-type trunk
 port trunk allow-pass vlan 100
#
ospf 1
 area 0.0.0.0
  network 10.1.2.0 0.0.0.255
#
snmp-agent
snmp-agent local-engineid 800007DB03360102101100
#
snmp-agent sys-info version v3
snmp-agent group v3 admin privacy write-view allextisis acl 2001
snmp-agent target-host host-name NMS2 trap address udp-domain 10.1.1.2 params securityname nms2-admin v3 privacy
#
snmp-agent mib-view excluded allextisis isisMIB
snmp-agent usm-user v3 nms2-admin
snmp-agent usm-user v3 nms2-admin group admin
snmp-agent usm-user v3 nms2-admin authentication-mode sha cipher %^%#>rWG1!T'uGx-eiWUd2o$|YX@W/Pnj9(di:TNF84B%^%#
snmp-agent usm-user v3 nms2-admin privacy-mode aes128 cipher %^%#2Qkp*gA$D~TXG^J$1/PG0[=57kq~JPj>hS,znsC*%^%#
#
return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13568

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页