所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C10 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、Packet trace、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置TCP测试示例

配置TCP测试示例

组网需求

图8-13所示。使用NQA TCP测试功能测试SwitchA到SwitchC之间建立TCP连接的时间。

图8-13 TCP测试组网图

配置思路

采用如下思路进行TCP测试的配置:

  1. SwitchA作为NQA客户端,SwitchC作为NQA服务器端。

  2. 在NQA服务器上配置侦听端口号,在NQA客户端配置TCP类型的NQA测试例。

操作步骤

  1. 图8-13配置各接口并配置Switch之间路由可达

    # 配置SwitchA,SwitchB、SwitchC的配置与之类似,详见配置文件。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] quit
    [*SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    [*SwitchA] commit

  2. 在SwitchC上配置NQA服务器

    # 配置NQA服务器TCP连接侦听的IP地址和端口号。

    <SwitchC> system-view
    [~SwitchC] nqa server tcpconnect 10.2.1.2 9000
    [*SwitchC] commit

  3. 配置SwitchA

    # 使能NQA客户端,配置TCP Private类型的测试例。

    [~SwitchA] nqa test-instance admin tcp
    [*SwitchA-nqa-admin-tcp] test-type tcp
    [*SwitchA-nqa-admin-tcp] destination-address ipv4 10.2.1.2
    [*SwitchA-nqa-admin-tcp] destination-port 9000 
    [*SwitchA-nqa-admin-tcp] commit 

  4. 启动测试

    [~SwitchA-nqa-admin-tcp] start now
    [*SwitchA-nqa-admin-tcp] commit

  5. 验证测试结果

    [~SwitchA-nqa-admin-tcp] display nqa results test-instance admin tcp
                                                                                    
    NQA entry(admin, tcp): test flag is active,test type is TCP                      
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3                Receive response times: 3             
       Completion:success                     RTD over thresholds number:0           
       Attempts number:1                      Drop operation number:0               
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT Status errors number:0             
       Destination IP address:10.2.1.2                                             
       Min/Max/Average completion time: 103/133/114                                 
       Sum/Square-Sum  completion time: 343/39747                                   
       Last response packet receiving time: 2012-08-09 00:24:06.1                                  
       Lost packet ratio: 0 %                            

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
     ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin tcp
     test-type tcp
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
     nqa server tcpconnect 10.2.1.2 9000
    #
     ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
翻译
下载文档
更新时间:2020-01-09

文档编号:EDOC1100075464

浏览量:13573

下载量:225

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页