所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S5700修改堆叠ID操作指导

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
S5700修改堆叠ID操作指导

S5700修改堆叠ID操作指导

简介

这篇文章主要介绍堆叠环境中修改堆叠成员交换机ID的操作步骤。适用于所有S系列盒式交换机堆叠系统。

前提条件

修改堆叠ID需要重启设备,会导致业务中断,请在特定时间内进行操作。

初始组网配置

图1-1所示,堆叠系统从上到下原堆叠ID是3、1、2。为了便于管理,需要把堆叠系统的堆叠ID根据位置重新规划。
图1-1 堆叠系统所在网络组网图

查看堆叠系统中堆叠ID对应的设备信息:

<Stack> display stack 
Stack mode: Service-port                                                       
Stack topology type: Ring                                                        
Stack system MAC: 0018-82b1-6eb4                                                 
MAC switch delay time: 10 min                                                     
Stack reserved VLAN: 4093                                                        
Slot of the active management port: 3 
Slot    Role        MAC address       Priority   Device type 
------------------------------------------------------------- 
    3   Master      0018-82b1-6eb4   200          S5720-28X-LI-AC 
    1   Standby     0018-82b1-6eba   150          S5720-28X-LI-AC 
    2   Slave       0018-82b1-6ebb   150          S5720-28X-LI-AC

现需要按照下面规则重新修改堆叠ID。修改完成后,可以通过设备的MAC地址判断修改是否正确。

  • Slot 3 → Slot 1
  • Slot 1 → Slot 2
  • Slot 2 → Slot 3

操作步骤

  1. 把堆叠系统的上行接口和下行接口shutdown,将堆叠系统从组网中隔离。

    <Stack> system-view
    [Stack] interface gigabitethernet 3/0/8 
    [Stack-GigabitEthernet3/0/8] shutdown
    [Stack-GigabitEthernet3/0/8] quit
    [Stack] interface gigabitethernet 1/0/9 
    [Stack-GigabitEthernet1/0/9] shutdown
    [Stack-GigabitEthernet1/0/9] quit
    [Stack] interface gigabitethernet 2/0/5 
    [Stack-GigabitEthernet2/0/5] shutdown
    [Stack-GigabitEthernet2/0/5] quit
    [Stack] interface gigabitethernet 3/0/6 
    [Stack-GigabitEthernet3/0/6] shutdown
    [Stack-GigabitEthernet3/0/6] quit

  2. 修改堆叠ID后,原堆叠ID对应接口的配置会丢失,所以在修改堆叠ID之前,需要先在新接口上进行相同的配置。

    例如:原堆叠ID对应接口的配置如下

    # 
    interface GigabitEthernet3/0/6
     description ToPC 
     port link-type access
     port default vlan 10   
    # 
    interface GigabitEthernet3/0/8
     eth-trunk 10 
    # 
    interface GigabitEthernet1/0/9
     eth-trunk 10 
    # 
    interface GigabitEthernet2/0/5
     description ToIPPhone-01    
     port link-type access   
     port default vlan 20   
     # 

    将接口下的配置修改为新堆叠ID对应接口的配置

    [Stack] interface gigabitethernet 1/0/6  //对应原来的GE3/0/6接口
    [Stack-GigabitEthernet1/0/6] description ToPC
    [Stack-GigabitEthernet1/0/6] port link-type access
    [Stack-GigabitEthernet1/0/6] port default vlan 10
    [Stack-GigabitEthernet1/0/6] quit
    [Stack] interface gigabitethernet 1/0/8  //对应原来的GE3/0/8接口
    [Stack-GigabitEthernet1/0/8] eth-trunk 10
    [Stack-GigabitEthernet1/0/8] quit
    [Stack] interface gigabitethernet 2/0/9  //对应原来的GE1/0/9接口
    [Stack-GigabitEthernet2/0/9] eth-trunk 10
    [Stack-GigabitEthernet2/0/9] quit
    [Stack] interface gigabitethernet 3/0/5  //对应原来的GE2/0/5接口
    [Stack-GigabitEthernet3/0/5] description ToIPPhone-01
    [Stack-GigabitEthernet3/0/5] port link-type access
    [Stack-GigabitEthernet3/0/5] port default vlan 20
    [Stack-GigabitEthernet3/0/5] quit

  3. 修改堆叠ID,保存配置,重启设备。

    [Stack] stack slot 3 renumber 1
    Info: The assigned slot ID already exists in the stack system.  
    Warning: All the configurations related to the slot ID will be lost after the slot ID is modified.              
    Do not frequently modify the slot ID because it will make the stack split. Continue? [Y/N]: y
    Info: Stack configuration has been changed, and the device needs to restart to make the configuration effective. 
    [Stack] stack slot 1 renumber 2
    Info: The assigned slot ID already exists in the stack system.  
    Warning: All the configurations related to the slot ID will be lost after the slot ID is modified.
    Do not frequently modify the slot ID because it will make the stack split. Continue? [Y/N]:y
    Info: Stack configuration has been changed, and the device needs to restart to make the configuration effective. 
    [Stack] stack slot 2 renumber 3
    Info: The assigned slot ID already exists in the stack system.  
    Warning: All the configurations related to the slot ID will be lost after the slot ID is modified. 
    Do not frequently modify the slot ID because it will make the stack split. Continue? [Y/N]:y
    Info: Stack configuration has been changed, and the device needs to restart to make the configuration effective. 
    [Stack] quit
    <Stack> save
    The current configuration will be written to flash:/vrpcfg.zip.                     
    Are you sure to continue?[Y/N]y
    Now saving the current configuration to the slot 3.........  
    Save the configuration successfully. 
    Now saving the current configuration to the slot 1.                                               
    Save the configuration successfully.       
    Now saving the current configuration to the slot 2.                         
    Save the configuration successfully.                  
    <Stack> reboot
    Info: The system is now comparing the configuration, please wait...................             
    Info: If want to reboot with saving diagnostic information, input 'N' and then execute 'reboot save diagnostic-information'.
    System will reboot! Continue?[Y/N]:y

  4. 重启完成后,查看堆叠系统状态和堆叠ID,以及接口下的配置是否正确。如果接口下的配置不正确,此时可以再重新配置。

    <Stack> display stack
    Stack mode: Service-port                                                       
    Stack topology type: Ring                                                        
    Stack system MAC: 0018-82b1-6eb4                                                 
    MAC switch delay time: 10 min                                                     
    Stack reserved VLAN: 4093                                                        
    Slot of the active management port: 1 
    Slot    Role        MAC address       Priority   Device type 
    ------------------------------------------------------------- 
        1   Master      0018-82b1-6eb4    200        S5720-28X-LI-AC 
        2   Standby     0018-82b1-6eba    150        S5720-28X-LI-AC 
        3   Slave       0018-82b1-6ebb    150        S5720-28X-LI-AC

  5. 配置正确,放开堆叠系统的上行和下行接口。

    <Stack> system-view
    [Stack] interface gigabitethernet 1/0/8 
    [Stack-GigabitEthernet1/0/8] undo shutdown
    [Stack-GigabitEthernet1/0/8] quit
    [Stack] interface gigabitethernet 2/0/9 
    [Stack-GigabitEthernet2/0/9] undo shutdown
    [Stack-GigabitEthernet2/0/9] quit
    [Stack] interface gigabitethernet 3/0/5 
    [Stack-GigabitEthernet3/0/5] undo shutdown
    [Stack-GigabitEthernet3/0/5] quit
    [Stack] interface gigabitethernet 1/0/6 
    [Stack-GigabitEthernet1/0/6] undo shutdown
    [Stack-GigabitEthernet1/0/6] quit

翻译
下载文档
更新时间:2019-06-29

文档编号:EDOC1100088154

浏览量:1230

下载量:181

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页