增加服务器失败
现象描述
通过维护工具增加eSight服务器(该服务器为Windows操作系统)时,增加失败,界面提示“连接失败,请检查IP、端口和用户密码是否正确”。详细操作步骤请参见《eSight 维护指南》。
可能原因
- 通过维护工具增加eSight服务器时,需要保证待增加的服务器上“OpenSSH Server”服务正常运行。登录待增加的服务器,发现其“OpenSSH Server”服务未运行。
- eSight中集成了“OpenSSH Server”服务,该服务通过“ossuser”用户来启动。
使用Administrator用户在命令行窗口中执行如下命令检查“ossuser”用户的状态。
net user ossuser
发现其密码已到期。
“ossuser”用户密码到期导致“OpenSSH Server”服务启动失败,从而导致增加服务器失败。
处理步骤
- 以Administrator用户登录待增加的服务器。
- 重新设置“ossuser”用户的密码,修改方法请参见《eSight 维护指南》的“修改Windows操作系统用户密码”。
- 修改“OpenSSH Server”服务的登录密码。
- 右键单击“计算机”,选择“管理”。
- 在“本地服务器”窗口中,单击右上角“任务”下拉框,选择“计算机管理”。
- 在“计算机管理”中单击左侧的“服务和应用程序”。
- 双击右侧的“服务”。
- 在右侧服务列表中找到名称为“OpenSSH Server”的服务,右键单击,选择“属性”。
- 在弹出的对话框中选择“登录”页签。
- 设置“密码”和“确认密码”,与步骤2中所设置的密码保持一致。
- 单击“确定”。
- 重新启动“OpenSSH Server”服务。
在右侧服务列表中找到名称为“OpenSSH Server”的服务,右键单击,选择“启动”。