登录eSight时,提示安全证书错误
现象描述
登录eSight时,Web浏览器提示安全证书错误。
- IE浏览器提示安全证书错误。
- Firefox浏览器提示安全证书错误。
- Chrome浏览器提示安全证书错误。
可能原因
安全证书错误或者没有安装eSight安全证书,需要安装合法的安全证书。
处理步骤
- 方法一:部署CA机构颁发的证书到eSight。
- 请联系eSight服务器管理员从CA(Certificate Authority)机构申请证书。
- 部署CA机构颁发的证书到eSight中,具体操作请参见《eSight 产品文档》中“维护指南 > 安全维护 > 安全证书 > 部署安全证书 > 使用证书工具导入CA证书”章节。
- 通过域名访问eSight,只能使用此方法(重新申请对应域名的证书并部署证书)才能解决浏览器提示安全证书错误的问题。
- 如果您使用的是 Google Chrome 浏览器,版本号高于58,且使用IP地址(而不是域名)访问eSight,则申请的数字证书中必须包含“使用者备用名称”,且其中的IP地址是访问 eSight 所使用的IP地址。
- 方法二:将eSight自带CA证书设置为浏览器信任证书。
- 在 Microsoft Windows 上,Internet Explorer、Microsoft Edge、Google Chrome 等浏览器使用操作系统管理的证书,您只需要将 eSight 自带的CA证书导入系统的“受信任的根证书颁发机构”中;
- Mozilla Firefox 目前使用自己的证书管理器,您需要将 eSight 自带的CA证书导入浏览器的证书管理器中;
- 如果您使用的是 Google Chrome 浏览器,版本号高于 58,eSight 版本号低于 V300R010C00SPC612,则此方法无效;如果您刚刚将 eSight 升级到 V300R010C00SPC612 或更高的版本,建议您重新生成自签名证书,然后执行下列步骤。
- 在操作系统中安装安全证书
- 将eSight服务器上的“eSight安装路径/AppBase/etc/certificate/application/ca/ca.crt”复制到本地。
- 双击 ca.crt 文件,进入“证书”窗口;单击“安装证书”。
- 在弹出的“证书导入向导”窗口中,选择“当前用户”,单击“下一步”。
- 在“证书存储”页面,选中“将所有的证书都放入下列存储”,然后单击“证书存储: ”右侧的“浏览”按钮。
- 在“选择证书存储”对话框中,单击“受信任的根证书颁发机构”,单击“确定”。
- 回到“证书存储”页面,单击“完成”。
- 在弹出的“安全警告”窗口,单击“是”,然后在“导入成功”窗口,单击“确定”。
- 在“证书”窗口中,单击“确定”,关闭此窗口。
- 关闭IE浏览器,然后重新打开IE浏览器,登录eSight。
- 在Mozilla Firefox中安装安全证书
- 将eSight服务器上的“eSight安装路径/AppBase/etc/certificate/application/ca/ca.crt”复制到本地。
- 在浏览器右上方,单击右上角的“打开菜单”按钮,单击“选项” 。
- 单击左侧的“隐私与安全”,滑动页面到底部的“证书”部分。
- 单击“查看证书”,进入“证书管理器”。
- 在“证书管理器”窗口,选择“证书颁发机构”页签。
- 单击“导入”,选择需要导入的证书(ca.crt),单击“打开”。
- 在“下载证书”窗口,勾选“信任使用此CA标识的网站。”,单击“确定”。
- 回到“证书管理器”窗口,单击“确定”。
- 关闭Firefox浏览器,然后重新打开Firefox浏览器,登录eSight。
建议与总结
建议选择方法一部署CA机构颁发的证书到eSight。而方法二可能因为浏览器版本差异会导致部分场景下不生效。
- 如果已经开启了多子网访问eSight,用eSight安装IP地址访问网管才不会报“证书错误”。
- 如果eSight部署的是异地高可用性系统,用主服务器eSight安装IP地址访问网管才不会报“证书错误”。