未安装多路径软件(UltraPath)的情况下,控制器B故障导致业务中断
在未安装多路径软件的情况下,控制器B故障导致存储系统业务中断。此时可以手动将与控制器B连接的应用服务器连接到控制器A上,以确保应用服务器上业务正常运行。
现象描述
- 控制器B的指示灯全部熄灭;控制器A的指示灯显示无异常。
- 与控制器B连接的应用服务器读写请求无法下发给存储设备,导致业务中断。登录DeviceManager,在“性能监控”页面中,控制器B上的主机端口写I/O流量或读I/O流量变为0。
可能原因
控制器故障。
影响范围及程度
未安装多路径的情况下,控制器故障导致主机业务中断,可以通过手动切换到正常控制器的方式恢复主机业务。
定位思路
处理步骤
- 将控制器B的业务切换到控制器A上。
- 移除控制器B与应用服务器之间的连接线缆。
- 将与控制器B连接的应用服务器连接到控制器A上。
- 重新配置业务中断的主机的启动器。
- 对控制器B下电并重新启动。
观察控制器B的指示灯是否呈绿色常亮状态。
- 是 => 3。
- 否 => 保持故障环境并联系技术支持工程师。
- 将原来属于控制器B的业务重新从控制器A切换至控制器B。
- 观察业务读写情况。
在DeviceManager上查看业务读写情况前,请先开启性能监控功能。
- 登录DeviceManager,选择“监控 > 性能监控 > 分析”。
- 单击“创建”。
系统弹出“创建图表”页面。
- 设置图表名称。
- 在“对象类型”中选择“LUN”和“自定义”,并在“对象实例”选择通过控制器B向服务器提供服务的LUN。
- 在“统计指标”中选择“总IOPS(IO/s)”。
- 单击“确定”。
观察I/O的性能监控数据,性能曲线的变化是否较为平滑。
- 是 => 业务读写正常,处理完毕。
- 否 => 保持故障环境并联系技术支持工程师。
建议与总结
为最终解决该故障,建议:
- 在应用服务器上安装多路径(UltraPath)软件。
- 更换故障的控制器。
- 对存储设备进行升级。
- 将收集到的日志信息反馈至技术支持工程师进行下一步处理。