应用服务器无法扫描到LUN
应用服务器无法扫描到LUN,将导致应用服务器无法使用存储系统提供的资源。
现象描述
当用户为应用服务器映射了LUN后,在应用服务器侧无法发现映射的LUN。
告警信息
无。
可能原因
出现应用服务器无法扫描到LUN的故障,常见的原因包括:
- 存储池故障。
- 链路通信异常。
- 设备节点文件丢失(适用于UNIX或Linux)。
- 应用服务器动态检测机制影响扫描LUN(适用于Mac OS X)。
- 应用服务器没有“主机LUN ID”为0的LUN映射(适用于HP-UX)。
- 应用服务器自动停止扫描LUN操作(适用于Solaris 9)。
影响范围及程度
应用服务器无法扫描到LUN,将导致应用服务器无法使用存储系统提供的资源。
定位思路
处理步骤
- 原因1:存储池故障。
- 请检查存储系统中是否存在“存储池故障”的告警。
- 是 => 2。
- 否 => •原因2:链路通信异常。。
- 根据“存储池故障”告警处理存储池故障。
- 在应用服务器上重新扫描LUN,查看故障是否解决。
- 是 => 处理完毕。
- 否 => •原因2:链路通信异常。。
- 请检查存储系统中是否存在“存储池故障”的告警。
- 原因2:链路通信异常。
- 在DeviceManager界面导航栏单击“系统 > 硬件 > 设备”。查看与应用服务器连接的FC或iSCSI主机端口的“运行状态”是否显示为“未连接”。
- 是 => 2。
- 否 => •原因3:设备节点文件丢失(适用于UNIX或Li...。
- 确认是iSCSI组网还是FC组网。
- 根据FC链路异常处理FC组网的链路问题,处理完成后转至f。
- 根据iSCSI链路异常处理iSCSI组网的链路问题,处理完成后转至f。
- 在应用服务器上重新扫描LUN,查看故障是否解决。
- 是 => 处理完毕。
- 否 => •原因3:设备节点文件丢失(适用于UNIX或Li...。
- 在DeviceManager界面导航栏单击“系统 > 硬件 > 设备”。查看与应用服务器连接的FC或iSCSI主机端口的“运行状态”是否显示为“未连接”。
- 原因3:设备节点文件丢失(适用于UNIX或Linux)。
- 确认应用服务器的操作系统是否为Linux或UNIX。
- 是 => 2。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 在应用服务器侧查看“dev”目录下,是否有对应的设备节点文件,例如“dev/sdb”。
- 是 => •原因4:应用服务器动态检测机制影响扫描LUN(...。
- 否 => 3。
- 在应用服务器的“Terminal”中执行命令mknod,创建设备节点。
命令mknod一般使用的格式为:mknod Name {b | c} Major Minor,其中Name代表设备名称,b | c代表块设备或者字符设备,Major代表主设备号,Minor代表次设备号。
- 在应用服务器上重新扫描LUN,查看故障是否解决。
- 是 => 处理完毕。
- 否 => •原因4:应用服务器动态检测机制影响扫描LUN(...。
- 确认应用服务器的操作系统是否为Linux或UNIX。
- 原因4:应用服务器动态检测机制影响扫描LUN(适用于Mac OS X)。
- 确认应用服务器的操作系统是否为Mac OS X。
- 是 => 2。
- 否 => •原因5:应用服务器没有“主机LUN ID”为0...。
- 请重新启动Mac OS X应用服务器。
当Mac OS X应用服务器没有LUN映射时,Mac OS X应用服务器本身的动态检测机制可能无法生效,所以需要重新启动应用服务器来触发该动态机制。
- 在应用服务器上重新扫描LUN,查看故障是否解决。
- 是 => 处理完毕。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 确认应用服务器的操作系统是否为Mac OS X。
- 原因5:应用服务器没有“主机LUN ID”为0的LUN映射(适用于HP-UX)。
- 确认应用服务器的操作系统是否为HP-UX。
- 是 => 2。
- 否 => •原因6:应用服务器自动停止扫描LUN操作(适用...。
- 在DeviceManager上查看HP-UX应用服务器的LUN映射,是否存在“主机LUN ID”为0的LUN映射。
- 是 => 保持故障环境并联系技术支持工程师进行处理。
- 否 => 3。
- 为HP-UX应用服务器添加“主机LUN ID”为0的LUN映射。
- 在应用服务器上重新扫描LUN,查看故障是否解决。
- 是 => 处理完毕。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 确认应用服务器的操作系统是否为HP-UX。
- 原因6:应用服务器自动停止扫描LUN操作(适用于Solaris 9)。
- 确认应用服务器的操作系统是否为Solaris 9。
- 是 => 2。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 确认Solaris 9应用服务器是否安装了“SAN Foundation Software”。
- 是 => 3。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 运行cfgadm al命令查询端口的WWPN(World Wide Port Name)号。
- 运行cfgadm al -o show_FCP_dev c2::WWPN命令重新启动端口扫描LUN操作。其中show_FCP_dev表示显示LUN信息,c2表示3中查询到的端口号,WWPN表示3中查询到的WWPN号。
查看故障是否解决。
- 是 => 处理完毕。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 确认应用服务器的操作系统是否为Solaris 9。
建议与总结
无。