通过串口无法激活登录
通过串口无法激活登录,将导致用户无法通过串口访问存储系统。
现象描述
维护终端通过串口线缆与设备的串口连接后,维护终端接收不到设备串口输出的信息或串口输出乱码且未出现登录提示信息。
告警信息
无。
可能原因
出现通过串口无法激活登录的故障,常见的原因包括:
- 串口连接的端口被占用。
- 串口线缆连接异常。
- 串口连接参数设置错误。
- 远程桌面时,串口被禁用。
定位思路
处理步骤
- 原因1:串口连接的端口被占用。
- 使用串口工具连接后,检查是否有回显显示端口不能打开。
- 是 => •原因2:串口线缆连接异常。。
- 否 => 2。
- 关闭占用端口的程序或进程。
- 在维护终端上重新通过串口执行登录操作,查看维护终端是否可接收到设备串口输出的信息。
- 是 => 处理完毕。
- 否 => •原因2:串口线缆连接异常。。
- 使用串口工具连接后,检查是否有回显显示端口不能打开。
- 原因2:串口线缆连接异常。
- 确认串口是否有输出,按“Enter”,确认是否有回显信息。
- 是 => •原因3:串口连接参数设置错误。。
- 否 => 2。
- 重新拔插或更换串口线缆。
- 在维护终端上重新通过串口执行登录操作,查看维护终端是否可接收到设备串口输出的信息。
- 是 => 处理完毕。
- 否 => •原因3:串口连接参数设置错误。。
- 确认串口是否有输出,按“Enter”,确认是否有回显信息。
- 原因3:串口连接参数设置错误。
- 关闭维护终端上已经打开的串口管理程序。
- 重新在维护终端上打开串口管理程序,依次检查波特率、数据位、奇偶校验、停止位等属性的设置信息。
串口管理程序的正确设置如下。
- 波特率:115200
- 数据位:8
- 奇偶校验:无
- 停止位:1
- 在维护终端上重新通过串口执行登录操作,查看维护终端是否可接收到设备串口输出的信息。
- 是 => 处理完毕。
- 否 => 4。
- 确认是否通过远程桌面方式登录应用服务器。
- 是 => •原因4:远程桌面时,串口被禁用。。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 原因4:远程桌面时,串口被禁用。
- 在维护终端上查看建立远程连接时是否禁用了串口。
可以在“计算机管理 > 设备管理器 > 端口”下查看是否禁用了串口。
被禁用串口的显示状态为
。
- 是 => 2。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 关闭远程桌面,然后重新登录远程桌面。登录时,请开启串口。
- 重新通过串口执行登录操作,查看维护终端是否可接收到设备串口输出的信息。
- 是 => 处理完毕。
- 否 => 保持故障环境并联系技术支持工程师进行处理。
- 在维护终端上查看建立远程连接时是否禁用了串口。
建议与总结
无。