业务面Web界面无法登录
控制器界面无法打开
故障现象
iMaster NCE-Campus控制器界面无法打开,控制器管理IP网络正常。
可能原因
排查流程
故障定位
定位思路:
- 登录iMaster NCE-Campus管理面执行健康检查,根据检查结果再判断是否执行后续排障步骤。
- 确认iMaster NCE-Campus控制器各服务进程是否正常。
- 确认iMaster NCE-Campus控制器数据库服务是否正常。
- 检查集群节点的硬盘占用率是否过高。
- 确认iMaster NCE-Campus控制器服务器硬件状态是否正常。
定位方法:
- 登录iMaster NCE-Campus管理面执行健康检查。
- 在iMaster NCE-Campus管理面确认BusService、ERService、SSOWebSite、AuthService等各服务进程是否正常。
- 确定对应服务运行的节点,检查服务是否正常。
- 在管理面选择 ,进入系统监控界面。
- 在“进程”页签中输入进程名进行搜索,其中“节点名称”即为服务运行的节点。
BusService、ERService、SSOWebSite、AuthService服务的进程名分别为:ir、er、ssowebsite、authservice。
因er搜索结果较多,ERService服务进程建议通过关键字“er-”进行搜索。
- 确定对应服务运行的节点,检查服务是否正常。
- 以sopuser登录对应节点,执行su - root切换到root用户,例如执行如下命令查看AuthService进程是否在。重启该AuthService服务命令如下:
# su ossadm -c "/opt/oss/manager/agent/bin/ipmc_adm -cmd restartapp -app AuthService"
- 以sopuser登录对应节点,执行su - root切换到root用户,例如执行如下命令查看AuthService进程是否在。
- 确定对应服务运行的节点,检查服务是否正常。
- 确认数据库服务是否正常。
参考《故障处理》排查解决数据库故障。
- 查看节点硬盘使用率。
以sopuser登录各节点,执行su - root切换到root用户。执行如下命令查看当前节点的硬盘使用率。
# df -h
显示结果如下图,能够展示当前硬盘使用率。
如果硬盘使用率超过用户设置的硬盘阈值,则请参见应急恢复中的4进行处理。否则继续执行下一步,检查硬件是否故障。
- 检查服务器上的告警指示灯是否亮起。
如果是,则定界为服务器硬件故障。请参见2进行应急恢复。
应急恢复
- 如果定界为BusService、ERService、SSOWebSite、AuthService等服务异常,可以通过重启对应服务进行应急恢复。
- 在iMaster NCE-Campus管理面确认各个服务部署的节点。
- 查看各个服务是否启动正常,如下图所示,则说明AuthService服务进程正常,否则请联系华为技术工程师。
- 如果服务器硬件故障,请联系服务器厂家进行处理。
更换硬件完成后,可重新安装故障节点进行应急恢复。
- 如果定界为数据库服务有问题,请参考《故障处理》进行数据库服务应急恢复。
如果恢复数据库后,数据库服务依然异常,请联系华为技术工程师。
- 如果定界为节点的硬盘使用率过高,可通过删除硬盘中的无效数据进行应急恢复。
请仔细确认数据是否可删除,避免误操作造成数据丢失或致使集群失效。
在节点下执行命令df -h,检查Use%列值较高的分区是否为控制器分区(“/dev/mapper/”这个目录都是控制器分区)。此处以/dev/mapper的Use%值最高为例。- 如果是控制器安装镜像所在目录或其子目录,则执行命令cd /dev/mapper进入该目录后再执行命令ll,收集文件列表并联系技术支持人员处理。
- 如果不是控制器安装镜像所在目录或其子目录,则请用户自行确认该目录下数据并删除清理。
- 如果上述操作均无法解除故障,请联系华为技术工程师。
控制器界面打开后无法登录
故障现象
iMaster NCE-Campus控制器界面打开后,登录超时。
可能原因
定位思路
故障定位
定位思路:
- 确认iMaster NCE-Campus节点服务正常。
- 参考《故障处理》中数据库故障章节,确认数据库集群服务是否异常。
- 确认iMaster NCE-Campus的BusService、ERService、SSOWebSite、AuthService等各服务是否异常。
输入IP地址后无法跳转到登录页面
故障现象
- 输入iMaster NCE-Campus的地址后页面无法跳转到登录页面。
- 在正常操作页面时单击刷新,页面无法正常刷新或者打开。
可能原因
- 原因一:浏览器版本不符合要求。
- 原因二:客户网络异常。
- 原因三:服务器硬件故障。
- 原因四:iMaster NCE-Campus进程异常。
处理建议
- 检查是否是原因一:浏览器版本不符合要求,引起的故障。
- 支持的浏览器FireFox ESR52及以上版本和Chrome 57及以上版本,查看浏览器版本是否符合要求。
- 如果符合,说明故障不是由浏览器版本不符合要求引起的,请检查其他原因。
- 如果不符合,请将浏览器更新为iMaster NCE-Campus支持的版本。
重新登录iMaster NCE-Campus,判断故障是否解决。如果已经解决,结束故障处理;如果没有解决,请继续如下步骤。
- 检查是否是原因二:客户网络异常,引起的故障。
- 在本地ping iMaster NCE-Campus界面地址以及网关,例如iMaster NCE-Campus的界面地址为192.168.19.15,网关为192.168.19.1,查看是否能ping通。
- 如果能ping通,说明故障不是由客户网络异常引起的,请检查其他原因。
- 如果不能ping通,说明网络异常。
- 检查网络异常是否是本地PC机网线松动、IP地址配置冲突等本地故障引起的。若是,请排除故障。
重新登录iMaster NCE-Campus,判断故障是否解决。如果已经解决,结束故障处理;如果没有解决,请继续如下步骤。
- 检查PC和iMaster NCE-Campus之间是否部署防火墙。若是,请登录防火墙,查看是否对接入iMaster NCE-Campus的源地址有配置限制、是否对iMaster NCE-Campus界面端口(31943)禁止访问。若是,请解除限制。
重新登录iMaster NCE-Campus,判断故障是否解决。如果已经解决,结束故障处理;如果没有解决,请继续如下步骤。
- 检查网络异常是否是本地PC机网线松动、IP地址配置冲突等本地故障引起的。若是,请排除故障。
- 检查是否是原因三:服务器硬件故障,引起的故障。
- 获得iMaster NCE-Campus的服务部署节点信息。
- 如果用户已知iMaster NCE-Campus的部署配置信息,请转3。
- 若使用SSH方式登录iMaster NCE-Campus后台成功,请转3。
- 若使用SSH方式登录iMaster NCE-Campus后台失败,请尝试登录FC的VRM管理页面,使用VNC登录。
- 如果使用VNC登录iMaster NCE-Campus后台成功,请转3。
- 如果使用VNC登录iMaster NCE-Campus后台仍然失败,请执行如下步骤。
- 在机房检查物理机网卡、硬盘等是否有告警(亮红灯或者绿灯熄灭),或者通过FC的VRM页面查看有无硬件告警。如果存在告警,可能是告警导致登录问题。
请先解决告警问题,若成功,请转3。若失败,请继续如下步骤。
- 如果没有告警但是iMaster NCE-Campus后台登录不上,可能虚拟机已停止响应导致无法正常登录,请通过FC VRM管理页面强制重启虚拟机。
- 如果非安全规格的硬盘,物理网卡全部故障,或者安全规格的服务器整机故障导致其上的虚拟机已完全故障,需要使用新的服务器,重新安装CNA物理节点,把CNA物理节点添加到VRM主机列表当中,创建新的虚拟机。
- 在机房检查物理机网卡、硬盘等是否有告警(亮红灯或者绿灯熄灭),或者通过FC的VRM页面查看有无硬件告警。如果存在告警,可能是告警导致登录问题。
- 如果用户已知iMaster NCE-Campus的部署配置信息,请转3。
- 获取到iMaster NCE-Campus的BusService、ERService部署节点信息之后请继续如下步骤。
- 检查BusService、ERService服务状态。
- 获得iMaster NCE-Campus的服务部署节点信息。
- 检查是否是原因四:iMaster NCE-Campus的AuthService、SSOWebSite进程异常,引起的故障。
参考控制器界面无法打开的步骤2修复。
判断故障是否解决,如果解决,请结束故障处理;如果没有解决,请联系售后服务工程师。