所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
案例库

在FusionInsight HD安装中关于双机Manager的权限设置问题

发布时间:  2017-10-25  |   浏览次数:  137  |   下载次数:  0  |   作者:  c00417652  |   文档编号: EKB1000971820

目录

问题描述

进行Precheck时,出现了‘Defaults requiretty’ is configured incorrectly in ‘/etc/sudoers’ the files.错误,“/etc/sudoers”文件中“Defaults requiretty”配置错误,修改了该文件的权限。将文件权限修改为777可修改,并未修改回来

因此安装双机Manager过程中该文件仍处于可写状态,进而双机Manager安装失败

告警信息

1.Defaults requiretty’ is configured incorrectly in ‘/etc/sudoers’ the files.

 

2.

处理过程

更改“/etc/sudoers”文件的权限,将其从“777”改为默认的“440”,重新安装双机Manager即可。



根因

在安装大数据平台时,linux对于文件权限较为敏感

解决方案

更改“/etc/sudoers”文件的权限,将其从“777”改为默认的“440”,重新安装双机Manager即可。