所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
案例库

AC6005 配置三层旁挂组网(ac和ap不在同一网段)

发布时间:  2018-09-28  |   浏览次数:  6766  |   下载次数:  98  |   作者:  yWX481366  |   文档编号: EKB1001885613

目录

问题描述

需求:核心交换机做dhcp服务器,为ap和无线终端进行地址分配,其中ap获取的地址和ac的源地址不在同一网段,数据规划和拓扑如下


处理过程

1、核心交换机配置

[Huawei]vlan batch 100 101 102 200   //创建相应的vlan

[Huawei]dhcp enable              //开启dhcp服务

[Huawei]interface Vlanif 100

[Huawei-Vlanif100]ip address 192.168.100.2 24    //配置vlanif 100,用来和ac进行对接,使得核心能和ac进行通信

[Huawei]interface Vlanif 101

[Huawei-Vlanif101]ip address 192.168.101.1 24    //创建无线终端的网关

[Huawei-Vlanif101]dhcp select interface         //开启dhcp,给无线终端分发ip地址

[Huawei-Vlanif101]q

[Huawei]interface Vlanif 102

[Huawei-Vlanif102]ip address 192.168.102.2 24       //用来和路由器进行对接

[Huawei-Vlanif102]q

[Huawei]interface Vlanif 200

[Huawei-Vlanif200]ip address 192.168.200.1 24      //配置ap的网关

[Huawei-Vlanif200]dhcp select interface       //给ap分发ip地址

[Huawei-Vlanif200]dhcp server option 43 sub-option 2 ip-address 192.168.100.1    //因为ap和ac在不同的网段,要是ap能够和ac建立capwap隧道,必须把ac的源地址告诉给客户ap,此包含在dhcp中,                                                            为本案例的核心关键点

[Huawei-Vlanif200]q

[Huawei]interface GigabitEthernet 0/0/1                              

[Huawei-GigabitEthernet0/0/1]port link-type access               //配置g0/0/1口和路由器进行对接,划分到vlan 102中

[Huawei-GigabitEthernet0/0/1]port default vlan 102

[Huawei-GigabitEthernet0/0/1]q

[Huawei]interface GigabitEthernet 0/0/2                          //g0/0/2和g0/0/3分别于ac和poe交换机对接,采用trunk模式,放通所有vlan即可

[Huawei-GigabitEthernet0/0/2]port link-type trunk

[Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan all

[Huawei]interface GigabitEthernet 0/0/3

[Huawei-GigabitEthernet0/0/3]port link-type trunk

[Huawei-GigabitEthernet0/0/3]port trunk allow-pass vlan all 

[Huawei-GigabitEthernet0/0/3]q

[Huawei]ip route-static 0.0.0.0 0 192.168.102.1                  //配置默认路由指向路由器,使得能够上网



2、poe交换机配置

<Huawei>sy

[Huawei]sy poe

[poe]vlan batch 101 200                    //创建业务和ap的vlan号

[poe]interface GigabitEthernet 0/0/1

[poe-GigabitEthernet0/0/1]port link-type trunk         //与核心交换机相连的用trunk口放通所有vlan即可

[poe-GigabitEthernet0/0/1]port trunk allow-pass vlan all 

[poe-GigabitEthernet0/0/1]q

[poe]interface GigabitEthernet 0/0/2

[poe-GigabitEthernet0/0/2]port link-type  trunk 

[poe-GigabitEthernet0/0/2]port trunk pvid vlan 200      //与ap相连的口用trunk口,放通业务和ap的vlan,但是必须打上ap vlan的pvid,使得ap能够获取ip地址

[poe-GigabitEthernet0/0/2]port trunk allow-pass vlan all 

[poe-GigabitEthernet0/0/2]q



<AC6605>sy

Enter system view, return user view with Ctrl+Z.

[AC6605]vlan batch 100 101                   //创建业务和管理vlan

Info: This operation may take a few seconds. Please wait for a moment...done.

[AC6605]interface vlanif 100

[AC6605-Vlanif100]ip address 192.168.100.1 24           //配置管理vlan的ip地址

[AC6605-Vlanif100]q

[AC6605]interface g 0/0/1

[AC6605-GigabitEthernet0/0/1]port link-type trunk

[AC6605-GigabitEthernet0/0/1]port trunk allow-pass vlan all     //和交换机相连的口配置为trunk放通所有vlan即可

[AC6605-GigabitEthernet0/0/1]q

[AC6605]capwap source interface vlanif 100              //将vlanif 100设置为ac的源地址,作为ap的管理vlan

[AC6605]wlan

[AC6605-wlan-view]ap auth-mode no-auth

Warning: It is insecure to configure none authentication mode.

[AC6605-wlan-view]q

[AC6605]ip route-static 0.0.0.0 0 192.168.100.2         //配置默认路由指向交换机,使得ac能和ap通信

执行完成后ap上线成功

<AC6605>display ap all
Info: This operation may take a few seconds. Please wait for a moment.done.
Total AP information:
nor  : normal          [1]
--------------------------------------------------------------------------------
---------------------------
ID   MAC            Name           Group   IP              Type            State
 STA Uptime
--------------------------------------------------------------------------------
---------------------------
0    00e0-fc6d-42c0 00e0-fc6d-42c0 default 192.168.200.254 AP4030TN        nor  
 0   14H:13M:51S
--------------------------------------------------------------------------------
---------------------------

建议与总结

此案例的关键点在于dhcp option 43字段的配置,这个字段的作用是指定ac的源地址,将此告诉ap,使得ap知道ac的位置,才能在ac上上线