No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S1720, S2700, S5700, and S6720 V200R011C10

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a BGP Routing Policy

Example for Configuring a BGP Routing Policy

Networking Requirements

Figure 10-54 shows the simplified MPLS network that carries multiple types of L3VPN services, such as multimedia, signaling, and accounting. In Figure 10-54, two sites, each of which has two PEs accessing the core layer, are taken as an example. The core layer is divided into two planes. All the P nodes on the same plane are full-meshed P nodes. Nodes on different planes are connected to provide backup paths across plane. MP-BGP is used to advertise inner labels and VPNv4 routes between the PEs. All PEs set up MP-IBGP peer relationships with the RR.

NOTE:

In this scenario, ensure that all connected interfaces have STP disabled. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 10-54  Networking diagram

NOTE:
Figure 10-54 is a simplified networking diagram, in which two sites are taken as an example and each plane takes three P nodes and one RR as an example. In the actual network, there are 14 sites with 28 PEs and each plane has four P nodes and two RR nodes, and each RR needs to set up MP-IBGP connections with 28 PEs.

In Figure 10-54, each PE sends BGP Update messages to the RR, other PEs receive BGP Update messages from different planes. Therefore, routing policies need to be deployed to ensure that one VPN flow is transmitted only through one plane.

Data Plan

Table 10-33  IP addresses of interconnected interfaces

Link Name

(Local End-Remote End)

Local Interface and IP Address

Remote Interface and IP Address

P1–P3

GE1/0/0

VLANIF10:10.1.1.1/30

GE1/0/0

VLANIF10:10.1.1.2/30

P1–P5

GE2/0/0

VLANIF20:10.1.2.1/30

GE1/0/0

VLANIF20:10.1.2.2/30

P1–RR

GE3/0/0

VLANIF30:10.1.3.1/30

GE1/0/0

VLANIF30:10.1.3.2/30

P1–P2

GE4/0/0

VLANIF40:10.1.4.1/30

GE1/0/0

VLANIF40:10.1.4.2/30

P1–PE1

GE5/0/0

VLANIF50:10.1.5.1/30

GE1/0/0

VLANIF50:10.1.5.2/30

P2–P6

GE4/0/0

VLANIF80:10.1.6.1/30

GE1/0/0

VLANIF80:10.1.6.2/30

P2–P4

GE3/0/0

VLANIF70:10.1.7.1/30

GE1/0/0

VLANIF70:10.1.7.2/30

P2–RR

GE2/0/0

VLANIF60:10.1.8.1/30

GE2/0/0

VLANIF60:10.1.8.2/30

P2–PE2

GE5/0/0

VLANIF90:10.1.9.1/30

GE1/0/0

VLANIF90:10.1.9.2/30

P3–P5

GE2/0/0

VLANIF110:10.1.10.1/30

GE2/0/0

VLANIF110:10.1.10.2/30

P3–P4

GE3/0/0

VLANIF120:10.1.11.1/30

GE2/0/0

VLANIF120:10.1.11.2/30

P3–PE3

GE4/0/0

VLANIF130:10.1.12.1/30

GE1/0/0

VLANIF130:10.1.12.2/30

P4–P6

GE3/0/0

VLANIF150:10.1.13.1/30

GE3/0/0

VLANIF150:10.1.13.2/30

P4–PE4

GE4/0/0

VLANIF160:10.1.14.1/30

GE1/0/0

VLANIF160:10.1.14.2/30

P5–P6

GE3/0/0

VLANIF170:10.1.15.1/30

GE2/0/0

VLANIF170:10.1.15.2/30

PE1–PE2

GE2/0/0

VLANIF100:10.1.16.1/30

GE2/0/0

VLANIF100:10.1.16.2/30

PE3–PE4

GE2/0/0

VLANIF140:10.1.17.1/30

GE2/0/0

VLANIF140:10.1.17.2/30

Table 10-34  IP addresses of loopback interfaces

Local Device

IP Address of the local Loopback 0 Interface

Remote Device

IP Address of the Remote Loopback 0 Interface

P1

10.1.1.9/32

P2

10.2.2.9/32

P3

10.3.3.9/32

P4

10.4.4.9/32

P5

10.5.5.9/32

P6

10.6.6.9/32

PE1

10.7.7.9/32

PE2

10.8.8.9/32

PE3

10.9.9.9/32

PE4

10.10.10.9/32

RR

10.11.11.9/32

-

-

Table 10-35  BGP parameter Value

BGP Parameter

Value

AS number

65000

Router ID

Same as the address of Loopback 0 interface

BGP community attribute

Plane A: 65000:100

Plane B: 65000:200

BGP local preference

Plane A: The local preference of community attribute 65000:100 is set to 200.

Plane B: The local preference of community attribute 65000:200 is set to 200.

NOTE:
By default, the BGP local preference is 100. The greater the value, the higher the preference.

Routing policy name

Route import policy: local_pre

Route export policy: comm

Community filter name

1

BGP peer group name

Client

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure different RDs for two PEs in the same site to ensure that each PE can receive two routes from different BGP next hops in the remote site. When two PEs in a site advertise the routes to the same destination, configuring different RDs for the two PEs can ensure that BGP peers consider the advertised routes as two different routes. This is because BGP-VPNv4 uses the VPNv4 addresses that consist of IPv4 addresses and RDs.
  2. Assign different communities for BGP routes from PE in plane A and BGP routes from PE in plane B.
  3. Set different local preferences for routes based on the community attributes of the routes. In this manner, the PEs in plane A choose the routes advertised by remote PEs in plane A, and the PEs in plane B always choose the routes advertised by the remote PEs in plane B.

Procedure

  1. Configure names for devices and IP addresses for interfaces.

    For detailed configurations, see the configuration files of this example.

  2. Configure an IGP.

    In this example, IS-IS is used as an IGP. For detailed configurations, see the configuration files of this example.

    After the configuration, run the display ip routing-table command. You can view that PEs, Ps and PEs, and Ps have learned the addresses of Loopback 0 interfaces from each other.

  3. Establish MP-IBGP connections between the PEs and RR.

    # Take the configuration of PE1 as an example. Configurations of other PEs are similar to that of PE1, and are not mentioned here.

    [PE1] bgp 65000
    [PE1-bgp] peer 10.11.11.9 as-number 65000
    [PE1-bgp] peer 10.11.11.9 connect-interface LoopBack0
    [PE1-bgp] ipv4-family unicast
    [PE1-bgp-af-ipv4] undo peer 10.11.11.9 enable
    [PE1-bgp-af-ipv4] quit
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 10.11.11.9 enable

    # Configure the RR.

    [RR] bgp 65000
    [RR-bgp] group client internal
    [RR-bgp] peer client connect-interface LoopBack0
    [RR-bgp] ipv4-family unicast
    [RR-bgp-af-ipv4] undo peer client enable
    [RR-bgp-af-ipv4] quit
    [RR-bgp] ipv4-family vpnv4
    [RR-bgp-af-vpnv4] undo policy vpn-target
    [RR-bgp-af-vpnv4] peer client enable
    [RR-bgp-af-vpnv4] peer 10.7.7.9 group client
    [RR-bgp-af-vpnv4] peer 10.8.8.9 group client
    [RR-bgp-af-vpnv4] peer 10.9.9.9 group client
    [RR-bgp-af-vpnv4] peer 10.10.10.9 group client
    [RR-bgp-af-vpnv4] peer client reflect-client
    
    NOTE:
    You need to run the undo policy vpn-target command in the BGP-VPNv4 address family view of the RR to ensure that VPN-target-based filtering is not performed on VPNv4 routes. By default, an RR performs VPN-target-based filtering on the received VPNv4 routes. The matching routes are added to the VPN routing table, and the other routes are discarded. In this example, VPN instances are not configured on the RR. As a result, if VPN-target-based filtering is enabled, all the received VPNv4 routes will be discarded.

    After the configuration, run the display bgp vpnv4 all peer command on the RR. You can view that the RR sets up MP-IBGP peers with all PEs.

    [RR] display bgp vpnv4 all peer
     BGP local router ID : 10.11.11.9
     Local AS number : 65000
     Total number of peers : 4                 Peers in established state : 4
      Peer          V    AS     MsgRcvd  MsgSent  OutQ  Up/Down       State       PrefRcv
      10.7.7.9       4    65000  79      82        0     00:01:31      Established      0
      10.8.8.9       4    65000  42      66        0     00:01:16      Established      0
      10.9.9.9       4    65000  21      34        0     00:00:50      Established      0
      10.10.10.9     4    65000  2        4        0     00:00:21      Established      0
    

  4. Configure a routing policy.

    NOTE:
    Take the configurations of PE1, PE2, and the RR as an example. The configurations of PE3 and PE4 are similar to the configurations of PE1 and PE2 respectively, and are not mentioned here.

    # Configure a routing policy on PE1 so that the BGP VPNv4 route advertised by PE1 can carry community attribute 65000:100.

    [PE1] route-policy comm permit node 10
    [PE1-route-policy] apply community 65000:100

    # Configure the routing policy on PE2 so that the BGP VPNv4 route advertised by PE2 can carry community attribute 65000:200.

    [PE2] route-policy comm permit node 10
    [PE2-route-policy] apply community 65000:200

    # On PE1, apply the routing policy to the BGP VPNv4 route advertised by PE1 to the RR so that the route can carry the community attribute.

    [PE1] bgp 65000
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 10.11.11.9 route-policy comm export
    [PE1-bgp-af-vpnv4] peer 10.11.11.9 advertise-community

    # On PE2, apply the routing policy to the advertised BGP VPNv4 route advertised by PE2 to the RR so that the route can carry the community attribute.

    [PE2] bgp 65000
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 10.11.11.9 route-policy comm export
    [PE2-bgp-af-vpnv4] peer 10.11.11.9 advertise-community

    # Configure the RR to advertise the community attribute to the PEs.

    [RR] bgp 65000
    [RR-bgp] ipv4-family vpnv4
    [RR-bgp-af-vpnv4] peer client advertise-community
    

    # Configure the community attribute filter on PE1.

    [PE1] ip community-filter 1 permit 65000:100

    # Configure the community attribute filter on PE2.

    [PE2] ip community-filter 1 permit 65000:200

    # On PE1, configure a routing policy and set the local preference of the route with community attribute 65000:100 to 200.

    [PE1] route-policy local_pre permit node 10
    [PE1-route-policy] if-match community-filter 1
    [PE1-route-policy] apply local-preference 200
    [PE1-route-policy] quit
    

    # On PE2, configure a routing policy and set the local preference of the route with community attribute 65000:200 to 200.

    [PE2] route-policy local_pre permit node 10
    [PE2-route-policy] if-match community-filter 1
    [PE2-route-policy] apply local-preference 200
    [PE2-route-policy] quit

    # On PE1, apply the routing policy to the imported BGP VPNv4 route so that the PE1 chooses the route advertised by the remote PEs in plane A.

    [PE1] bgp 65000
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 10.11.11.9 route-policy local_pre import

    # On PE2, apply the routing policy to the imported BGP VPNv4 route so that the PE2 chooses the route advertised by the remote PEs in plane B.

    [PE2] bgp 65000
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 10.11.11.9 route-policy local_pre import
    NOTE:
    After this configuration, you also need to configure MPLS, establish tunnels, configure MPLS L3VPN, and configure PEs to access CEs. For detailed configurations, see the configuration files of this example.

  5. Verify the configuration.

    Run the display bgp vpnv4 all routing-table community command on a PE. You can view information about the VPNv4 routes with community attributes. Take the display on PE1 and PE2 as an example.

    [PE1] display bgp vpnv4 all routing-table community
    
    
     BGP Local router ID is 10.7.7.9
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
    
     Total Number of Routes from all PE: 2
     Route Distinguisher: 65000:10001012
    
    
           Network        NextHop        MED        LocPrf    PrefVal  Community
    
    *>   10.22.1.0/24     10.9.9.9         0           200             65000:100
    *                     10.10.10.9       0           100             65000:200
    
     VPN-Instance NGN_Media, router ID 10.7.7.9:
    
     Total Number of Routes: 2
          Network         NextHop        MED        LocPrf    PrefVal  Community
    
     *>i  10.22.1.0/24    10.9.9.9         0           200       0     65000:100
    *                     10.10.10.9       0           100       0     65000:200
    
    [PE2] display bgp vpnv4 all routing-table community
    
    
     BGP Local router ID is 10.8.8.9
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
    
     Total Number of Routes from all PE: 2
     Route Distinguisher: 65000:10001011
    
     Route Distinguisher: 65000:10001011
           Network        NextHop        MED        LocPrf    PrefVal  Community
    
    *>   10.22.1.0/24     10.10.10.9       0          200              65000:200
    *                     10.9.9.9         0          100              65000:100
    
     VPN-Instance NGN_Media, router ID 10.7.7.9:
    
     Total Number of Routes: 2
     Total routes of vpn-instance NGN_Media: 2
          Network         NextHop        MED        LocPrf    PrefVal  Community
    
     *>i  10.22.1.0/24    10.10.10.9       0         200        0      65000:200
    *                     10.9.9.9         0         100        0      65000:100

    Run the display ip routing-table vpn-instance NGN_Media 10.22.1.0 24 command on PE1, and you can find that the next hop of route 10.22.1.0/24 is PE3. That is, PE1 chooses the route advertised by PE3.

    [PE1] display ip routing-table vpn-instance NGN_Media 10.22.1.0 24
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table: NGN_Media
    Summary Count: 1
    Destination/Mask  Proto  Pre  Cost  Flags  NextHop   Interface
       10.22.1.0/24   IBGP    255  0      RD   10.9.9.9  Vlanif50

Configuration Files

  • P1 configuration file

    #
    sysname P1
    #
    vlan batch 10 20 30 40 50
    #
    mpls lsr-id 10.1.1.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0100.1009.00
    #
    interface Vlanif10
     description toP3Vlanif10
     ip address 10.1.1.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif20
     description toP5Vlanif20
     ip address 10.1.2.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif30
     description toRRVlanif30
     ip address 10.1.3.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif40
     description toP2Vlanif40
     ip address 10.1.4.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif50
     description toP1Vlanif50
     ip address 10.1.5.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    interface GigabitEthernet5/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface LoopBack0
     ip address 10.1.1.9 255.255.255.255
     isis enable 64
    #
    return
  • P2 configuration file

    #
    sysname P2
    #
    vlan batch 40 60 70 80 90
    #
    mpls lsr-id 10.2.2.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0200.2009.00
    #
    interface Vlanif40
     description toP1Vlanif40
     ip address 10.1.4.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif60
     description toRRVlanif60
     ip address 10.1.8.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif70
     description toP4Vlanif70
     ip address 10.1.7.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif80
     description toP6Vlanif80
     ip address 10.1.6.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif90
     description toPE2Vlanif90
     ip address 10.1.9.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 70 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 80 
    #
    interface GigabitEthernet5/0/0
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface LoopBack0
     ip address 10.2.2.9 255.255.255.255
     isis enable 64
    #
    return
  • P3 configuration file

    #
    sysname P3
    #
    vlan batch 10 110 120 130
    #
    mpls lsr-id 10.3.3.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0300.3009.00
    #
    interface Vlanif10
     description toP1Vlanif10
     ip address 10.1.1.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif110
     description toP5Vlanif110
     ip address 10.1.10.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif120
     description toP4Vlanif120
     ip address 10.1.11.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif130
     description toPE3Vlanif130
     ip address 10.1.12.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 110 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 120 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 130
    #
    interface LoopBack0
     ip address 10.3.3.9 255.255.255.255
     isis enable 64
    #
    return
  • P4 configuration file

    #
    sysname P4
    #
    vlan batch 70 120 150 160
    #
    mpls lsr-id 10.4.4.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0400.4009.00
    #
    interface Vlanif70
     description toP2Vlanif70
     ip address 10.1.7.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif120
     description toP3Vlanif120
     ip address 10.1.11.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif150
     description toP6Vlanif150
     ip address 10.1.13.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif160
     description toPE4Vlanif160
     ip address 10.1.14.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 70 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 120 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 150 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 160 
    #
    interface LoopBack0
     ip address 10.4.4.9 255.255.255.255
     isis enable 64
    #
    return
  • P5 configuration file

    #
    sysname P5
    #
    vlan batch 20 110 170
    #
    mpls lsr-id 10.5.5.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0500.5009.00
    #
    interface Vlanif20
     description toP1Vlanif20
     ip address 10.1.2.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif110
     description toP3Vlanif110
     ip address 10.1.10.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif170
     description toP6Vlanif170
     ip address 10.1.15.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 110 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 170 
    #
    interface LoopBack0
     ip address 10.5.5.9 255.255.255.255
     isis enable 64
    #
    return
  • P6 configuration file

    #
    sysname P6
    #
    vlan batch 80 150 170
    #
    mpls lsr-id 10.6.6.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0600.6009.00
    #
    interface Vlanif80
     description toP2Vlanif80
     ip address 10.1.6.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif150
     description toP4Vlanif150
     ip address 10.1.13.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif170
     description toP5Vlanif170
     ip address 10.1.15.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 80 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 170 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 150 
    #
    interface LoopBack0
     ip address 10.6.6.9 255.255.255.255
     isis enable 64
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 50 100
    #
    ip vpn-instance NGN_Media
     ipv4-family
     route-distinguisher 65000:10001012
     apply-label per-instance
     vpn-target 65000:100 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Other
     ipv4-family
     route-distinguisher 65000:30001012
     apply-label per-instance
     vpn-target 65000:300 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Signaling
     ipv4-family
     route-distinguisher 65000:20001012
     apply-label per-instance
     vpn-target 65000:200 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    mpls lsr-id 10.7.7.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0700.7009.00
    #
    interface Vlanif50
     description toP1Vlanif50
     ip address 10.1.5.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif100
     description toPE2Vlanif100
     ip address 10.1.16.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet3/0/0
    #
    interface GigabitEthernet3/0/0.10
     dot1q termination vid 180
     ip binding vpn-instance NGN_Media
     ip address 10.21.1.73 255.255.255.252
    #
    interface GigabitEthernet3/0/0.11
     dot1q termination vid 190
      ip binding vpn-instance NGN_Signaling
     ip address 10.21.1.77 255.255.255.252
    #
    interface GigabitEthernet3/0/0.12
     dot1q termination vid 200
     ip binding vpn-instance NGN_Other
     ip address 10.21.1.81 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100 
    #
    interface LoopBack0
     ip address 10.7.7.9 255.255.255.255
     isis enable 64
    #
    bgp 65000
     peer 10.11.11.9 as-number 65000
     peer 10.11.11.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      undo peer 10.11.11.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 10.11.11.9 enable
      peer 10.11.11.9 route-policy local_pre import
      peer 10.11.11.9 route-policy comm export
      peer 10.11.11.9 advertise-community
     #
     ipv4-family vpn-instance NGN_Media
      aggregate 10.21.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Other
      aggregate 10.21.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Signaling
      aggregate 10.21.1.0 255.255.255.0 detail-suppressed
      import-route direct
    #
    route-policy comm permit node 10
     apply community 65000:100
    #
    route-policy local_pre permit node 10
     if-match community-filter 1
     apply local-preference 200
    #
     ip community-filter 1 permit 65000:100
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 90 100
    #
    ip vpn-instance NGN_Media
     ipv4-family
     route-distinguisher 65000:10001011
     apply-label per-instance
     vpn-target 65000:100 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Other
     ipv4-family
     route-distinguisher 65000:30001011
     apply-label per-instance
     vpn-target 65000:300 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Signaling
     ipv4-family
     route-distinguisher 65000:20001011
     apply-label per-instance
     vpn-target 65000:200 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    mpls lsr-id 10.8.8.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0800.8009.00
    #
    interface Vlanif90
     description toP2Vlanif90
     ip address 10.1.9.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif100
     description toPE1Vlanif100
     ip address 10.1.16.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet3/0/0
    #
    interface GigabitEthernet3/0/0.10
     dot1q termination vid 210
     ip binding vpn-instance NGN_Media
     ip address 10.21.1.13 255.255.255.252
    #
    interface GigabitEthernet3/0/0.11
     dot1q termination vid 220
     ip binding vpn-instance NGN_Signaling
     ip address 10.21.1.17 255.255.255.252
    #
    interface GigabitEthernet3/0/0.12
     dot1q termination vid 230
     ip binding vpn-instance NGN_Other
     ip address 10.21.1.21 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 90 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100 
    #
    interface LoopBack0
     ip address 10.8.8.9 255.255.255.255
     isis enable 64
    #
    bgp 65000
     peer 10.11.11.9 as-number 65000
     peer 10.11.11.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      undo peer 10.11.11.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 10.11.11.9 enable
      peer 10.11.11.9 route-policy local_pre import
      peer 10.11.11.9 route-policy comm export
      peer 10.11.11.9 advertise-community
     #
     ipv4-family vpn-instance NGN_Media
      aggregate 10.21.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Other
      aggregate 10.21.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Signaling
      aggregate 10.21.1.0 255.255.255.0 detail-suppressed
      import-route direct
    #
    route-policy comm permit node 10
     apply community 65000:200
    #
    route-policy local_pre permit node 10
     if-match community-filter 1
     apply local-preference 200
    #
     ip community-filter 1 permit 65000:200
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    vlan batch 130 140
    #
    ip vpn-instance NGN_Media
     ipv4-family
     route-distinguisher 65000:10000811
     apply-label per-instance
     vpn-target 65000:100 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Other
     ipv4-family
     route-distinguisher 65000:30000811
     apply-label per-instance
     vpn-target 65000:300 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Signaling
     ipv4-family
     route-distinguisher 65000:20000811
     apply-label per-instance
     vpn-target 65000:200 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    mpls lsr-id 10.9.9.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.0900.9009.00
    #
    interface Vlanif130
     description toP3Vlanif130
     ip address 10.1.12.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif140
     description toPE4Vlanif140
     ip address 10.1.17.1 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet3/0/0
    #
    interface GigabitEthernet3/0/0.10
     dot1q termination vid 240
     ip binding vpn-instance NGN_Media
     ip address 10.22.1.73 255.255.255.252
    #
    interface GigabitEthernet3/0/0.11
     dot1q termination vid 250
     ip binding vpn-instance NGN_Signaling
     ip address 10.22.1.77 255.255.255.252
    #
    interface GigabitEthernet3/0/0.12
     dot1q termination vid 260
     ip binding vpn-instance NGN_Other
     ip address 10.22.1.81 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 130 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 140 
    #
    interface LoopBack0
     ip address 10.9.9.9 255.255.255.255
     isis enable 64
    #
    bgp 65000
     peer 10.11.11.9 as-number 65000
     peer 10.11.11.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      undo peer 10.11.11.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 10.11.11.9 enable
      peer 10.11.11.9 route-policy local_pre import
      peer 10.11.11.9 route-policy comm export
      peer 10.11.11.9 advertise-community
     #
     ipv4-family vpn-instance NGN_Media
      aggregate 10.22.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Other
      aggregate 10.22.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Signaling
      aggregate 10.22.1.0 255.255.255.0 detail-suppressed
      import-route direct
    #
    route-policy comm permit node 10
     apply community 65000:100
    #
    route-policy local_pre permit node 10
     if-match community-filter 1
     apply local-preference 200
    #
    route-policy local_pre permit node 20
    #
     ip community-filter 1 permit 65000:100
    #
    return
  • PE4 configuration file

    #
    sysname PE4
    #
    vlan batch 140 160
    #
    ip vpn-instance NGN_Media
     ipv4-family
     route-distinguisher 65000:10000712
     apply-label per-instance
     vpn-target 65000:100 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Other
     ipv4-family
     route-distinguisher 65000:30000712
     apply-label per-instance
     vpn-target 65000:300 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    ip vpn-instance NGN_Signaling
     ipv4-family
     route-distinguisher 65000:20000712
     apply-label per-instance
     vpn-target 65000:200 export-extcommunity
     vpn-target 65000:100 65000:200 65000:300 import-extcommunity
    #
    mpls lsr-id 10.10.10.9
    mpls
    #
    mpls ldp
    #
    isis 64
     network-entity 49.0091.0100.1001.0009.00
    #
    interface Vlanif140
     description toPE3Vlanif140
     ip address 10.1.17.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface Vlanif160
     description toP4Vlanif160
     ip address 10.1.14.2 255.255.255.252
     isis enable 64
     mpls
     mpls ldp
    #
    interface GigabitEthernet3/0/0
    #
    interface GigabitEthernet3/0/0.10
     dot1q termination vid 270
     ip binding vpn-instance NGN_Media
     ip address 10.22.1.13 255.255.255.252
    #
    interface GigabitEthernet3/0/0.11
     dot1q termination vid 280
     ip binding vpn-instance NGN_Signaling
     ip address 10.22.1.17 255.255.255.252
    #
    interface GigabitEthernet3/0/0.12
     dot1q termination vid 290
     ip binding vpn-instance NGN_Other
     ip address 10.22.1.21 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 160 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 140 
    #
    interface LoopBack0
     ip address 10.10.10.9 255.255.255.255
     isis enable 64
    #
    bgp 65000
     peer 10.11.11.9 as-number 65000
     peer 10.11.11.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      undo peer 10.11.11.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 10.11.11.9 enable
      peer 10.11.11.9 route-policy local_pre import
      peer 10.11.11.9 route-policy comm export
      peer 10.11.11.9 advertise-community
     #
     ipv4-family vpn-instance NGN_Media
      aggregate 10.22.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Other
      aggregate 10.22.1.0 255.255.255.0 detail-suppressed
      import-route direct
     #
     ipv4-family vpn-instance NGN_Signaling
      aggregate 10.22.1.0 255.255.255.0 detail-suppressed
      import-route direct
    #
    route-policy comm permit node 10
     apply community 65000:200
    #
    route-policy local_pre permit node 10
     if-match community-filter 1
     apply local-preference 200
    #
     ip community-filter 1 permit 65000:200
    #
    return
  • RR configuration file

    #
    sysname RR
    #
    vlan batch 30 60
    #
    isis 64
     network-entity 49.0091.0100.1101.1009.00
    #
    interface Vlanif30
     description toP1Vlanif30
     ip address 10.1.3.2 255.255.255.252
     isis enable 64
    #
    interface Vlanif60
     description toP2Vlanif60
     ip address 10.1.8.2 255.255.255.252
     isis enable 64
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    interface LoopBack0
     ip address 10.11.11.9 255.255.255.255
     isis enable 64
    #
    bgp 65000
     group client internal
     peer client connect-interface LoopBack0
     peer 10.7.7.9 as-number 65000
     peer 10.8.8.9 as-number 65000
     peer 10.9.9.9 as-number 65000
     peer 10.10.10.9 as-number 65000
     #
     ipv4-family unicast
      undo synchronization
      undo peer client enable
      undo peer 10.7.7.9 enable
      undo peer 10.8.8.9 enable
      undo peer 10.9.9.9 enable
      undo peer 10.10.10.9 enable
     #
     ipv4-family vpnv4
      undo policy vpn-target
      peer client enable
      peer client reflect-client
      peer client advertise-community
      peer 10.7.7.9 enable
      peer 10.7.7.9 group client
      peer 10.8.8.9 enable
      peer 10.8.8.9 group client
      peer 10.9.9.9 enable
      peer 10.9.9.9 group client
      peer 10.10.10.9 enable
      peer 10.10.10.9 group client
    #
    return
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178171

Views: 330925

Downloads: 1146

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next