No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic BGP Functions

Example for Configuring Basic BGP Functions

Networking Requirements

As shown in Figure 9-26, BGP runs between Routers; an EBGP connection is established between Router A and Router B; IBGP full-mesh connections are established between Router B, Router C, and Router D.

Figure 9-26 Networking diagram of configuring basic BGP functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IBGP connections between Router B, Router C, and Router D.
  2. Configure an EBGP connection between Router A and Router B.

Procedure

  1. Configure an IP address for each interface.

    # Configure Router A.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 8.1.1.1 8
    [RouterA-GigabitEthernet1/0/0] quit

    The configurations of Router B, Router C, and Router D are similar to the configuration of Router A, and are not mentioned here.

  2. Configure IBGP connections.

    # Configure Router B.

    [RouterB] bgp 65009
    [RouterB-bgp] router-id 2.2.2.2
    [RouterB-bgp] peer 9.1.1.2 as-number 65009
    [RouterB-bgp] peer 9.1.3.2 as-number 65009

    # Configure Router C.

    [RouterC] bgp 65009
    [RouterC-bgp] router-id 3.3.3.3
    [RouterC-bgp] peer 9.1.3.1 as-number 65009
    [RouterC-bgp] peer 9.1.2.2 as-number 65009
    [RouterC-bgp] quit

    # Configure Router D.

    [RouterD] bgp 65009
    [RouterD-bgp] router-id 4.4.4.4
    [RouterD-bgp] peer 9.1.1.1 as-number 65009
    [RouterD-bgp] peer 9.1.2.1 as-number 65009
    [RouterD-bgp] quit

  3. Configure an EBGP connection.

    # Configure Router A.

    [RouterA] bgp 65008
    [RouterA-bgp] router-id 1.1.1.1
    [RouterA-bgp] peer 200.1.1.1 as-number 65009

    # Configure Router B.

    [RouterB-bgp] peer 200.1.1.2 as-number 65008

    # View the status of BGP peers.

    [RouterB-bgp] display bgp peer
    
    
     BGP local router ID : 2.2.2.2
     Local AS number : 65009
     Total number of peers : 3                 Peers in established state : 3
    
    
      Peer          V    AS  MsgRcvd  MsgSent  OutQ  Up/Down         State PrefRcv
    
    
      9.1.1.2       4 65009       49       62     0 00:44:58 Established       0
      9.1.3.2       4 65009       56       56     0 00:40:54 Established       0
      200.1.1.2     4 65008       49       65     0 00:44:03 Established       1

    The preceding command output shows that BGP connections have been established between Router B and other Routers.

  4. Configure Router A to advertise route 8.0.0.0/8.

    # Configure Router A to advertise a route.

    [RouterA-bgp] ipv4-family unicast
    [RouterA-bgp-af-ipv4] network 8.0.0.0 255.0.0.0
    [RouterA-bgp-af-ipv4] quit

    # View the routing table of Router A.

    [RouterA-bgp] display bgp routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     Total Number of Routes: 1
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   8.0.0.0        0.0.0.0            0                     0      i
    

    # View the routing table of Router B.

    [RouterB-bgp] display bgp routing-table
     BGP Local router ID is 2.2.2.2
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     Total Number of Routes: 1
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   8.0.0.0        200.1.1.2          0                     0      65008i
    

    # View the routing table of Router C.

    [RouterC] display bgp routing-table
     BGP Local router ID is 3.3.3.3
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     Total Number of Routes: 1
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
       i  8.0.0.0        200.1.1.2          0          100        0      65008i
    
    NOTE:

    The preceding command output shows that Router C has learned the route to destination 8.0.0.0 in AS 65008. The route, however, is invalid because the next hop 200.1.1.2 of this route is unreachable.

  5. Configure BGP to import direct routes.

    # Configure Router B.

    [RouterB-bgp] ipv4-family unicast
    [RouterB-bgp-af-ipv4] import-route direct

    # View the BGP routing table of Router A.

    [RouterA-bgp] display bgp routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     Total Number of Routes: 4
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   8.0.0.0            0.0.0.0         0                     0      i
     *>   9.1.1.0/24         200.1.1.1       0                     0      65009?
     *>   9.1.3.0/24         200.1.1.1       0                     0      65009?
          200.1.1.0          200.1.1.1       0                     0      65009?
     

    # View the BGP routing table of Router C.

    [RouterC] display bgp routing-table
     BGP Local router ID is 3.3.3.3
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     Total Number of Routes: 4
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>i  8.0.0.0          200.1.1.2       0          100        0      65008i
     *>i  9.1.1.0/24         9.1.3.1         0          100        0      ?
       i  9.1.3.0/24         9.1.3.1         0          100        0      ?
     *>i  200.1.1.0          9.1.3.1         0          100        0      ?
    

    The preceding command output shows that the route to destination 8.0.0.0 becomes valid because the next-hop address of this route is the address of Router A.

    # Run the ping command on Router C.

    [RouterC] ping 8.1.1.1
      PING 8.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 8.1.1.1: bytes=56 Sequence=1 ttl=254 time=31 ms
        Reply from 8.1.1.1: bytes=56 Sequence=2 ttl=254 time=47 ms
        Reply from 8.1.1.1: bytes=56 Sequence=3 ttl=254 time=31 ms
        Reply from 8.1.1.1: bytes=56 Sequence=4 ttl=254 time=16 ms
        Reply from 8.1.1.1: bytes=56 Sequence=5 ttl=254 time=31 ms
    
    
      --- 8.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/31/47 ms

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 8.1.1.1 255.0.0.0
    #
    interface GigabitEthernet2/0/0
     ip address 200.1.1.2 255.255.255.0
    #
    bgp 65008
     router-id 1.1.1.1
     peer 200.1.1.1 as-number 65009
     #
     ipv4-family unicast
      undo synchronization
      network 8.0.0.0
      peer 200.1.1.1 enable
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 9.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 200.1.1.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 9.1.3.1 255.255.255.0
    #
    bgp 65009
     router-id 2.2.2.2
     peer 9.1.1.2 as-number 65009
     peer 9.1.3.2 as-number 65009
     peer 200.1.1.2 as-number 65008
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 9.1.1.2 enable
      peer 9.1.3.2 enable 
      peer 200.1.1.2 enable
    #
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
    interface GigabitEthernet2/0/0
     ip address 9.1.2.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 9.1.3.2 255.255.255.0
    #
    bgp 65009
     router-id 3.3.3.3
     peer 9.1.2.2 as-number 65009
     peer 9.1.3.1 as-number 65009
     #
     ipv4-family unicast
      undo synchronization
      peer 9.1.2.2 enable
      peer 9.1.3.1 enable
    #
    return
  • Configuration file of Router D

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
     ip address 9.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 9.1.2.2 255.255.255.0
    #
    bgp 65009
     router-id 4.4.4.4
     peer 9.1.1.1 as-number 65009
     peer 9.1.2.1 as-number 65009
     #
     ipv4-family unicast
      undo synchronization
      peer 9.1.1.1 enable
      peer 9.1.2.1 enable
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034072

Views: 110781

Downloads: 163

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next